15:01:12 <adetalhouet> #startmeeting NIC
15:01:12 <odl_meetbot> Meeting started Fri Sep  4 15:01:12 2015 UTC.  The chair is adetalhouet. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:12 <odl_meetbot> The meeting name has been set to 'nic'
15:01:34 <odl_meetbot> raphaelamorim_: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
15:01:55 <adetalhouet> #chair raphaelamorim
15:01:55 <odl_meetbot> Current chairs: adetalhouet raphaelamorim
15:02:39 <gzhao> #info gzhao
15:02:47 <adetalhouet> #topic M2 Status / Release Planning
15:03:18 <adetalhouet> #info Initial planning is done
15:03:34 <adetalhouet> #info Now we have 2 millstones to accomplish the features
15:05:12 <raphaelamorim_> #link https://lists.opendaylight.org/pipermail/nic-dev/2015-September/000878.html
15:06:29 <adetalhouet> #link release plan https://wiki.opendaylight.org/view/NIC:Beryllium:Release_Plan
15:07:41 <renato_aguiar> #info renato_aguiar
15:09:53 <adetalhouet> #topic Community goals for NIC
15:12:01 <adetalhouet> #info reviewing the trello board
15:12:13 <adetalhouet> #info OF Renderer is almost done, a few review to address
15:13:35 <adetalhouet> #info Lot of items in the backlogs, please pick one and start working on it :)
15:14:55 <adetalhouet> #info dlenrow added 2 proposed goals on the Main page
15:16:20 <adetalhouet> #info dlenrow hope we can plan work on those 2 goals
15:16:49 <adetalhouet> #info Are we agree with the proposed goals?
15:17:07 <adetalhouet> #info 1st goal: Solve the problem of resource contention between disparate ODL apps/services
15:18:10 <adetalhouet> #info mlemay asking how it does fit with the extension of OFP, ...
15:18:42 <adetalhouet> #action mlemay to send thread on discussions around this
15:19:17 <adetalhouet> #info Should we solve multiple writer in NIC?
15:19:26 <adetalhouet> #info mlemay say it might be an issue
15:20:33 <adetalhouet> #info Let's have a conversation around the layers where the conflict could happen
15:22:12 <adetalhouet> #info dlenrow says NIC is the common arbitration layer
15:22:51 <adetalhouet> #info  2nd goal: Provide a controller based, performant, easy to deploy
15:23:08 <adetalhouet> #info make the netvirt implementation coexist
15:23:21 <adetalhouet> #undo
15:23:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18d7c10>
15:23:34 <adetalhouet> #info make the netvirt implementation coexist between the various SDN services
15:24:54 <adetalhouet> #info dlenrow would like NIC to do what NN does conceptually to handle better OpenStack
15:25:11 <helenchen> #info colindixon said, "I think that no matter how much we feel like everyone should go through NIC, there will be people who don't and they *will* solve their conflicts in some way at a lower layer."
15:25:22 <colindixon> helenchen: thanks
15:25:41 <helenchen> colindixon: you are welcome
15:26:55 <adetalhouet> #info mlemay mentioned that there is a lot of discussion around rewriting the plugin for OpenStack
15:27:45 <adetalhouet> #info gzhao asks if we're going to maintain Boulder?
15:28:00 <adetalhouet> #info dlenrow says it's a use case the world would be really interested in
15:28:37 <adetalhouet> #info raphaelamorim says that this is one of the BE deliverable
15:29:02 <adetalhouet> #info we need folks to invest time in its implementation
15:29:59 <adetalhouet> #info Boulder could help to make people being engaged in ODL-NIC
15:30:17 <colindixon> I’m still following here, but had to drop off webex
15:30:21 <adetalhouet> #info mlemay says that Boulder allow you to script the Intent
15:30:45 <adetalhouet> #info mlemay  says Boulder is a scripting layer on top of NIC
15:31:19 <dlenrow> Colin: Thats the comment about "including services that are not cooperation aware". Have some ideas... Should discuss. TWS call? Add a nic call?
15:31:52 <colindixon> dlenrow: I’m happy to talk whenever, I think there’s a plan ot have another meeting on Thursday at 7/10a pacific/eastern
15:31:58 <adetalhouet> #info raphaelamorim this allow for SDN controller to have a common NB interface
15:32:04 <adetalhouet> #undo
15:32:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d33bd0>
15:32:10 <adetalhouet> #info raphaelamorim says this allow for SDN controller to have a common NB interface
15:33:43 <adetalhouet> #action start the discussion on the ML
15:34:44 <adetalhouet> #info raphaelamorim says the 2 goals presented by dlenrow are in accordance with the current release planning
15:35:26 <adetalhouet> #info dlenrow saying those 2 goals are the based principle of the NIC projects, and this is normal to address them
15:35:36 <adetalhouet> #undo
15:35:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d33a90>
15:35:51 <adetalhouet> #info dlenrow says those 2 goals are the based principles of NIC project, and this is normal to address them
15:36:25 <adetalhouet> #info raphaelamorim says that even in the Neutron community, they are ready to discuss about skipping the NB interface and going directly into MD-SAL
15:38:19 <adetalhouet> #action raphaelamorim to provide pointers about that
15:39:09 <adetalhouet> #info gvrangan_ says this is pretty much abstract and would like us to discuss around this
15:39:27 <adetalhouet> #info dlenrow says that we will discuss the design as a community
15:40:49 <adetalhouet> #info raphaelamorim mentioned that there are also bunch of stuff that need to be done to maintain the Intent, how they are manage, resolve, ..
15:41:46 <adetalhouet> #info raphaelamorim says that it would be nice to have tasks that add value to both NIC and surrounding project
15:42:07 <adetalhouet> #info raphaelamorim referring to the 2nd goals
15:44:11 <adetalhouet> #info raphaelamorim present the sample renderer: it's aims it to make folks who want to create their renderer to have an exemple to start with
15:44:18 <adetalhouet> #undo
15:44:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d33050>
15:44:32 <adetalhouet> #info raphaelamorim presents the sample renderer: it aims it to make folks who want to create their renderer to have an exemple to start with
15:44:45 <adetalhouet> #info raphaelamorim says this won't be part of the features
15:44:49 <adetalhouet> #undo
15:44:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d33550>
15:44:53 <adetalhouet> #info raphaelamorim says this won't be part of the  NIC features
15:45:53 <adetalhouet> #info it's a really open/abstract implementation
15:46:22 <adetalhouet> #info An H asks if renderer should resides in NIC or outside NIC
15:46:32 <adetalhouet> #info raphaelamorim says all renderer should be in NIC
15:47:55 <adetalhouet> #info dlenrow takes a concrete exemple with Netvirt: we don't want to build a new one, we want to leverage the one from the OVSDB project
15:48:54 <adetalhouet> #info dlenrow asks if we should have another meeting the discuss issues around bringing NN and OVSDB into NIC
15:49:18 <adetalhouet> #info raphaelamorim says it's a good idea
15:50:07 <adetalhouet> #action dlenrow to send a mail to the list
15:50:25 <adetalhouet> #topic cookies
15:50:30 <adetalhouet> #endmeeting