16:09:29 <tbachman> #startmeeting nic_weekly
16:09:29 <odl_meetbot> Meeting started Fri Feb  6 16:09:29 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:09:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:09:29 <odl_meetbot> The meeting name has been set to 'nic_weekly'
16:09:31 <tbachman> #chair ShaunWackerly
16:09:31 <odl_meetbot> Current chairs: ShaunWackerly tbachman
16:09:37 <tbachman> #chair devond
16:09:37 <odl_meetbot> Current chairs: ShaunWackerly devond tbachman
16:09:59 <tbachman> #topic project culter
16:10:03 <dbainbri> #info dbainbri
16:10:15 <tbachman> #info project culter is to use Trello for managing and trakcing tasks
16:10:20 <tbachman> #undo
16:10:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19aca50>
16:10:30 <tbachman> #info project culture is to use Trello for managing and tracking tasks
16:10:38 <phrobb> tbachman:  rocks
16:10:39 * tbachman is in a coffe shop atm, so sometimes has trouble hearing
16:10:41 <gzhao> no roll call?
16:10:42 <ShaunWackerly> Thank you, tbachman!
16:10:49 <tbachman> phrobb: I just type ;)
16:11:09 <phrobb> yea, yea, yea, don't be humble tbachman
16:11:17 <ShaunWackerly> Is it common practice to #info into the meeting at the start?
16:11:35 <tbachman> #topic Project Release Plane
16:11:39 <gzhao> ShaunWackerly: I think so
16:11:51 <tbachman> #info devond says we need to elect the project lead
16:12:01 <tbachman> #info devond asks if this is the right time to call for the election
16:12:13 <tbachman> #info dbainbri says we should do it on the mailing list
16:12:21 <tbachman> #info phrobb says to send mail asking for self-nominations
16:12:30 <tbachman> devond: make sure you set time frames for these
16:12:45 <tbachman> #info phrobb  says the condorcet web site is used for the election process
16:12:53 <tbachman> #info devond is the project contact
16:13:00 <phrobb> #action devond to send mail for self nominations
16:13:06 <tbachman> phrobb: thx!
16:13:15 <tbachman> #info devond asks how to approach the test contact
16:13:43 <tbachman> #info hideyuki says there’s not official process to elect a test contact
16:13:58 <tbachman> #info phrobb says the only elected position is the project lead; everything else is by appointment by the project
16:14:21 <tbachman> #info phrobb says the test and doc contacts work with the respective teams in ODL (e.g. integration and docs)
16:14:34 <ShaunWackerly> phrobb: thanks for that clarification
16:15:11 <tbachman> #action devond to work with Project Lead, once elected, to get test and doc contacts
16:15:53 <tbachman> #info gzhao asks about the nic project dependencies — do we need the controller for the MD-SAL SFC pieces?
16:15:59 <ShaunWackerly> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan
16:16:09 <tbachman> ShaunWackerly: thx!
16:16:15 <tbachman> fwiw, we usually add a context with the link
16:16:18 <tbachman> so, something like this:
16:16:20 <tbachman> #undo
16:16:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1aaf9d0>
16:16:34 <tbachman> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan Lithim release plan for the NIC project
16:16:44 <uchau> openflowplugin as a dependency?
16:16:46 <tbachman> (may seem redundant, but folks find it more useful this way)
16:16:56 * tbachman is having trouble hearing the current speaker
16:17:32 <tbachman> #info dbainbri says it should be yangtools and the controller for the dependency
16:17:48 <tbachman> btw, anyone can info things in — hard to hear some of these
16:18:19 <tbachman> #info gzhao says you list everything you need, and if there are new features needed, you need to make requests of those projects
16:18:56 * tbachman can barely hear dmentze
16:19:33 <ShaunWackerly> tbachman: +1
16:19:38 <tbachman> #action devond says he will do the legwork to manage the dependencies
16:19:53 <tbachman> #info dependencies to be added are yangtools, ofplugin, and the controller
16:20:00 <tbachman> #info devond asks if AAA is a dependency
16:20:06 <tbachman> #info team says no
16:20:33 <tbachman> #info hideyuki says he doesn’t understand the difference between prototype and ONF-SFC
16:20:53 <tbachman> #info hideyuki plans to implement a prototype, and would like to know the difference between them
16:21:41 <tbachman> #info ShaunWackerly says the ONF-SFC prototype was specifically what dlenrow and Cathy had spoken to on the mailing list — a well defined prototype
16:21:54 <tbachman> #info ShaunWackerly says they also plan to do some prototyping outside of the ONF-SFC as well
16:22:03 * tbachman is still confused
16:22:43 <ShaunWackerly> The prototyping selected components was starting implementation of the high level design we come up with
16:23:08 <ShaunWackerly> It would be unrelated to the ONF SFC
16:23:19 <ShaunWackerly> #info The prototyping selected components was starting implementation of the high level design we come up with
16:23:22 <ShaunWackerly> there :)
16:23:23 <tbachman> ShaunWackerly: thx!
16:23:44 <tbachman> hideyuki: ^^^
16:23:46 <ShaunWackerly> #info It would be unrelated to the ONF SFC. ONF SFC was described earlier as a dead-end branch.
16:24:15 <ShaunWackerly> #info dmentze describes that non-ONF prototyping would be the building blocks for a long-term NIC solution
16:24:28 * tbachman is glad that ShaunWackerly can hear dmentze
16:25:15 <tbachman> #info devond asks if we should edit the wiki to get rid of the confusion around prototype
16:25:19 <tbachman> #info gzhao says yes
16:25:44 <ShaunWackerly> #info dmentze says that we need input from dlenrow about the differences
16:26:42 <tbachman> ShaunWackerly: thx for the help!
16:27:13 <ShaunWackerly> #info hideyuki asks if he should add a VTN prototype to the list, that's what he plans on working on
16:27:34 <ShaunWackerly> #info dmentze says that will hopefully be included under the general prototyping item
16:28:25 <ShaunWackerly> #info dmentze says that the team should discuss architecture well enough to be able to have a prototyped framework that works for all
16:29:59 <ShaunWackerly> #action dlenrow has been asked (by devond) to give a fuller description of the scope of the ONF SFC prototype
16:32:50 <ShaunWackerly> Is everyone able to get the general concept of what dmentze is saying, with his reduced volume?
16:33:07 <tbachman> ShaunWackerly: I have to rely on your IRC :(
16:33:12 * tbachman is in a noisy coffee shop
16:33:51 <ShaunWackerly> #info devond asks if we need to update themes to reflect other items
16:34:08 <ShaunWackerly> #info dmentze suggests we add one item to reflect the high level priorities
16:34:18 <ShaunWackerly> (that's as good as I got)
16:34:25 <tbachman> ShaunWackerly: works for me ;)
16:34:30 <tbachman> ShaunWackerly: doing great, btw!
16:34:38 <tbachman> using the #action, even :)
16:34:54 <ShaunWackerly> tbachman: it's like a dad watching his kid ride without training wheels! I just hope I don't crash.
16:34:59 <tbachman> lol
16:35:35 * tbachman pictures dmentze at the bottom of a hole
16:36:00 <tbachman> #info dmentze says that we’ve got work going on with the model; use case work can progress from that
16:36:03 <ShaunWackerly> He is, but we just lengthened the cord a little so that he's closer to the mic.
16:36:46 <tbachman> ShaunWackerly: lol!
16:36:53 <uchau> f2f meetings?
16:37:04 <tbachman> #info uchau asks if we should do f2f meetings
16:37:05 <ShaunWackerly> uchau: what is f2f?
16:37:11 <tbachman> ShaunWackerly: face to face
16:37:14 <tbachman> like, real world even :)
16:37:15 <ShaunWackerly> ah
16:37:17 <tbachman> lol
16:37:23 <uchau> :)
16:37:32 <tbachman> y’know… people :)
16:37:39 * tbachman promises he’s not a chatterbot
16:38:08 <tbachman> #info dbainbri says if we can get this all done in one week that’s great; depends on feedback for use cases
16:38:21 <tbachman> #info dbainbri says we can use email and the wiki, so that it’s documented in an easy to find place
16:38:53 <tbachman> #info ShaunWackerly asks if we can use email and post outcomes on the wiki?
16:39:10 <tbachman> #info ShaunWackerly says we can tag emails for use cases, so we can record a discussion per use case
16:39:23 <tbachman> #info dbainbri says that makes sense, as long as we identify the individual who’s going to document it
16:39:44 <tbachman> #info phrobb says we don’t typically do that kind of commenting on the wiki, but etherpad is available for such things
16:40:02 <tbachman> #agreed will use email, tag use cases in the email, and document on the wiki
16:40:26 <tbachman> #info devond would like to have this done by next week; may prompt need for f2f meetings the following week
16:40:50 <tbachman> #info ShaunWackerly proposed some changes to the model; wonders if we’re suspending any model changes while we discuss use cases
16:41:26 <tbachman> #info dbainbri says we should do both at the same time
16:41:51 <tbachman> #info Helen asks if the current use cases are documented?
16:42:05 <tbachman> wasn’t there an action item from last week to get the ONF’s use cases opened up?
16:42:11 <tbachman> (I guess that was dlenrow’s task)
16:43:57 <tbachman> #info ShaunWackerly asks if Helen asks to discuss things on email, propose markups on etherpad or gdoc, and put results on wiki
16:44:01 <tbachman> #info Helen says that’s correct
16:44:31 <tbachman> #info dbainbri prefers first #agreed — do email, then take to wiki
16:44:39 <tbachman> #info devond asks if Helen is okay with the first approach
16:44:50 <tbachman> #info Helen says that’s okay — just finds it hard following all the emails
16:45:22 <tbachman> #info dbainbri agres it would be nice to have a tool for more focused discussion
16:45:40 <dbainbri> dbainbri missing google wave
16:45:43 <tbachman> folks — another way of documenting such things is to use meetbot and IRC
16:45:47 <ShaunWackerly> We could email with Subject: USE-CASE - <use case title>
16:45:49 <tbachman> you have your own channel
16:45:54 <ShaunWackerly> good point
16:46:00 <tbachman> you can start a meeting
16:46:12 <tbachman> meetbot will put this in whatever meeting title you want
16:46:19 <tbachman> (i.e. that folder)
16:46:24 <tbachman> creates an archive
16:47:32 <tbachman> #info ShaunWackerly asks that folks change the email thread name if the thread changes (e.g. per use case)
16:47:35 <dbainbri> does meetbot time out a meeting if a meeting is left open for days?
16:48:11 <tbachman> dbainbri: no
16:48:15 <tbachman> only endmeeting
16:48:21 <tbachman> we’ve had meetings left open for weeks ;)
16:48:29 <ShaunWackerly> #info dmentze proposes a special meeting to discuss use cases, like uchau proposed f2f
16:48:53 <tbachman> #agreed next meeting is in HI
16:48:55 <tbachman> lol
16:48:56 <tbachman> #undo
16:48:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x1ab50d0>
16:50:40 <tbachman> #info ShaunWackerly asks if we want to talk about src/destinations split and other items
16:50:53 <tbachman> #info dbainbri sent another email about desired network state
16:50:58 <tbachman> #undo
16:50:58 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19c67d0>
16:51:08 <tbachman> #info dbainbri submitted another patch about desired network state
16:51:37 <tbachman> #info dbainbri wonders if it makes sense for an intent to have src/dest, and policy with src/dst and dst/src
16:53:43 * tbachman hears lots of thoughts on policy
16:57:16 <ShaunWackerly> #info ShaunWackerly says that atomicity could be handled by grouping or some kind of ID in policies
16:57:31 <ShaunWackerly> #info dbainbri says that might move complexity from one area to another
16:57:44 <ShaunWackerly> #info dmentze asks if we need to solve the atomicity issue
16:59:06 <ShaunWackerly> (???)
16:59:41 <ShaunWackerly> #info dmentze proposes that different policies in each direction should be two separate intents
17:00:07 <ShaunWackerly> #info dbainbri points out that this would need 2 intents per bidirectional connection
17:00:26 <ShaunWackerly> #info dmentze says we should talk more use cases
17:00:28 * tbachman is glad that ShaunWackerly is scribing at this point :P
17:00:55 <devond> So is Devon!
17:01:20 <ShaunWackerly> #info dbainbri referred to an email that LouisF sent, where he identified all of the different options for A,B,C policies
17:01:20 <dbainbri> so is dbainbri
17:01:24 <tbachman> lol
17:01:35 <tbachman> ShaunWackerly: you can end the meeting with an #endmeeting
17:01:48 * tbachman hands scribing baton to ShaunWackerly
17:02:12 <ShaunWackerly> #endmeeting