16:02:11 <tbachman> #startmeeting nic_weekly
16:02:11 <odl_meetbot> Meeting started Fri Feb 13 16:02:11 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:11 <odl_meetbot> The meeting name has been set to 'nic_weekly'
16:02:14 <tbachman> #chair devond
16:02:14 <odl_meetbot> Current chairs: devond tbachman
16:02:19 <tbachman> anyone else for chair?
16:02:24 <tbachman> #topic agenda
16:02:43 <tbachman> #link https://meetings.opendaylight.org/opendaylight-nic/2015/nic_weekly/opendaylight-nic-nic_weekly.2015-02-06-16.09.html Minutes from last week’s meeting
16:03:29 <tbachman> #info Agenda: PTL Election; Clarify SFC prototype in release plan; thread discussions
16:04:34 <tbachman> #info agenda item: how to keep pressing key topics
16:04:41 <tbachman> #topic PTL Election
16:05:13 * tbachman looks for NIC IRC expert ShaunWackerly1 to help out
16:05:17 <tbachman> #chair ShaunWackerly1
16:05:17 <odl_meetbot> Current chairs: ShaunWackerly1 devond tbachman
16:05:34 <ShaunWackerly1> #info ShaunWackerly1
16:05:37 <dbainbri> #info dbainbri
16:05:42 <devond> #info devond
16:05:45 <gzhao> #info gzhao
16:05:45 <dmentze> #info dmentze
16:05:47 <tbachman> #info tbachman
16:05:53 <alagalah> #info alagalah
16:05:56 <gzhao> #info gzhao
16:06:09 <ShaunWackerly1> #info devond says last call for PTL election
16:06:24 <tbachman> #info devond has pulled his election nomination for PTL; dmentze has added his
16:06:31 <tbachman> #info current nominations are dbainbri and dmentze
16:06:49 <alagalah> devond: phrobb has this.... and ...
16:06:50 <tbachman> #info ShaunWackerly1 asks how long the election should take
16:06:51 <ShaunWackerly1> #info election period will last for 1 week
16:06:56 <alagalah> devond: no sooner did I type than he spoke
16:06:58 <alagalah> :D
16:07:17 <ShaunWackerly1> Who was speaking? So I can correlate voice with username ...
16:07:23 <ShaunWackerly1> tbachman?
16:07:30 <ShaunWackerly1> or phil robb?
16:07:38 <tbachman> ShaunWackerly1: phrobb
16:07:42 <ShaunWackerly1> thanks
16:07:51 <tbachman> #link https://wiki.opendaylight.org/view/CondorcetElection4PTLs Wiki page showing how to setup PTL elections
16:08:11 <tbachman> #info devond asks what the criteria is to add committers
16:08:32 <tbachman> #info phrobb says that it requires contributions to the project, and project votes on whether to add the committer, then brings this to the TSC
16:08:47 <tbachman> #topic Clarify SFC Prototype in release plan
16:09:21 <tbachman> #info devond asks if anyone aside from dlenrow can speak to this
16:09:32 <tbachman> #info dmentze says we’ll probably need dlenrow for this
16:09:52 <tbachman> #action devond says he’ll contact dlenrow to get him at the next meeting to discuss
16:09:53 <ShaunWackerly1> #action devond to get confirmation from dlenrow regarding attendance next week
16:09:57 <ShaunWackerly1> #undo
16:09:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1a30450>
16:09:58 <tbachman> ShaunWackerly1: nice!
16:10:01 <tbachman> you got it
16:10:05 * tbachman steps aside for ShaunWackerly1
16:10:08 <ShaunWackerly1> haha
16:10:29 <tbachman> ShaunWackerly1: want to “topic”?
16:10:31 <ShaunWackerly1> #topic How to keep pressing forward on key topics
16:10:34 <tbachman> nice!
16:10:42 * tbachman grabs a beer and sits back
16:10:44 <tbachman> lol
16:10:57 <uchau> kinda early isn't it?
16:11:08 <tbachman> not in europe
16:11:08 <uchau> only 11 on the east coast ;)
16:11:11 <ShaunWackerly1> #info devond suggests options like f2f meetings or more frequent webex
16:11:38 <ShaunWackerly1> #info dbainbri says f2f would be ideal, but non-local people would need a way to be involved
16:12:08 <ShaunWackerly1> #info mlemay asks if anyting from ONF meeting will be included in our NIC project
16:12:35 <ShaunWackerly1> #info dbainbri says ONF has lots of interest in intent, but some things need clarified in terms of how ONF will work on intent
16:13:40 <ShaunWackerly1> #info dbainbri says subgroups are looking at models, should be looked at and pulled in
16:14:06 <ShaunWackerly1> #info devond asks if we can identify some key topics to focus on
16:14:18 <ShaunWackerly1> #info dbainbri suggests "endpoint" definition, SFC
16:14:42 <ShaunWackerly1> #info dmentze suggests multi-writer and multi-api, and the difference between them
16:15:20 <ShaunWackerly1> #info dmentze says he has prototype code to share with multi-writer
16:15:40 <ShaunWackerly1> #info mlemay says he also has code to share, would like to discuss offline details
16:16:10 <ShaunWackerly1> #info dbainbri asks mlemay if his company will be funded by ONF
16:16:25 <ShaunWackerly1> #info mlemay says that it is being decided
16:17:04 <ShaunWackerly1> #info dbainbri notes that dlenrow (in the ONF meeting) mentioned that ONF would make code available in git repo, and that code would be utilized by ONOS and ODL
16:17:33 <ShaunWackerly1> #info mlemay says that politics get involved
16:18:00 <ShaunWackerly1> #info dbainbri asks if everyone from NIC needs to work on ONF
16:18:19 <ShaunWackerly1> #info mlemay says that NIC and ONF would need a similar set of primitives need to be exposed
16:19:20 <ShaunWackerly1> #info ShaunWackerly1 asks how we can guarantee we've got the same primitives
16:19:31 <ShaunWackerly1> #info mlemay says that's what cross-project meetings are for
16:20:34 <ShaunWackerly1> #info dmentze asks how this will factor into the policy engine that NIC is going to develop, how will it generate native code
16:20:58 <ShaunWackerly1> #info mlemay says that the ONF stuff will sit on top, above policy level
16:21:24 <ShaunWackerly1> #info dbainbri says he was under the impression that ONF would develop the policy engine underneath
16:21:49 <ShaunWackerly1> #info dmentze says that if ONF wants to participate in ODL, they are welcome to
16:22:06 <ShaunWackerly1> #info mlemay says that ONF wanted NIC to be the reference implementation of what ONF wanted to do
16:22:28 <ShaunWackerly1> #info mlemay says ONF would bring standards, ODL would bring implementation
16:24:00 <ShaunWackerly1> #info ShaunWackerly1 asks if agreement was made between ONF and NIC
16:24:32 <ShaunWackerly1> #info mlemay says that ONF and dlenrow came up with a compromise (not on behalf of NIC), it is more of an experiment
16:24:53 <ShaunWackerly1> #info dbainbri says that NIC still retains the right to not use ONF code
16:25:36 <ShaunWackerly1> #info mlemay says that we will remain flexible, that another higher level runtime project may be what interfaces with ONF
16:25:50 <ShaunWackerly1> #info mlemay mentions that the project could be GBP
16:26:23 <ShaunWackerly1> #info mlemay says it is more politics than technology
16:27:44 <ShaunWackerly1> #info mlemay says that the goal was an experiment to try and come up with a way for ONF to work with ODL
16:27:51 <ShaunWackerly1> #info dbainbri adds "and ONOS"
16:28:38 <ShaunWackerly1> #info mlemay says will try to send more info about ONF meetings, perhaps NIC can influence ONF's git repo
16:29:01 <ShaunWackerly1> #info dmentze notes that ONF is interested in northbound API, asks if ONF has reviewed NIC discussions on NB API
16:29:29 <ShaunWackerly1> #info mlemay says discussions in ONF are over whether they will even have an API, or will it just be primitives/models
16:30:03 <ShaunWackerly1> #info dbainbri notes that individuals in ONF have pinged him, regarding discussions
16:30:19 <ShaunWackerly1> #info dmentze says that if ONF wants to participate, they will need to speak up in NIC
16:30:33 <ShaunWackerly1> #info dbainbri says that ONF is restructuring to focus on intent
16:30:40 * tbachman applauds ShaunWackerly1’s excellent minutes (and fast typing)!
16:30:44 <tbachman> ShaunWackerly1: thx!
16:30:57 * ShaunWackerly1 's fingers are getting a workout
16:31:17 <tbachman> lol
16:31:20 <ShaunWackerly1> #info dbainbri says they might not have voiced opinions because they don't know what they are doing yet
16:31:27 <ShaunWackerly1> #info ("they" being ONF)
16:32:10 <ShaunWackerly1> #info mlemay says he and dbainbri may be able to help bridge the gap
16:32:37 <ShaunWackerly1> #info dbainbri says he's not too involved with ONF, but dlenrow is the chair of the ONF NBI group and dlenrow is also involved in NIC
16:33:27 <ShaunWackerly1> #info phrobb says that as we figure out which software ONF is building, we need to keep licenses in view. ONF and ONOS are under apache, ODL is under EPL.
16:33:47 * ShaunWackerly1 lost sound ...
16:33:53 * ShaunWackerly1 just got sound back
16:34:34 <ShaunWackerly1> #info phrobb says licenses would prevent moving code from ONF to ODL easily
16:35:21 <ShaunWackerly1> #info dbainbri says that since it's "open source", NIC folks could go over to ONF and develop code, swap between projects
16:35:34 <ShaunWackerly1> #info dbainbri is scared by forking and having our own copy of code
16:36:01 <ShaunWackerly1> #info phrobb says ONF is meant for upstreaming w/apache license
16:37:00 <ShaunWackerly1> #info mlemay says he will try to keep informed of the ONF work
16:38:08 <ShaunWackerly1> #info devond asks for more topics to discuss in the future
16:38:32 <ShaunWackerly1> #info ShaunWackerly1 says we should decide on classifier/filter (or not)
16:38:47 <ShaunWackerly1> #info dmentze says we need use cases defined before API discussions
16:39:34 <ShaunWackerly1> #info ShaunWackerly1 notes that API is frozen on 3/19, need to freeze use cases prior
16:40:15 <ShaunWackerly1> #info dbainbri says use cases can be developed in tandem to the API discussions
16:40:37 <ShaunWackerly1> #info dmentze and dbainbri agree that we should pick a use case deadline
16:41:03 <ShaunWackerly1> #info mlemay suggests a topic, that we discuss primitives
16:41:55 <ShaunWackerly1> #action mlemay will send out some primitives from the HP intent summit, and notes from ONF discussions
16:42:53 <ShaunWackerly1> #info devond asks if we need a special use case meeting
16:43:11 <ShaunWackerly1> #info ShaunWackerly1 says the only reason we'd need that is in the presence of disagreement over whether a use case is valid
16:44:06 <ShaunWackerly1> #info dmentze says he'd rather present advanced topics (like multi-writer and SFC) in a f2f meeting, suggests we could share the floor with ONF to present and listen
16:44:37 <ShaunWackerly1> #info devond says use cases will be discussed over email, asks if we meet f2f next week
16:45:02 <ShaunWackerly1> #info dmentze says that f2f meeting should be the following week (2/23-27?)
16:45:17 <ShaunWackerly1> #info dbainbri asks if multi-writer is predicated on use cases
16:45:41 <ShaunWackerly1> #info dmentze says he can meet sooner than 2 weeks from now, if desired
16:46:18 <ShaunWackerly1> #info mlemay and dbainbri say that f2f scheduling may be problematic
16:46:35 <ShaunWackerly1> #info dmentze asks for poll regarding f2f meeting regarding multi-writer and SFC
16:48:04 <ShaunWackerly1> #info dmentze asks who would be interested in f2f meeting
16:48:25 <devond> #info F2F Devond Roseville
16:48:31 <dmentze> #info dmentze bay area
16:48:37 * tbachman couldn’t hear phrobb  on that one
16:48:38 <dbainbri> #info DavidB - bay area
16:48:39 <ShaunWackerly1> #info F2F ShaunWackerly1 Roseville
16:48:48 <uchau> #info uchau Roseville
16:48:51 <dbainbri> #info keith bay area
16:48:57 <dmentze> #dmentze roseville - but wiling to travel to bay areal
16:49:32 <tbachman> a plane
16:49:33 <tbachman> lol
16:49:47 <ShaunWackerly1> #info mlemay is based on ottowa, and can travel to bay area
16:50:10 <tbachman> #info dmentze
16:50:12 <tbachman> oops
16:50:17 <ShaunWackerly1> #info dmentze suggests bay area would give best chance for participants
16:50:20 <tbachman> #info dmentze roseville - but wiling to travel to bay areal
16:50:27 <tbachman> (#dmentze isn’t an action ;) )
16:50:30 <ShaunWackerly1> #info dbainbri offers to donate ciena offices
16:51:27 <ShaunWackerly1> #info dbainbri asks for a date
16:51:37 <ShaunWackerly1> #info dmentze proposes 2/18 or 2/19
16:52:14 <dbainbri> +1 18th
16:52:23 <ShaunWackerly1> +1 18th
16:52:42 <ShaunWackerly1> #action devond will email mailing list to ask for interest and solidify the date
16:54:12 <ShaunWackerly1> #info devond asks for pre-work that's necessary before the meeting
16:54:21 <tbachman> dmentze: just push a gerrit
16:54:42 <tbachman> sorry — that was very declarative
16:54:48 <tbachman> you *can* just push a gerrit :)
16:54:54 <ShaunWackerly1> #info dmentze asks what is the best way to offer code for review prior to meeting
16:55:06 <ShaunWackerly1> #info dbainbri suggests git (along with tbachman)
16:55:16 <tbachman> ShaunWackerly1: :
16:55:17 <tbachman> :)
16:55:29 <ShaunWackerly1> #info dbainbri asks for explanation of reasoning, along with code
16:55:43 <tbachman> btw — thanks for doing the minutes!
16:55:47 <tbachman> fantastic job!
16:55:48 <ShaunWackerly1> sure!
16:55:50 <ShaunWackerly1> thanks :)
16:56:02 * tbachman is up for HI
16:56:15 <ShaunWackerly1> #action dbainbri will secure meeting location for f2f
16:56:53 <ShaunWackerly1> #endmeeting