16:01:35 <gzhao> #startmeeting nic_weekly
16:01:35 <odl_meetbot> Meeting started Fri Mar  6 16:01:35 2015 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:35 <odl_meetbot> The meeting name has been set to 'nic_weekly'
16:02:08 <gzhao> #chair colindixon tbachman
16:02:08 <odl_meetbot> Current chairs: colindixon gzhao tbachman
16:02:22 <gzhao> #topic roll call
16:02:32 * tbachman wonders where ShaunWhackerly is
16:02:48 <gzhao> disney? will be back 3/9?
16:02:53 <tbachman> ah
16:02:57 <tbachman> nice disney trip :)
16:03:30 <dmentze> #info duane
16:04:00 <gzhao> #info gzhao
16:04:39 <tbachman> gzhao: I’m not sure how well I’ll be able to help w/the minutes - a double-booked with the neutron northbound IRC meeting
16:05:09 <gzhao> tbachman: i.c
16:05:11 <dbainbri> #info dbainbri
16:07:04 * colindixon is getting on the webex now
16:09:32 <gzhao> #topic Model discussions
16:10:15 <gzhao> #info right now there three models proposed in NIC, Shuan/Duane, Luis/Cathy and George
16:11:24 <dbainbri> colindixon: i heard you i the background
16:11:39 <dbainbri> multiple voices overlapping so hard to hear you
16:14:52 <dlenrow> 15000 that's a lot
16:15:56 <dbainbri> dlenrow: wrong chat? or what is 15000?
16:16:01 <gzhao> #info meeting conflict with neutron caused no recording for nic
16:18:02 <dlenrow> dbainbri: cdixon said sane minutes 15000 x better than recording
16:18:32 <colindixon> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Composite_Endpoint the wiki page which Louis is presenting on Composite Endpoints
16:18:53 <colindixon> #info to be clear, we’re unsure if there’s a conflict, but if there is and we try to claim the host code when there is a conflict, we’ll be kicked out and everyone will have to rejoin
16:19:07 <gzhao> colindixon: you are really quick, I just found the link
16:20:06 <gzhao> #info LouisF  says multiple tags and values can be attached to endpoint
16:20:58 <colindixon> #info dmentze asks questions about the relationship of descriptors, tags, and attributes
16:22:23 <colindixon> #info dmentze says there dosn’t appare to be an endpoint database, but where the is the database?
16:22:44 <dlenrow> #info different approach: move infected to a different EPG. don't apply attributes to EPs.Apply them only to EPGs and relationships between EPGs.
16:22:58 <gzhao> #chair dlenrow
16:22:58 <odl_meetbot> Current chairs: colindixon dlenrow gzhao tbachman
16:23:20 <colindixon> #info dmentze says it looks like there are no endpoints, there are only descriptors (which I think are expressions across traffic flows)
16:23:21 <dlenrow> #info different approach: move infected to a different EPG. don't apply attributes to EPs.Apply them only to EPGs and relationships between EPGs.
16:23:31 <dlenrow> thx gzhao:
16:23:40 <colindixon> dlenrow: +10
16:28:03 <gzhao> #action dmentze is going to send email to furthur discuss his question for composite endpoints
16:29:39 <gzhao> #info colindixon asks are we converging or diverging
16:33:05 <colindixon> #info colindixon notes that this model (coposite endpoints) focuses a lot on endpoint definition and endpoint group definition, which was explicity made orthogonal to dbainbri’s original model
16:34:34 <colindixon> #info colindixon notes that this might make them easy to merge, that is this model offers ways to define endpoints and groups in some detail, while the action/policy/operation bit about how to treat traffic between endpoint groups seems much more similar
16:36:00 <gzhao> #info colindixon says disjoint path is more like property than operation.
16:36:47 <gzhao> #info dmentze asks if use name operation or constrains
16:36:48 <colindixon> #undo
16:36:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x194b6d0>
16:36:51 <colindixon> #undo
16:36:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bac150>
16:36:53 <dbainbri> +1 colindixon's comment that operation or action doesn't fit everything
16:36:57 <colindixon> #info Cathy asks would the term operation be the right term for the thing that happens to traffic between two endpoints
16:37:04 <colindixon> #info colindixon says disjoint path is more like property than operation.
16:37:11 <dbainbri> (but the name isn't a road blocker)
16:37:11 <colindixon> #info dmentze asks if use name operation or constrains
16:37:53 <colindixon> #info colindixon notes that he’s not saying he’ll block the model (if people like it) for the name, but it doesn’t quite fit the set of things that we’d actually do
16:39:23 <gzhao> #info dmentze suggests to have model decided first.
16:39:24 <colindixon> #info colindixon and dlenrow note that they’d rather not spend time trying to come up with a name on confernce call with lots of people on it
16:40:05 <gzhao> LouisF: can you pass me the ball
16:40:32 <colindixon> #topic Nemo Model
16:42:18 <colindixon> #link https://wiki.opendaylight.org/view/File:Nemo_object_model.jpg the diagram being talked about
16:43:00 <colindixon> #info gzhao says that this is actually very similar to Cathy’s model
16:43:35 <colindixon> #info a connection is a path through the network without source or destinations, the actual physical path
16:44:02 <colindixon> #info a flow an established flow of data with source and destinations
16:44:36 <colindixon> #info gzhao notes that Nemo has an IETF proposed standard, it’s also been proposed in OPNFV, ONF, and likely will be an ODL project soon
16:45:19 <colindixon> #info Louis says that the flow is very similar to a classifier in dmentze’s previous model
16:45:46 <dlenrow> #info central to other intent models is the idea that intent is about relationships between EPGs. end-points, connections, flows, are not intent, they are implementation detail.
16:46:08 <colindixon> #info gzhao notes that the *only* difference is the new addition of connections and flows
16:46:09 <colindixon> dlenrow: +10000000000000
16:50:03 <colindixon> #info Cathy points out that they need to have some access to lower-level details than just endpoints and they want access to them
16:50:32 <colindixon> #info colindixon says that in general, when you have a higher-level asbtraction that is too complex and you want more details, you do that by providing the more details below in a lower layer
16:50:38 <dlenrow> #info pairwise relationships between singletons are not interesting at scale. It's about EPGs and relationships between large numbers of entities with similar behaviors
16:51:07 <LouisF> +1
16:51:32 <colindixon> #info colindixon says in this case it looks like conections (basically path level stuff) would be a good candidate for how to provide some specific constraint/policy/operation, rather than being another abstraction on the same level with endpoint groups
16:52:02 <colindixon> #info colindixon goes on to say that the flow sounds like it might actually be better provided as a way to define endpoints that then are collected into endpoint groups
16:53:57 <LouisF> the challenge is to come up with a good lower layer model that addresses divergent paths, waypoints..
16:54:24 <colindixon> #info colindixon says that he thinks a lot of disagreement is talking at different layers
16:54:53 <colindixon> #info colindixon says that, unfortunately, this might make things harder rather than easier because now we need models at multiple levels
16:55:10 <LouisF> colindixon: agree
16:56:07 <colindixon> #info it might help the discussion at least to bin objections to models into 3 bins: “this model is too high-level, I can’t speicfy things I care about in the detail I care about”, “this model is too low-level, I have to jump through hoops to translate what I want to do into it” and “at the level of this model, we could do this in a different/better way"
16:56:26 <dlenrow> #intent is an overlay and is completely virtual. disjoint path, and flow processing is part of the mapping required before intent is overlayed, but it is not part of intent. If four-nines should map to disjoint path, that gets mapped in pre-intent configuration. The one and only intent NBI offered is the "four-nines" constraint
16:56:46 <colindixon> #undo
16:56:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a30e90>
16:56:58 <colindixon> #info it might help the discussion at least to bin objections to models into 3 bins: “this model is too high-level, I can’t speicfy things I care about in the detail I care about”, “this model is too low-level, I have to jump through hoops to translate what I want to do into it” and “at the level of this model, we could do this in a different/better way"
16:57:14 <colindixon> #info dlenrow notes that he thinks intent is an overlay and is completely virtual. disjoint path, and flow processing is part of the mapping required before intent is overlayed, but it is not part of intent. If four-nines should map to disjoint path, that gets mapped in pre-intent configuration. The one and only intent NBI offered is the "four-nines" constraint
16:57:23 <colindixon> dlenrow: getting things actually logged
16:58:23 <colindixon> #topic changes to shaun’s and dmentze’s model
16:59:33 <colindixon> #link https://wiki.opendaylight.org/view/File:Nic_usecase_5_LyncCallQoS.txt the text file that dmentze is talking to
17:00:13 <colindixon> #info dmentze talks about endpoint attributes and traffic attributes and why he thinks they’re very important
17:00:57 <colindixon> #info Louis says he still doesn’t why you need to specify the different attributes need to be split
17:03:47 <dlenrow> #info IMO to much emphasis on classifier looking stuff. Intent model and verbs need progress. Need to abstract end-points away and get on with it.
17:03:57 <helenchen> The need for traffic-attribute is samiliar as "Flow" in NEMO model, we want things to be simple, but it cannot descriibe real use case well.
17:04:12 <colindixon> #info dmentze says its because in many controllers we will know things about endpoints at run time and the traffic attributes are things you might not know (or at least that was my understanding)
17:04:16 <colindixon> #endmeeting