15:02:57 <gzhao> #startmeeting nic weekly
15:02:57 <odl_meetbot> Meeting started Fri Mar 20 15:02:57 2015 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:57 <odl_meetbot> The meeting name has been set to 'nic_weekly'
15:03:07 <gzhao> #Roll Call
15:03:14 <gzhao> #topic Roll Call
15:03:19 <gzhao> #info gzhao
15:03:23 <tbachman> #info tbachman
15:03:34 <tbachman> #link https://meetings.opendaylight.org/opendaylight-nic/2015/nic_weekly/opendaylight-nic-nic_weekly.2015-03-13-15.02.html Minutes from last week’s meeting
15:03:59 <dmentze> #info duane mentze
15:04:33 <hideyuki> #info Hideyuki Tai
15:04:53 <gzhao> #chair tbachman phrobb dmentze
15:04:53 <odl_meetbot> Current chairs: dmentze gzhao phrobb tbachman
15:05:36 <gzhao> #topic agenda
15:05:43 <tbachman> #info dmentze and devon have to change roles — moving on
15:06:21 <tbachman> #link https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000584.html email describing today’s agenda
15:06:41 <tbachman> #info gzhao will be the project contact
15:06:45 <tbachman> #action gzhao to update M3 status
15:06:54 <gzhao> #undo
15:06:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ba94d0>
15:07:00 <tbachman> lol
15:07:01 <tbachman> sorry gzhao
15:07:07 <gzhao> #action gzhao to work with dmentze for M3 status
15:07:07 * tbachman misheard
15:07:13 <tbachman> got it
15:07:14 <tbachman> ;)
15:07:19 <gzhao> tbachman: ;)
15:07:45 <gzhao> #topic PTL election
15:08:00 <alagalah_> dmentze: My understanding is a few weeks
15:09:18 <tbachman> #info dbainbri is out until the end of the month; dmentze says we have two options — do election w/o dbainbri, or just have folks volunteer for those roles until a PTL election can be done that includes dbainbri
15:09:18 <alagalah_> gzhao: May I offer some precedents for this ?
15:09:38 * alagalah_ can't get on microphone...
15:10:20 <tbachman> #link https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000600.html email from gzhao describing his thoughts/proposal on this issue
15:10:21 <alagalah_> gzhao: PTL is self-nominating only ... but even though PTL has been in the charter for as long as I remember, we got by with POC... so I believe the precedent of a POC in the interim would be acceptable
15:11:08 <alagalah_> phrobb: Can you verify what I said above ?
15:11:11 <tbachman> #info phrobb says his recommendation is to try to contact dbainbri to see if he will self-nominate
15:11:27 <alagalah_> tbachman: Are you on webex ?
15:11:27 <gzhao> #link https://wiki.opendaylight.org/view/CondorcetElection4PTLs < --- ODL PTL process
15:11:31 <tbachman> alagalah_: ack
15:11:37 <alagalah_> Can you ask folks to look at IRC plesae?
15:11:55 <tbachman> gzhao: ^^^^
15:12:25 <alagalah_> tbachman: IRC only
15:12:34 <tbachman> got it — just mentioned that they look at it
15:12:35 <alagalah_> tbachman: So can you direct people to IRC please ?
15:13:22 <tbachman> #info phrobb says worst-case is that a Point of Contact can be used for a while — asks if anyone else is planning to self-nominate
15:14:08 <tbachman> #action gzhao will try to contact dbainbri re: PTL self-nomination
15:14:45 <tbachman> #action colindixon to also try to contact dbainbri
15:15:10 <dlenrow> I may self-nominate, negotiating w/mgmt, when is deadline?
15:15:21 <alagalah_> dlenrow: Folks aren't paying attention to IRC
15:15:22 <tbachman> dlenrow: I think they’re trying to define it :)
15:15:23 <gzhao> dlenrow: great
15:15:31 <dlenrow> On plane doors closing soon...
15:15:42 <tbachman> #info dlenrow may self-nominate (pending approval from mgmt)
15:15:42 <alagalah_> dlenrow: tbachman Can you PLEASE GET PEOPLE TO WATCH IRC
15:16:10 <tbachman> #info mlemay says there are a couple of candidates who are expressing concern about the amount of time involved in being PTL
15:16:22 <tbachman> #Info gzhao asks if everyone agrees to extend deadline to next week
15:16:35 <tbachman> #info dmentze agrees we need to extend it to next week
15:17:04 <tbachman> #info dmentze asks colindixon if the TSC would approve just putting dbainbri’s name on the PTL nominiation list
15:17:35 <tbachman> #info colindixon says that projects are free to determine their nomiation process — the election has to be handled as called out by the TSC
15:17:53 <tbachman> #info colindixon says he’s not aware of any timeline that a project has for running w/o a PTL
15:18:22 <tbachman> #info gzhao recommends moving the deadline to March 31st, as there are several candidates who need more time — would have PTL elected on April 3rd meeting
15:18:34 <dlenrow> "If nominated I will not run. If elected I will not serve" :)
15:18:54 <dlenrow> Just goofing
15:18:57 <tbachman> #agreed moving the nomination deadline to March 31st; PTL election on April 3rd meeting
15:19:08 <tbachman> #topic M3 status
15:19:48 <helen_chen> dlenrow: looks like the process is "self-nominate", you are safe. lol
15:20:21 <tbachman> #info dmentze says NIC doesn’t have customer-visible features, which simplifies this
15:20:56 <tbachman> #info dmentze asks for volunteers for karaf features
15:21:12 <tbachman> #info mlemay says dmentze can put mlemay’s name next to karaf features
15:23:20 <tbachman> #info colindixon says the docs requirement for M3 is to mostly just create a template, not filling in content; requests help adding content as the project moves along
15:24:57 <gzhao> dmentze: I can help on Karaf as well if needed
15:25:15 <tbachman> #info dmentze says there are no system/integration requirements, as there are no user-facing features
15:26:31 <mlemay> gzhao: ok great.. :) thx george lets sync up on that if you want
15:26:45 <gzhao> mlemay: sure
15:27:12 <tbachman> #info dmentze recommends picking a model so that code can be written
15:27:42 <tbachman> #info dmentze asks how to get a consensus decision from a large group
15:27:55 * tbachman wonders if this is a TSC question, or project question
15:30:03 <dlenrow> Recommend coders assume model can change still
15:30:36 <tbachman> #info dmentze says one possibility is to take HP code, work with it, and then let that drive design discussions
15:31:07 <dlenrow> Recommend EPG-centric intent model so EP concensus not needed
15:31:39 <tbachman> #info gzhao agrees with dmentze — if we want something to happen in Lithium time frame, given that we’re at M3, this may be the best path
15:31:52 <tbachman> #info gzhao asks who at HP would be the contact for his code going forward
15:32:23 <tbachman> #info dmentze says during the deep-dive, there wasn’t a lot of questions; wasn’t sure how to interpret that; going forward, HP has 3 dedidcate engineers who are going to be ramping on the code
15:33:02 <tbachman> #link https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000574.html email from dmentze describing replacements from HP
15:33:59 <tbachman> #info helen says sometimes it
15:34:01 <tbachman> #undo
15:34:01 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1824590>
15:34:19 <tbachman> #info helen says sometimes it’s harder to inherit code than create from scratch
15:35:14 <tbachman> #info helen says it may be better to focus on a single use case, such as SFC
15:35:19 <tbachman> was it SFC or NFV?
15:35:37 <tbachman> #info dmentze says it’s important for the group to agree on that use case
15:36:14 <tbachman> #info colindixon says the challenge is to create clean, simple abstractions in order to support a bunch of use cases; focusing on a single use case early on may make creating such a model hard
15:38:13 <helen_chen> #info helen said we look at the whole use case set, and implement one for the lithium time frame
15:38:22 <tbachman> helen_chen: thx!
15:38:29 * tbachman didn’t realize helen_chen was on IRC ;)
15:38:42 <helen_chen> tbachman: welcome
15:40:04 <tbachman> #info mlemay says there’s been a lot of model discussions — we’ve identified a bunch of use cases, but we need to start working at providing extra value in ODL through this project
15:41:20 <tbachman> #info dmentze says that while he appreciates the need for clean APIs, the code underneath is really non-trivial
15:42:01 <tbachman> #info dmentze says we need to get coders working on supporting some of these APIs — might be good for some to go explore SFC space; pull HP code and work with it
15:42:26 <tbachman> #info dmentze says it might be hard to do a “think-tank” design
15:43:27 <tbachman> #info colindixon says there are lots of implementations of intent in ODL: OVSDB is an implementation of one kind of intent; SFC is another implementation of another kind of intent; there’s GBP which is another implementation of another kind of intent; he feels that this might be down to simple shims into those projects
15:43:52 <tbachman> #info colindixon says his experience is that if the people who wrote the code aren’t there, then the code is not useful
15:44:14 <tbachman> #info gzhao says during the 2hrs deep dive let people understand the structures; but to take ownership of the HP code is harder
15:44:39 <tbachman> #info colindixon says there are implementations that are lying around, with active committers; figuring out how NIC maps onto those might be very constructive
15:45:14 <tbachman> #info mlemay agrees with colindixon — having a shim layer to existing pieces in ODL is already providing value
15:45:42 <tbachman> #info mlemay says having the ability to batch intent has a lot of value, and an intent topology
15:45:54 <tbachman> #info gzhao agrees with colindixon and mlemay
15:46:32 <tbachman> #info helen_chen agrees with that idea
15:47:18 <tbachman> #info someone asks if we need to agree on the API for intent, and then can start on the implementation
15:49:22 <tbachman> #info mlemay asks if those on the meeting would be okay with merging the HP code in one folder and the models in another folder, and then get started on the code piece
15:49:29 <tbachman> #info hideyuki asks what the shim layer is
15:50:02 <tbachman> #info mlemay says the shim layer is a mapping of the intent NB’s to existing projects or ways of implementing that, instead of translating to existing openflow rules
15:50:53 <tbachman> #info mlemay says for example, an intent that would describe an overlay could map to an overlay model in OVSDB
15:51:20 <tbachman> #info hideyuki says they are planning to developing a mapping layer in VTN project; that’s fine for them
15:51:56 <tbachman> #info gzhao asks what the concrete plan for Lithium, given agreement to the shim layer strategy
15:53:29 <gzhao> #info mlemay says we may come up with a model totally different
15:53:35 <tbachman> #info mlemay says one thing to keep in mind for the models is to keep the notion of groups
15:53:37 <tbachman> gzhao: thx!
15:54:07 * tbachman wonders who “Call in user 6” is
15:54:16 <mlemay> I would guess Cathy?
15:54:27 <gzhao> tbachman: cahty
15:54:30 <helen_chen> yes, it is Cathy
15:54:30 <tbachman> mlemay: thx!
15:54:31 <tbachman> gzhao: thx!
15:54:58 * tbachman is having trouble hearing Cathy
15:55:07 <tbachman> #info colindixon says he believes the developers will drive the model
15:56:04 <helen_chen> mlemay: you are opening the "Pandora's box" now
15:56:11 <tbachman> #info dmentze and mlemay agree
15:56:13 <colindixon> in this case, it’s going to be very interersting and hard to drive this
15:56:27 <colindixon> we need to both have people writing code drive the models up
15:56:38 <colindixon> but also we need to keep implementation details out of th emodel
15:56:46 <hideyuki> colindixon: +1
15:56:50 <colindixon> and keep it to a very small number of abstractions
15:56:52 <tbachman> #info gzhao asks if the conclusion is to let the developers work on the models
15:57:19 <colindixon> ther aren’t a ton of examples fo this happening the past, the UNIX abstrations focusing on the file is one of the few I can point to
15:58:36 <tbachman> #info dmentze asks how the project is going to operationalize all of this — who are the people who are going to write the code to connect it into ODL projects
15:59:56 <tbachman> #info mlemay says he can commit 2 resources to the project
16:00:06 <tbachman> #info helen_chen says she can include 1-2 resources
16:00:10 <colindixon> #info colindixon notes (in the IRC logs) that this is going to be *really* hard because it needs to be bottom up from the coders, but also keep the implementation details out of the model and keep the abstractions very simple
16:00:21 <tbachman> #info dmentze has committed resources
16:00:31 <tbachman> colindixon: thx!
16:00:45 <tbachman> wasn’t sure if you wanted me to capture that
16:01:20 <tbachman> #endmeeting