15:01:07 <gzhao> #startmeeting nic weekly
15:01:07 <odl_meetbot> Meeting started Fri Mar 27 15:01:07 2015 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <odl_meetbot> The meeting name has been set to 'nic_weekly'
15:01:15 <gzhao> #topic roll call
15:01:22 <gzhao> #info gzhao
15:01:34 <tbachman> #info tbachman
15:01:34 <dlenrow> #info dlenrow
15:01:42 <phrobb1> #info Phil Robb
15:01:57 <hideyuki> #info hideyuki
15:02:23 <gzhao> #link https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000609.html <-- agenda
15:03:58 <gzhao> #topic PTL update
15:04:45 <gzhao> #info no self nomination so far
15:05:24 <gzhao> #info gzhao sent David B email
15:06:54 <gzhao> #agree PTL self nomination deadline extends to 4/3
15:07:14 <gzhao> #agreed PTL self nomination deadline extends to 4/3
15:07:21 <dlenrow> #info agreed with no opposition on call to push deadline for self-nomination for PL to 4/3
15:10:22 <gzhao> #info mlemay suggest two parallel code repository for NIC
15:10:52 <gzhao> #info mlemay agrees with gzhao time is running short
15:12:38 <gzhao> #info dlenrow  suggests cut a snapshot for Lithium and have a long term in parallel.
15:13:16 <gzhao> #info mahesh ask which model should NIC use
15:13:55 <gzhao> #info mahesh asks how to define shim layer
15:15:18 <gzhao> #info mlemay says shim layer will use reservation, GBP, SFC in ODL
15:15:44 <hideyuki> gzhao: I would like to add VTN into the list.
15:15:50 <gzhao> #undo
15:15:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b78690>
15:16:05 <gzhao> #info mlemay says shim layer will use reservation, GBP, SFC, VTN in ODL
15:16:10 <hideyuki> gzhao: Thank you :)
15:16:12 <gzhao> hideyuki: thanks
15:17:28 <gzhao> #info dlenrow says this is a common layer that northbound will talk and eco system build around.
15:18:08 <gzhao> #info Cathy says API is different than GBP
15:20:05 <gzhao> #info LouisF asks mlemay details about shium
15:22:11 <gzhao> #info dlenrow NIC is common layer that can be mapped to different new or existing projects.
15:22:26 <cathy_> Dave; The shim layer will map the common northbound APIs to multiple southbound implementations.
15:23:04 <gzhao> #action dlenrow will draft a wiki page for NIC direction.
15:23:15 <cathy_> Cathy: the common north bound interface will be different from GBP interface, service chaining will be the use case for this release
15:24:24 <helenc878> cathy_: if you like your notes be captured by minutes, please put #info keyword, otherwise it will be lost.
15:24:39 <gzhao> #action mlemay to prepare two repository for NIC
15:24:42 <cathy_> Dave: the common northbound interface will have endpoint definition, redirect operation definition
15:25:06 <gzhao> #action dlenrow to work with mahesh for HP code pass IPR
15:26:20 <cathy_> Cathy: #info Cathy: we have discussed before to use "operation" instead of "redirect"
15:26:46 <gzhao> #info mlemay will propose architecture for review.
15:26:52 <gzhao> cathy_: thanks
15:26:53 <helenc878> gzhao: I thought we are agreed to do an organic version from scratch
15:30:29 <gzhao> dlenrow: can you #info your sentence?
15:32:17 <gzhao> #info mahesh ask if HP code can be refactored to avoid two code base
15:33:55 <gzhao> #info mlemay says technically HP code is too AD-SAL ish or OSGI-ish.
15:34:05 <helenc878> #info there're two parallel approach for NIC: one is contintuing discussion on data model and others for post-Lithium release; another one is creating shim layer from scratch
15:34:43 <helenc878> #info the second one is from Lithium release
15:35:03 <gzhao> helenc878: mlemay is going to prepare two repositories to do in parallel
15:35:20 <helenc878> #undo
15:35:36 <helenc878> #info the second one is for Lithium release
15:35:56 <gzhao> #undo
15:35:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab5310>
15:36:00 <gzhao> #undo
15:36:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19acfd0>
15:36:06 <gzhao> #info the second one is for Lithium release
15:36:13 <gzhao> #chair dlenrow mlemay helenc878
15:36:13 <odl_meetbot> Current chairs: dlenrow gzhao helenc878 mlemay
15:36:26 <gzhao> helenc878: need to be chair to undo
15:36:47 <helenc878> gzhao: thanks. I saw you did that.lol
15:36:52 <dlenrow> I think worst case we throw away 100% of first gen Li shim. All decisions are temporary. Goal is to learn
15:37:50 <gzhao> #info dlenrow build first shim layer with simple definitions
15:38:54 <gzhao> #info Mahesh asks who will be the consumer for the shim layer
15:39:00 <cathy_> Cathy: info# Dave : we have the SFC use case in the NIC web page, We will try to align our northbound API and model with that
15:39:12 <gzhao> #info dlenrow says will be anything to the north of controller
15:39:39 <gzhao> #info dlenrow says we have the SFC use case in the NIC web page, We will try to align our northbound API and model with that
15:39:47 <gzhao> cathy_: just starts with #info
15:40:43 <cathy_> #info: Dave said we have the SFC use case on the NIC page and we will try to aling our northbound API and model with that
15:40:55 <gzhao> #undo
15:40:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x194b310>
15:41:04 <gzhao> cathy_: already added that
15:41:43 <cathy_> #Info: you asked me to use #info, so that is why I rewrite it
15:42:13 * gzhao miss tbachman so much
15:42:26 <tbachman> gzhao: am here!
15:42:27 <tbachman> sorry
15:42:30 <gzhao> #topic M3 status
15:42:32 <tbachman> am also coding :)
15:42:34 <tbachman> lol
15:43:51 <gzhao> #info gzhao asks will NIC define Karaf features
15:44:33 <gzhao> #info hideyuki says yes, NIC should define karaf features
15:45:45 <gzhao> #info mlemay says ETA for feature is next Monday
15:46:45 <tbachman> mlemay: you may want to go on mute when not speaking
15:46:52 <tbachman> (makes it hard to hear gzhao_
15:46:58 <tbachman> mlemay: thx!
15:47:01 <mlemay> sorry
15:47:10 <mlemay> airflow!.. my bad
15:47:24 <tbachman> mlemay: good mic ;)
15:48:08 <gzhao> #topic others
15:52:58 <gzhao> #info gzhao says NIC should be able to catch up in M4,M5 time frame if high level architecture is determined.
15:53:33 <gzhao> #action mehesh will work on for submit HP code for NIC
15:53:42 <gzhao> #endmeeting