15:04:12 <raphael> #startmeeting nic_weekly
15:04:12 <odl_meetbot> Meeting started Fri May  1 15:04:12 2015 UTC.  The chair is raphael. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:12 <odl_meetbot> The meeting name has been set to 'nic_weekly'
15:05:26 <dlenrow> colindixon: master of meeting tools
15:06:51 <colindixon> #topic agenda bashing
15:07:01 <colindixon> ah, raphael #chair me?
15:07:09 <raphael> #chair colindixon
15:07:09 <odl_meetbot> Current chairs: colindixon raphael
15:07:16 <colindixon> #topic agend bashing
15:07:54 <dlenrow> colin's buying monitors for the house :)
15:07:57 <colindixon> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Main#May_1.2C_2015 the agenda
15:08:35 <colindixon> #topic initial YANG / interface models
15:09:46 <colindixon> #link https://github.com/opendaylight/nic/tree/master/intentengine-api/src/main/yang the current YANG interfaces
15:10:40 <colindixon> #info it seems like the major changes are that we’ve split out primitive actions, and factored thigns apart into multiple yang files
15:11:32 <colindixon> #info dbainbri says we’d like to freeze this API in the next few days and wants feedback on that idea
15:11:40 <dlenrow> my microphone is not working. I would suggest we freeze a very skinny (minimum for SFC) for Li, and then immediately keep evolving our IM in parallel, including in Li timeframe
15:12:07 <dlenrow> Don't let Li freeze compete with continuing to iterate on what is community agreed "final" model
15:12:29 <colindixon> #info dbainbri and colindixon seem to agree that focusing on just allow and deny
15:12:52 <dlenrow> Don't we need a redirect/steer verb for Mathieu's SFC work?
15:13:19 <colindixon> #agree barring a major uprising, we’ll scale back the primitive actions to allow/deny, with agumentations for thigns like SFC (and maybe redirect steer for mlemay’s work)
15:13:20 <dlenrow> Need somebody with microphone to point dbainbridge at my comments
15:13:29 <colindixon> dlenrow: working on it
15:13:52 <colindixon> #info dlenrow raises concerns about just allow/deny for now
15:15:04 <colindixon> #action dbainbri to make the changes to trim down the primitives in the repository
15:15:39 <raphael> #info Now we have a high level intent model, but we're going to focus on actions allow and deny for lithium.
15:15:54 <colindixon> #action mlemay to work with dbainbri to make sure that the revised model will work for his issues in the Lithium time-frame
15:16:03 <dlenrow> Li IM is throw-away, fast fail learning opportunity
15:17:28 <colindixon> #info colindixon asks if we should have a “YANG expert” (e.g., Ed, Robert, etc.) look through things and make sure we’re not making any obvious mistakes
15:17:30 <raphael> #info raphaelamorim to push karaf console extensions with add, delete and list support today
15:17:52 <raphael> #action raphaelamorim to push karaf console extensions with add, delete and list support today
15:18:34 <colindixon> #undo
15:18:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19d72d0>
15:18:36 <colindixon> #undo
15:18:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b78c90>
15:18:42 <colindixon> #topic Karaf CLI
15:18:51 <colindixon> #action raphaelamorim to push karaf console extensions with add, delete and list support today
15:18:58 <raphael> thanks colin
15:19:03 <raphael> wrong topic
15:19:04 <colindixon> #topic providers
15:19:31 <colindixon> #info there are two providers we’re looking at in Lithium: VTN and GBP
15:20:08 <dlenrow> I think Mathieu was seeking path of least resistance and staffing from VTN side made that the easiest path to SFC
15:20:26 <colindixon> #info dbainbri asks if we have any commitment from those projects, because at some point we will really want that
15:20:53 <dlenrow> Current POR Commitment is from innocybe to build SFC on VTN
15:22:22 <hideyuki> dlenrow: We don't target SFC. I mean that we planned to implement a VTN provider for SFC in Lithium. But, we don't have enough time for Lithium now. Therefore, we plan to implement a very simple VTN provider for simple scenario.
15:22:44 <dlenrow> Li needs architectural placeholder. OPNFV 2.0 will be built on Li and needs some SFC hooks/NBI to ship in Li
15:23:36 <dlenrow> Planning to support one use case SFC for Li. There will be an NBI and an implementation.
15:24:16 <dlenrow> Doing with neutron doesn't meet goal of demonstrating that NIC NBI works for SFC.
15:24:59 <dlenrow> It's about common NIC API on ONOS and ODL. ONOS will support OPNFV SFC for Rel 2.0.
15:25:16 <dlenrow> If Li ODL doesn't have it, ONOS wins as OPNFV SDN controller
15:26:16 <dlenrow> As of now, SFC demo is a committed Li deliverable AFAIK
15:26:29 <colindixon> #info colindixon asks if there’s a simple way that we could map NIC onto Neutron in Lithium so that we would have a provider
15:27:43 <colindixon> #info dlenrow says that we need to deliver an SFC demo on top of ODL and ONOS in the Lithium timeframe, it appears as though mlemay is the person who is staffing that effort
15:27:52 <dlenrow> Clearly hear that you need to see ODL code commits to start building confidence that we will get something in.
15:28:22 <dlenrow> Community might help best by pursuing parallel conversation on getting to extended IM with community concensus.
15:30:41 <colindixon> #info dbainbri say she hasn’t seen any evidence of that work in the Lithium release, which concerns him, mlemay says he will try to reshuffle resources to make that happen
15:30:59 <raphael> #info hideyuki is working on VTN provider and focusing on alow/deny action for lithium timeframe
15:31:04 <colindixon> #undo
15:31:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b78b50>
15:31:06 <colindixon> #undo
15:31:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b78d90>
15:31:12 <raphael> #info hideyuki is working on VTN provider and focusing on alow/deny action for lithium timeframe
15:31:13 <colindixon> #info dbainbri say he hasn’t seen any evidence of that work in the Lithium release, which concerns him, mlemay says he will try to reshuffle resources to make that happen
15:31:28 <colindixon> thanks raphael
15:31:33 <raphael> :D
15:31:39 <colindixon> #topic documentation
15:31:39 <dlenrow> I could help with doc\
15:31:43 <hideyuki> raphael: Thank you!
15:31:50 <colindixon> #action dbainbri to work on docs for the model
15:32:28 <colindixon> #info dbainbri would love help with docs and especially adding anything for things for providers if we have any
15:33:19 <mlemay> Ok
15:33:23 <colindixon> #action raphael to work on integration testing for NIC
15:33:32 <colindixon> #topic trello board review
15:33:56 <colindixon> #link https://trello.com/b/L4GssBld/opendaylight-nic
15:36:14 <colindixon> #topic deliverable review
15:36:37 <colindixon> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan the release plan
15:37:13 <colindixon> #info we seem to be in good shape on: use cases, the YANG model, and the high-level design
15:37:26 <colindixon> #info the prototype and ONF SFC seem much, much scarier
15:39:10 <dlenrow> Will work with innocybe and HP team's to either present detailed plan to include SFC/VTN provider demo or will agree to miss Li milestones. Report back by email to lists early next week
15:39:15 <colindixon> #info in particular we don’t seem to have worked out either (a) if the model is sufficient for those and (b) if there’s a provider for the model that will be sufficient in the Lithium release
15:39:30 <colindixon> #action dlenrow Will work with innocybe and HP team's to either present detailed plan to include SFC/VTN provider demo or will agree to miss Li milestones. Report back by email to lists early next week
15:39:41 <dlenrow> Will work with innocybe  HP, NEC team's to either present detailed plan to include SFC/VTN provider demo or will agree to miss Li milestones. Report back by email to lists early next week
15:40:08 <dlenrow> Apology, left out Hideyuki before
15:41:04 <dlenrow> Hoping Li has the architectural hooks for SFC, Maybe separate that from including demo in Li
15:41:59 <dlenrow> +1, giant disclaimer in Li that IM will change
15:42:47 <dlenrow> Info Model
15:43:51 <colindixon> #info there is a longer discussion around worries about missing delivering on our Lithium release plans
15:44:04 <dlenrow> Restart meetings for YANG wars in parallel to Li delivery
15:44:47 <mlemay> Yes...
15:44:58 <mlemay> Sorry got disconnected..
15:45:30 <colindixon> #info colindixon and dbainbri say that there seems to be a real likelihood of shipping no NIC providers in Lithium, although it seems most likely that hideyuki and VTN will deliver one of the options
15:45:45 * dbainbri strongly disagrees with a restart of model wars.
15:46:01 <colindixon> #endmeeting