15:51:19 <raphaelamorim> #startmeeting nic_weekly
15:51:19 <odl_meetbot> Meeting started Fri Nov  6 15:51:19 2015 UTC.  The chair is raphaelamorim. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:51:19 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:51:19 <odl_meetbot> The meeting name has been set to 'nic_weekly'
15:51:51 <raphaelamorim> #chair gzhao
15:51:51 <odl_meetbot> Current chairs: gzhao raphaelamorim
15:59:21 <raphaelamorim> #topic Current Status User Stories
16:12:51 <raphaelamorim> #info All activities on going. No impediments.
16:15:14 <raphaelamorim> #info icarocamelo is going to propose a YANG model to implement a mapping service
16:16:41 <raphaelamorim> #link https://gist.github.com/icarocamelo/bd0ade3396f21dcf256a
16:20:34 <grmontpetit> you could have clustering with a map in a map where the outerkey would be the sharded instance identifier
16:40:11 <raphaelamorim> #info dlenrow commented about the need of having implementation independent mapping service
16:41:23 <raphaelamorim> grmontpetit: you're right
16:41:30 <raphaelamorim> grmontpetit: md-sal was not out of the plans
16:42:05 <raphaelamorim> grmontpetit: in nic's perspective the data structure that is being used behind the scenes doesn't matter
16:42:30 <raphaelamorim> grmontpetit: some people will use cassandra to implement the mapping service
16:42:48 <raphaelamorim> grmontpetit: we want to be agnostic to that
16:43:17 <raphaelamorim> #topic State Machine and Transaction Model
16:44:36 <raphaelamorim> #info yrineu talked about the current implementation of state machine
16:44:43 <raphaelamorim> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Beryllium_Planning#.239883:_Intent_state-machine_.28mandatory.29
16:44:58 <raphaelamorim> #info and the review:
16:45:27 <raphaelamorim> #link https://git.opendaylight.org/gerrit/#/c/28916/
16:46:39 <raphaelamorim> #info we've also discussed about the transaction model for the intents. link:
16:46:43 <raphaelamorim> #link https://wiki.opendaylight.org/images/4/4c/Transaction_model_state_machine.png
16:47:19 <raphaelamorim> #action yrineu to push the first review on the transaction model for the state machine
16:47:40 <raphaelamorim> #action everyone to make comments on the review to get to the final design
16:48:34 <raphaelamorim> #action icarocamelo to push a mapping service implementation based on md-sal
16:49:02 <raphaelamorim> #endmeeting