16:03:14 <ShaunWackerly> #startmeeting NIC Weekly Meeting
16:03:14 <odl_meetbot> Meeting started Fri Feb 20 16:03:14 2015 UTC.  The chair is ShaunWackerly. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:14 <odl_meetbot> The meeting name has been set to 'nic_weekly_meeting'
16:04:06 <gzhao> #info gzhao
16:04:13 <ShaunWackerly> #info ShaunWackerly
16:06:54 <gzhao> #topic administrative items
16:08:59 <ShaunWackerly> #info PTL election, will need to add +1's from email
16:09:27 <ShaunWackerly> #info devond recommends that dmentze be considered project lead, unless any objections
16:09:57 <ShaunWackerly> #info devond asks how Test Contact is chosen
16:10:29 <ShaunWackerly> #info colindixon says typically Test Contact is PTL, unless someone volunteers to do the work
16:11:35 <ShaunWackerly> #info colindixon says Test Contact must assure at least one system test
16:12:42 <ShaunWackerly> #info dlenrow points out that if Test Contact goes on vacation, they need to identify a replacement
16:13:05 <ShaunWackerly> #info Documentation Contact, will likely follow same path as Test Contact
16:13:54 <gzhao> I count 10 out of 18 committers +1 dmentze by email or oral support.
16:14:05 <ShaunWackerly> #info dmentze will be listed for both, then possibly delegate later
16:14:46 <ShaunWackerly> #topic F2F follow-up
16:15:24 <ShaunWackerly> #info dlenrow will present slides showing collaboration with ONF
16:16:22 <ShaunWackerly> #info dlenrow says it would be good for ODL to be reference implementation of Intent NBI
16:16:22 <gzhao> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:F2F-02-18-15 <-- f2f meeting slides
16:16:35 <ShaunWackerly> gzhao: thanks
16:17:20 <ShaunWackerly> #info dlenrow says a possible conflict is that ONF NBI decision may be slower
16:17:34 <ShaunWackerly> #info dlenrow says ONF can't slow down NIC
16:18:09 <ShaunWackerly> #info dlenrow presents possible solution to put approved (official) ONF info model fragments in ONF intent repo
16:18:50 <ShaunWackerly> #info dlenrow says a conversion tool could convert from official/non-official model fragments in ONF intent repo, to a format that NIC could consume
16:19:39 <ShaunWackerly> #info dlenrow says best case would be ONF defining broadly-adopted IM fragments
16:20:08 <ShaunWackerly> #info dlenrow says worst case is that ONF and ODL diverge information models (IMs)
16:20:15 <dbainbri> When is the ONF project officially starting its work?
16:20:35 <ShaunWackerly> dbainbri: please ask on audio, that's a good question
16:21:18 <ShaunWackerly> #info dlenrow suggests that we look at how to accomplish his proposed possible solution
16:22:00 <ShaunWackerly> #info dbainbri says that models have already diverged, since NIC has some code/yang and ONF does not
16:22:18 <ShaunWackerly> #info dlenrow says progress has been made on both sides, so we'll have some initial sync up work
16:23:07 <ShaunWackerly> #info dmentze asks why ONF folks wouldn't participate in NIC project
16:23:26 <colindixon> #link https://lists.opendaylight.org/pipermail/nic-dev/2015-February/000360.html this is a mailing list thread which has some conversation about the ONF/ODL interactions
16:23:26 <ShaunWackerly> #info dlenrow says he is chair of NBI working group, and colindixon and dbainbri are also working on ONF
16:23:48 <dbainbri> ich bin ONF
16:23:48 <ShaunWackerly> #info dmentze says that moving code out of NIC is not contributing
16:24:23 <dbainbri> (that was a joke and reference to JFK, btw)
16:24:50 <ShaunWackerly> #info dlenrow says goal of NBI is to develop a controller-agnostic NBI, and ODL is one of the controllers which should align with that NBI
16:25:08 <ShaunWackerly> #info dmentze says that defining the model is different than moving code
16:25:33 <ShaunWackerly> #info dlenrow says that he is not proposing to move code from NIC to ODL
16:26:07 <ShaunWackerly> #info dlenrow asks if we could get some people to work out details of how this might work
16:26:26 <ShaunWackerly> #info dmentze asks whether ideas or code are flowing from ONF to ODL
16:26:33 <ShaunWackerly> #info dlenrow says it is TBD
16:27:11 <ShaunWackerly> #info colindixon says that the definition could reside in ONF, then ODL could consume the information model (on the level of yang)
16:27:35 <ShaunWackerly> #info colindixon says that the code which implements the NBI could reside fully in NIC/ODL
16:28:05 <ShaunWackerly> #info colindixon says he can help dlenrow with details of how to accomplish this
16:29:00 <ShaunWackerly> #info colindixon asks if we agree that the goal is something we want
16:29:29 <ShaunWackerly> #info dbainbri says that phrobb identified some issues with 3rd party artifacts like this previously
16:30:36 <ShaunWackerly> #info colindixon says he thinks that we can find a way for it to work
16:30:50 * ShaunWackerly is getting lost
16:31:49 <ShaunWackerly> #info colindixon and dbainbri discuss details of how to keep artifact snapshots over time, so they aren't lost
16:32:05 <dbainbri> :)
16:32:17 * dbainbri gets more coffee
16:32:35 <ShaunWackerly> #info colindixon identifies some technical details, starting with licensing (apache vs EPL)
16:32:46 <ShaunWackerly> #info can go apache->EPL, but not EPL->apache
16:33:10 <ShaunWackerly> #info colindixon says this means ODL could never push code back to ONF
16:33:35 <ShaunWackerly> #info colindixon says intellectual property becomes an issue, between ODL and ONF (IP sharing)
16:33:52 <ShaunWackerly> #info dlenrow says linux foundation lawyers and other lawyers are sorting this out
16:34:39 <ShaunWackerly> #info dlenrow says that anyone can participate in ONF, so ODL members are not restricted
16:34:51 <dbainbri> so did we settle on model work being done in ONF GIT/REPO and then ODL will implement from that?
16:35:32 <dbainbri> also, given that intent is meant to be cross-controller API, will it be RESTCONF or support a customer (standard, cross-controller) API?
16:36:43 <ShaunWackerly> #info ShaunWackerly asks if non-ONF members need to join an ONF NBI to affect the NIC API
16:37:09 <ShaunWackerly> #info colindixon says that it would be an additional 1-hour per week, plus some email list stuff
16:38:32 <ShaunWackerly> #info dbainbri says that ODL is currently focused on implementation, ONF discussion is more academic right now
16:39:01 <ShaunWackerly> #info dlenrow says that we could split discussions along those lines (academic/implementation)
16:39:30 <ShaunWackerly> #info colindixon says that if you are only interested in 10% of a project, you are doing a disservice if you don't join the mailing list
16:39:51 <ShaunWackerly> #info colindixon implies that if ShaunWackerly does a good job taking notes, it will prevent that problem for NIC (personal commentary :) )
16:40:15 <ShaunWackerly> #info colindixon says we should make someone responsible for producing a project summary for each project per week
16:40:43 <ShaunWackerly> #info colindixon identifies another risk: what if ONF does weird things?
16:41:29 <ShaunWackerly> #info colindixon says that if NIC dislikes the ONF NBI, then we'd have a technical divergence
16:42:22 <ShaunWackerly> #info dmentze says that other problems like ONF moving too slow or ONF's NBI being unimplementable are other risks
16:42:38 <ShaunWackerly> #info colindixon mildly agrees, says those are forms of divergence
16:42:46 <dbainbri> There is a possibility of bleed the other way as well, i.e. ONF members start participating in NIC calls and then we spend a lot of separating academic discussion from implementation.
16:43:14 <ShaunWackerly> #info colindixon says the only way to stop divergence is to participate
16:43:42 <ShaunWackerly> #info dlenrow says the build process could omit some pieces of the NBI which are problematic, until there's time to implement them
16:44:24 <ShaunWackerly> #info colindixon says we shouldn't walk away from potential upsides because of potential downsides
16:44:55 <ShaunWackerly> #info colindixon says there is value to having academic input, if it can be maintained
16:45:09 <ShaunWackerly> #info dlenrow says the value is having a single interface that's larger than a single controller
16:45:34 <ShaunWackerly> #info dlenrow acknowledges that there are some risks and inconveniences
16:45:40 * dbainbri agrees that ONF has thought about this a while and can provide value from various perspectives that the NIC project people have not thought about. The trick is prioritizing that insight in terms of development
16:46:49 <colindixon> #info dbainbri agrees that ONF has thought about this a while and can provide value from various perspectives that the NIC project people have not thought about. The trick is prioritizing that insight in terms of development
16:47:09 <ShaunWackerly> #info ShaunWackerly asks if lithium API deliverable is in conflict with waiting for ONF NBI
16:48:52 <ShaunWackerly> #info dlenrow says that lithium API wouldn't necessarily be equivalent to ONF NBI
16:49:22 <ShaunWackerly> #info dlenrow says big picture goal is to have a common NBI
16:49:54 <ShaunWackerly> #info dmentze suggests that ONF ideas be shared, dlenrow says it is currently empty (repository)
16:50:06 <ShaunWackerly> #info dlenrow says they could use current NIC yang model as starting point
16:50:33 <ShaunWackerly> #info dlenrow says ODL isn't ready to start, dmentze says that NIC's yang isn't ready to go either
16:51:00 <ShaunWackerly> #info colindixon says the current yang model could be lifted from NIC
16:51:06 <mlemay> joining...
16:51:10 <ShaunWackerly> #info dmentze says the current model is not agreed upon
16:51:44 <ShaunWackerly> #info colindixon says that agreement within NIC may align with ONF timing for readiness
16:52:13 <ShaunWackerly> #info colindixon says it would be nice for ONF to publish a maven artifact
16:53:36 <ShaunWackerly> #info dmentze asks if NIC team has choice for what they pull from ONF
16:53:57 <ShaunWackerly> #info colindixon says ONF could do a weekly release of their model
16:54:23 <ShaunWackerly> #info dmentze objects to another group (ONF) making changes to a model that NIC has to support
16:54:47 <ShaunWackerly> #info colindixon says that as long as ONF produces release versions, there is no automatic tethering of NIC to ONF
16:55:03 <ShaunWackerly> #info dmentze says NIC could internally review and approve
16:55:50 <ShaunWackerly> #info colindixon says that ODL NIC could use augmentations to adapt ONF NBI (?)
16:56:33 <ShaunWackerly> #info mlemay says he proposed to ONF that the model should be totally decoupled from a language
16:57:11 <ShaunWackerly> #info mlemay says that ONF would be completely orthogonal, something like UML, that's mappable to NIC
16:57:39 <ShaunWackerly> #info mlemay says we may need a translation/shim/adapter for NIC ODL
16:58:16 <ShaunWackerly> #info dlenrow proposes discussion through email this next week
16:58:37 <ShaunWackerly> #info mlemay says he is trying to build a compiler which goes to intent instructions
16:59:06 <ShaunWackerly> *cough* policy engine *cough*
16:59:29 <ShaunWackerly> #info dbainbri asks if mlemay's proposal will compile from intent into OpenFlow, or something else
16:59:41 * dbainbri thinks that perhaps the ONF work being proposed is also the work that the NIC project thinks it is building
17:00:22 <ShaunWackerly> #info dlenrow says that mlemay's proposal is different from dlenrow's proposal
17:00:51 <ShaunWackerly> #info dmentze suggests we set up a separate discussion for discussing and deciding between proposals
17:01:41 <ShaunWackerly> #action dmentze will email to list regarding plan for making progress toward NIC lithium deliverables
17:02:32 <ShaunWackerly> #action mlemay and dlenrow will coordinate with colindixon and others to prepare summary of general approach being proposed
17:04:20 <ShaunWackerly> #action colindixon will work on the summary of the proposal
17:05:47 <ShaunWackerly> #info colindixon supports the notion of separating implementation discussion groups from API design
17:05:59 <ShaunWackerly> #endmeeting