15:02:46 <dbainbri> #startmeeting weekly-status
15:02:46 <odl_meetbot> Meeting started Fri Jul 10 15:02:46 2015 UTC.  The chair is dbainbri. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:46 <odl_meetbot> The meeting name has been set to 'weekly_status'
15:02:56 <adetalhouet> #chair adetalhouet
15:03:00 <adetalhouet> #chair dbainbri
15:03:03 <dbainbri> #chair adetalhouet
15:03:03 <odl_meetbot> Current chairs: adetalhouet dbainbri
15:04:31 <dbainbri> #info dbainbri
15:04:33 <hideyuki> #info Hideyuki Tai
15:04:38 <adetalhouet> #info adetalhouet
15:04:47 <adetalhouet> #topic Helium
15:05:05 <renato_aguiar> #info renato_aguiar
15:05:50 <adetalhouet> #info Cut off for Helium doesn't affect us as we don't have any patches
15:06:00 <adetalhouet> #topic Berylium
15:08:44 <adetalhouet> #info How to document action for each renderer type?
15:09:12 * gzhao is irc only, hope this is recorded.
15:09:26 <adetalhouet> gzhao: this is recorded
15:09:37 <gzhao> adetalhouet: thanks
15:09:40 <adetalhouet> gzhao: sorry I'm not good at taking minutes ...
15:10:09 <adetalhouet> #info dbainbri said we could have a different lead for each renderer?
15:10:24 <adetalhouet> #info dbainbri said we could have a lead for the control loop
15:10:57 <gzhao> adetalhouet: no worries, I will play back meeting recording.
15:11:05 <adetalhouet> #info lead would have to document the wiki and help folks on how to do
15:12:32 <adetalhouet> #info dbainbri: DSL concept means: intent can be express, so the tough was that we could threat all this expression as DSL
15:13:59 <adetalhouet> #info dbainbri the idea is one intent abstraction
15:15:06 <adetalhouet> #info two concept: 1. renderer that goes down to some common core abstraction (core policies) 2. Other project, as NEMO, could compile as Intent, but this couldn't be control
15:15:41 <adetalhouet> #info this will allow the renderer to implement Intent how they intend to do
15:17:14 <adetalhouet> #info Be will keep renderer's flexibility
15:19:51 <adetalhouet> #info Renderers should describe how the action behave, how they should be compose
15:20:29 <altonfong> #info
15:20:45 <adetalhouet> #info but for instance Action should be compatible with all renderers as we wan't to avoid incompatibility between actions
15:21:48 <adetalhouet> #info idea: have a compiler for each Renderers
15:23:41 <adetalhouet> #info idea: when a new action is added, a snippet could be added dynamically to each renderer (GBP, VTN, OF, ...)
15:25:55 <adetalhouet> #info we need a PL for each kind of renderer that will well define the scope for renderer, in wiki
15:28:07 <adetalhouet> #info need to be on the same page regarding terminology
15:30:05 <adetalhouet> #action Dave Lenrow to post the link to the draft document regarding Intent
15:30:35 <adetalhouet> #info Need volunteer to be PL and write wiki page for the Renderer feature
15:30:48 <adetalhouet> #undo
15:30:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3d310>
15:30:59 <adetalhouet> #info Need volunteer to be PL and write wiki page per Renderer feature
15:31:11 <adetalhouet> #topic Project Technical Lead
15:31:53 <adetalhouet> #info the TSC won't push this, so the thought is to do a checkpoint as each release
15:32:23 <adetalhouet> #info if we want to change PTL, someone can just self nominate by sending a mail to the mailing list
15:32:41 <adetalhouet> #info if no one self nominate, thing stays the same
15:32:58 <adetalhouet> #topic cookies
15:33:51 <adetalhouet> #endmeeting