15:08:30 <tbachman> #startmeeting of_plugin
15:08:30 <odl_meetbot> Meeting started Thu Nov  6 15:08:30 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:08:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:30 <odl_meetbot> The meeting name has been set to 'of_plugin'
15:08:43 <tbachman> #topic flow programming improvements
15:08:57 <tbachman> #info edwarnicke says there are 3 options for programming
15:09:16 <tbachman> #info 1) write state and then take action (FRM picks up state change and takes action by calling RPC to cause action to occur)
15:09:43 <tbachman> #info 2) take action then record state (RPC call is made, which then takes action and records the flow information in the data store)
15:10:13 <tbachman> #info 3) hybrid approach (but there could be challenges here)
15:11:01 <tbachman> #info edwarnicke says that for #3, someone writes state and you could take action on that or if they call the RPCs they can change the config state, but have to be careful not to wind up with loops
15:12:00 <tbachman> #info edwarnicke says he has additional ambitions for Lithium, based on things learned from Helium
15:12:46 <tbachman> #info michal_rehak says that pushing flows using the data store results in 100’s of flows/second
15:13:02 <tbachman> #info this shouldn’t happen, and he thinks there’s a bug here somewhere
15:13:33 <tbachman> #info michal_rehak says that the expensive thing is the beginning and closing of the transaction, so a difference is number of flows per transaction
15:14:44 <tbachman> #info abhijitkumbhare asks if there can be something wrong with the tests, as these results seem low compared to numbers reported by others (e.g. Jan)
15:15:03 <tbachman> #info edwarnicke says that part of it depends on what you’re doing to test stuff
15:15:47 <tbachman> #info For example, running against L2 Switch, and get so-and-so results — but these results may be terrible when using a tool such as CBench, b/c of the way L2 Switch is intended to be used
15:18:18 <tbachman> #info michal_rehak says there is a major optimization plan for statistics and writing things into the data store
15:20:16 <tbachman> #info michal_rehak says that there’s a bug where 1 transaction is used for 1 operation, which has poor results; one improvement is to bulk/batch the transactions, or have 1 thread writing the data store (no merging conflicts b/c only a single thread writing)
15:21:32 <tbachman> #info CM says that compared to the hydrogen release, the helium release seems to have hit some bottlenecks
15:22:00 <tbachman> #info CM says that using hydrogen, they were able to scale to about 5k or 6k flows/s using the drop test
15:22:13 <tbachman> #info using the drop test with Helium, that scales to a max of about 1k
15:22:39 <tbachman> #info edwarnicke says that there are peole measuring 50-100k flows/s on laptops
15:23:34 <tbachman> #info edwarnicke asks what features CM is loading
15:23:41 <tbachman> #info CM says that they are only loading the drop test
15:24:00 <tbachman> #info edwarnicke says he’d like to look at this, possibly over a webex, as this is inconsistent with what others are seeing
15:24:41 <tbachman> #info CM says that hey disabled a lot of logs
15:24:50 <tbachman> #info edwarnicke asks what kind of log messages were seen
15:24:57 <tbachman> #info CM says he will have to get that information
15:25:33 <tbachman> #info edwarnicke says that there’s a bug in the OVSDB project that’s causing log messages
15:26:55 <tbachman> #action CM to send email to the list on this, and ping edwarnicke on IRC to coordinate debugging this problem
15:27:59 <tbachman> #topic multiple nodes
15:28:27 <tbachman> #info edwarnicke says that after looking at the APIs, there are some changes that we might want to consider, keeping in mind that we need to support existing users
15:28:44 <tbachman> #info These changes relate to connection management, message ordering management, and translation
15:29:10 <tbachman> #info edwarnicke says it would be nice to allow people to plug in their own codecs
15:30:08 * tbachman wasn’t sure what the actual topic was (couldn’t hear, so did that one)
15:30:40 <tbachman> #info abhijitkumbhare asks if edwarnicke could write up something on this
15:30:51 <tbachman> #info edwarnicke said he’d like to discuss this here first
15:31:23 <tbachman> #info michal_rehak says this sounds like it might be a good idea
15:31:38 <abhijitkumbhare> tbachman - thanks for doing the minutes - was not even aware we had the IRC chat going
15:32:05 <tbachman> abhijitkumbhare: my pleasure :)
15:32:45 <tbachman> is it mawil ?
15:33:04 <abhijitkumbhare> That is Mouli
15:33:07 <tbachman> ah
15:33:20 <abhijitkumbhare> Its Chandramouli - but Mouli for short
15:33:25 <tbachman> wasn’t sure what nic to use, so just used CM (which is what it is on WebEx)
15:33:52 <tbachman> #info edwarnicke asks if CM could provide the output of feature:list -i
15:34:12 <tbachman> #action Mouli to provide this output
15:34:16 <tbachman> #undo
15:34:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2833b50>
15:34:29 <tbachman> #action Mouli to provide the ouptut of feature:list -i to edwarnicke
15:34:41 <abhijitkumbhare> #info Have captured the potential Lithium items from the design summit here:
15:34:45 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Potential_Lithium_Items
15:35:03 <tbachman> #chair abhijitkumbhare
15:35:03 <odl_meetbot> Current chairs: abhijitkumbhare tbachman
15:35:28 <tbachman> #info edwarnicke says that the performance of the openflowplugin has improved rapidly in Helium, based on what he’s seen
15:35:54 <tbachman> #info Mouli asks what the enhancements were made in Helium
15:36:07 <tbachman> #info edwarnicke says he doesn’t have that list, but there was a huge amount of work done there
15:36:15 <tbachman> #info Mouli asks if there’s a wiki that may capture this
15:36:29 <abhijitkumbhare> #info Also added the Helium backlog here:
15:36:33 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Backlog
15:36:39 <tbachman> abhijitkumbhare: thx!
15:36:50 <abhijitkumbhare> #info Please update these links
15:39:12 <tbachman> #info edwarnicke points out that openflowplugin is the “poster child” for needing more time up front, as there are many consumers/players involved
15:40:25 <tbachman> #info abhijitkumbhare asks if we should sort out the Lithium features here
15:42:26 <tbachman> #info abhijitkumbhare says one of the features that folks wanted was the ability to subscribe to a particular packet_in
15:42:45 <tbachman> #info abhijitkumbhare says we should look into adding that to the Lithium release
15:44:16 <tbachman> #info edwarnicke says we may want to look at what l2switch does, as that might be a good start
15:44:28 <tbachman> #info abhijitkumbhare says we could also look at what linux does with iptables
15:44:59 <tbachman> #info edwarnicke says there they have to still do a full decode of the packet
15:45:53 <tbachman> #info abhijitkumbhare says another feature is openflow 1.4 support
15:46:28 <tbachman> #info one particular feature that looks particularly interesting is the possibility to have bundles, where a group of openflow messages can be applied as a single operation
15:48:33 <tbachman> #info abhijitkumbhare asks if it’s possible to pick up features for 1.4 as extensions for 1.3
15:48:43 <tbachman> #info edwarnicke asks if abhijitkumbhare can present what’s possible in 1.4
15:48:51 <tbachman> #info abhijitkumbhare says yes, but not next week
15:49:37 <tbachman> #info edwarnicke says we need to figure out what we’re doing for High Availability — this may turn into requests to the clustering team
15:51:04 <tbachman> #info This includes Role Request messages
15:55:57 <mawil> i'm not mouli :)
15:56:05 <tbachman> mawil: sorry! :)
15:56:06 <tbachman> lol
15:56:11 * tbachman is NIC-spamming
15:56:18 <mawil> np
15:58:26 <tbachman> #info edwarnicke says there is the configuration state, which is what the state we’re trying to get to
15:58:36 <tbachman> #info the other is the operational state, which is whatever the switch tells us
15:58:54 <tbachman> #info edwarnicke says that for the “what should be the source of truth”, he feels that should be the controller
15:59:03 <tbachman> #info Mouli agress with edwarnicke on this point
15:59:46 <tbachman> #endmeeting