14:01:30 <abhijitkumbhare> #startmeeting OF Plugin Daily scrum
14:01:30 <odl_meetbot> Meeting started Fri Aug 15 14:01:30 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:01:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:30 <odl_meetbot> The meeting name has been set to 'of_plugin_daily_scrum'
14:02:05 <abhijitkumbhare> #chairs michal_rehak edwarnicke oflibMichal v_demcak vishnoianil
14:03:11 <michal_rehak> #info michal_rehak
14:03:12 <abhijitkumbhare> #info abhijitkumbhare
14:03:16 <oflibMichal> #info oflibMichal
14:03:18 <michal_rehak> abhijitkumbhare: reviewing
14:04:01 <abhijitkumbhare> OK - but I believe the build is not stable on 9214
14:04:32 <abhijitkumbhare> #info Have moved several Trello items to be “to do - not discussing today” to streamline the meeting
14:06:03 <abhijitkumbhare> But there are some new bugs which have come up - have not had a chance to go thru them yet
14:06:56 <abhijitkumbhare> #link
14:06:56 <abhijitkumbhare> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate%2Cpriority%2Cbug_severity&deadlineto=2014-09-30&list_id=13400&order=bug_severity%2Cassigned_to%2Cpriority&product=openflowplugin&query_based_on=&que
14:06:57 <abhijitkumbhare> ormat=advanced&resolution=---
14:08:23 <abhijitkumbhare> The first one (https://bugs.opendaylight.org/show_bug.cgi?id=1421) we do not have Kamal here - but he was planning a solution for this
14:09:49 <abhijitkumbhare> #info Bug 1491 - OF plugin does not handle SET_TP_SRC/SET_TP_DST actions
14:10:03 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1491
14:10:46 <abhijitkumbhare> michal_rehak: this is assigned to Timotej Kubas (I believe by you)
14:11:16 <abhijitkumbhare> Do you know the status of this?
14:12:15 <michal_rehak> timo will work on that starting on Monday
14:12:22 <michal_rehak> today we discussed details
14:13:06 <abhijitkumbhare> Yes - there are comments on the bug from you today
14:13:12 <michal_rehak> he will write a hotfix in ActionConverter in order to ship the change port action as set-field encapsulated stuff if of-1.3
14:13:32 <michal_rehak> and later we will clean md-sal models and fix that in sal-compatibility
14:13:46 <michal_rehak> I hope it will be done by Tuesday
14:14:10 <michal_rehak> deadline is Friday
14:14:12 <abhijitkumbhare> OK - will that require API change?
14:14:15 <abhijitkumbhare> OK
14:15:40 <michal_rehak> no, no external changes
14:15:54 <michal_rehak> just new else-if block
14:17:19 <avishnoi> #info avishnoi
14:17:26 <abhijitkumbhare> #action Bug 1491: Timotej Kubas will write a hotfix in ActionConverter in order to ship the change port action as set-field encapsulated stuff if of-1.3 and later we will clean md-sal models and fix that in sal-compatibility - deadline Aug 22 (Friday) - but trying to finish by the Tuedsay before.
14:17:39 <abhijitkumbhare> OK - michal_rehak
14:17:48 <abhijitkumbhare> Hello avishnoi
14:17:54 <avishnoi> hi abhijitkumbhare
14:18:05 <abhijitkumbhare> Hi kamal_rameshan - can you info in?
14:18:25 <kamal_rameshan> #info kamal_rameshan
14:19:19 <abhijitkumbhare> kamal_rameshan About https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:20:19 <abhijitkumbhare> When do you think you will be done on that?
14:20:35 <kamal_rameshan> Yes, i am working on it. Couldnt test yesterday as the OFP controller had datastore errors
14:21:13 <kamal_rameshan> If datastore errors are resolved, i was planning to get it done by today EOD
14:21:23 <abhijitkumbhare> Also that solution - do you see any issues?
14:22:25 <abhijitkumbhare> anyway - we can move to the next one
14:22:33 <kamal_rameshan> I think Luis too mentioned the same in his email
14:22:39 <abhijitkumbhare> OK
14:22:53 <abhijitkumbhare> the datastore issues?
14:22:59 <abhijitkumbhare> Yes - I saw that
14:23:30 <abhijitkumbhare> michal_rehak & oflibMichal  - do you know anything about the fix to those?
14:24:14 <oflibMichal> I don't
14:24:40 <abhijitkumbhare> Anyone working on it?
14:24:49 <michal_rehak> abhijitkumbhare: it is working for me - locally
14:24:57 <abhijitkumbhare> Because it looks very urgent
14:25:06 <michal_rehak> abhijitkumbhare: I have newest yangtools and altered md-sal
14:25:53 <abhijitkumbhare> Can you reply back on Luis’ email? So will his issues go away if he pulls the latest code?
14:26:00 <michal_rehak> abhijitkumbhare: let me try with md-sal from mastetr
14:26:05 <abhijitkumbhare> OK
14:26:24 <kamal_rameshan> michal_rehak: i too have the latest yang-tools, controller, ofjava and ofplugin.  But i am facing the same issue
14:26:36 <michal_rehak> I discussed that with Ed - he retriggered integration jenkins build for base-of13 but with no possitive effect
14:28:15 <abhijitkumbhare> Luis suspects https://git.opendaylight.org/gerrit/#/c/9757/ (Tony) & https://git.opendaylight.org/gerrit/#/c/9747/ (Martin Bobak)
14:28:20 <abhijitkumbhare> As per his email
14:30:02 <abhijitkumbhare> OK - lets move on to the next one:
14:30:21 <kamal_rameshan> abhijitkumbhare : can you merge #link https://git.opendaylight.org/gerrit/#/c/9214/ when you get a chance.
14:30:30 <abhijitkumbhare> #info Bug 537 - Node Status reconciliation between controller/switch on switch reconnect, fix datastore lifecycle
14:32:23 <abhijitkumbhare> OK - kamal_rameshan - after the meeting (michal_rehak was also reviewing the addition OrderComparatorTest)
14:33:17 <kamal_rameshan> abhijitkumbhare - oh ok.  thanks
14:33:18 <abhijitkumbhare> v_demcak: what’s the status of https://bugs.opendaylight.org/show_bug.cgi?id=537 ?
14:34:30 <abhijitkumbhare> is v_demcak around?
14:35:22 <abhijitkumbhare> OK - that looks to be on https://git.opendaylight.org/gerrit/#/c/8174/
14:35:57 <abhijitkumbhare> And v_demcak is going to be done end of the week for that
14:36:16 <abhijitkumbhare> to have the regression tests fixed
14:36:44 <abhijitkumbhare> #info Bug 1088 - flow id in operational not matched; after removal not removed completely
14:36:58 <abhijitkumbhare> avishnoi: any status on this?
14:37:03 <michal_rehak> kamal_rameshan: 9214 merged
14:37:18 <v_demcak> abhijitkumbhare: hi, https://git.opendaylight.org/gerrit/#/c/8174/ needs regresion test fixed
14:37:21 <abhijitkumbhare> OK it requires 8174 merge
14:37:35 <kamal_rameshan> michal_rehak: thanks :)
14:38:47 <abhijitkumbhare> v_demcak: are you on track for regression tests fixed for https://git.opendaylight.org/gerrit/#/c/8174/  end of the week (which is now)?
14:39:23 <avishnoi> abhijitkumbhare: working on 1088
14:39:35 <kamal_rameshan> michal_rehak: if you to  review and have comments on the 1421 design suggestion (made over email), please let me know
14:41:15 <abhijitkumbhare> #info Bug 1526 - RESTCONF POST fails with java.lang.IllegalArgumentException (Child is not present in tree)
14:41:28 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1526
14:42:22 <abhijitkumbhare> michal_rehak: is this fixed?
14:45:24 <abhijitkumbhare> The status shows as waiting for review
14:46:13 <michal_rehak> abhijitkumbhare: I still didn't test
14:46:32 <abhijitkumbhare> michal_rehak: Jozef G thinks it was solved by https://git.opendaylight.org/gerrit/#/c/9684/
14:46:44 <michal_rehak> abhijitkumbhare: dataStore was buggy today
14:46:54 <michal_rehak> abhijitkumbhare: right - I need to be sure
14:47:20 <abhijitkumbhare> OK - I believe ed is on a call regarding the datastore issue
14:48:21 <michal_rehak> abhijitkumbhare: yes - I am there too :-(
14:49:37 <abhijitkumbhare> OK - so who all is on the call? do you guys want to move our bug scrub to Monday?
14:56:54 <abhijitkumbhare> since robert varga, jan medved, vaclav, ed and michal rehak are on the other call - to fix the datastore issue - we can end the meeting & continue on Monday
14:57:49 <abhijitkumbhare> #endmeeting