14:10:47 <abhijitkumbhare> #startmeeting OF Plugin daily scrum Aug-8
14:10:47 <odl_meetbot> Meeting started Fri Aug  8 14:10:47 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:10:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:10:47 <odl_meetbot> The meeting name has been set to 'of_plugin_daily_scrum_aug_8'
14:10:55 <edwarnicke> #info edwarnicke
14:11:02 <oflibMichal> #info oflibMichal
14:11:09 <abhijitkumbhare> #info abhijitkumbhare
14:11:43 <abhijitkumbhare> Sorry guys - I was just adding some of the action items to the Trello
14:11:51 <edwarnicke> phrobb1: Nobody is fooled by your new alias ;)
14:12:08 <edwarnicke> abhijitkumbhare: Could you #link in the Trello ?
14:12:26 <abhijitkumbhare> #linbk https://trello.com/b/TtnyEJZr/helium-release
14:12:32 <abhijitkumbhare> #link https://trello.com/b/TtnyEJZr/helium-release
14:12:52 <kamal_rameshan> #info kamal_rameshan
14:12:58 <edwarnicke> abhijitkumbhare: Coffee.. I recommend coffee :)
14:13:06 <abhijitkumbhare> Yes :-)
14:13:48 <abhijitkumbhare> Although - I am finding driving in to the office before 7 am very refreshing :-)
14:13:59 <abhijitkumbhare> Less traffic
14:14:01 <edwarnicke> abhijitkumbhare: Shall we start with a quick agenda bashing topic ? #topic Agenda Bashing ?
14:14:15 <abhijitkumbhare> #topic Agenda Bashing
14:14:16 <edwarnicke> abhijitkumbhare: What is this 'office' of which you speak ;)
14:14:37 <edwarnicke> abhijitkumbhare: I presume as the keeper of the Trello you have some suggestions for the agenda?
14:14:41 <abhijitkumbhare> I know - you work from home guys have it so nice :-)
14:14:56 <abhijitkumbhare> Just going over the action items
14:15:24 <abhijitkumbhare> Were we done on "Jan's scripts against https://git.opendaylight.org/gerrit/#/c/8174"?
14:15:40 <abhijitkumbhare> Yesterday - I mean
14:15:48 <abhijitkumbhare> Yes - we were
14:15:57 <abhijitkumbhare> We were going to merge it
14:16:14 <abhijitkumbhare> Is that merged edwarnicke ?
14:16:46 <abhijitkumbhare> That was one of the actions: edwarnicke to review (and unless there is a bad late breaking issue) merge https://git.opendaylight.org/gerrit/#/c/8174/
14:17:04 <edwarnicke> It is not merged
14:17:07 <abhijitkumbhare> OK
14:17:08 <edwarnicke> Downloading to try it out now
14:17:11 <abhijitkumbhare> OK
14:17:24 <edwarnicke> abhijitkumbhare: Maybe we should queue up the agenda first and then run through it
14:17:31 <abhijitkumbhare> Sure
14:17:41 <abhijitkumbhare> I think the items for the agenda are:
14:17:44 <edwarnicke> Sort of walk through the items in Trello during the Agenda Bashing topic and then see if anything is missing
14:17:52 <edwarnicke> Could you #info them?
14:18:08 <abhijitkumbhare> #info Agenda items
14:18:18 <abhijitkumbhare> #info 1) Going thru the Trello actions
14:18:57 <abhijitkumbhare> #info 2) Performance discussions continued
14:19:06 <abhijitkumbhare> #info 3) Bugs list
14:19:20 <abhijitkumbhare> Meant bug scrub
14:19:38 <edwarnicke> abhijitkumbhare: #undo will remove the last #ed action so you can redo it
14:19:40 <abhijitkumbhare> #info 4) Any follow up on the VTN problems?
14:20:00 <abhijitkumbhare> Anything else?
14:20:00 <edwarnicke> Folks... anything else?
14:20:04 <edwarnicke> LOL
14:20:12 <edwarnicke> That sounds good to me
14:20:45 <abhijitkumbhare> So - how do we change topic - by #topic?
14:20:54 <edwarnicke> Just #topic <new topic>
14:21:05 <abhijitkumbhare> #topic Trello actions
14:21:29 <abhijitkumbhare> Before I do that - how do I add chairs ?
14:22:08 <edwarnicke> You can do #chair <nick>
14:22:20 <abhijitkumbhare> #chair edwarnicke , kamal_rameshan , oflibMichal , vishnoianil
14:22:20 <odl_meetbot> Current chairs: abhijitkumbhare edwarnicke kamal_rameshan oflibMichal vishnoianil
14:23:23 <abhijitkumbhare> The trello action: Avishnoi review https://git.opendaylight.org/gerrit/#/c/8174
14:23:31 <abhijitkumbhare> That is done - correct?
14:23:57 <abhijitkumbhare> Moving it to done
14:24:05 <edwarnicke> abhijitkumbhare: Could you #info that?
14:24:20 <edwarnicke> The stuff that is #info ed bubbles up to the summary for the topic
14:24:33 <abhijitkumbhare> #info moving to done trello action: Avishnoi review https://git.opendaylight.org/gerrit/#/c/8174
14:25:06 <abhijitkumbhare> #info NXM stats issue - vishnoianil to look at on Tuesday
14:25:11 <kamal_rameshan> I dont see visnoianil in the #info, not sure he joined
14:25:47 <abhijitkumbhare> I see him online - but not joined I guess
14:25:53 <edwarnicke> kamal_rameshan: True... but he +1ed the patch :)
14:26:26 <abhijitkumbhare> kamal_rameshan - anything about "Action ordering bug: https://bugs.opendaylight.org/show_bug.cgi?id=1338 there is a partial fix at https://git.opendaylight.org/gerrit/#/c/9214/"?
14:26:45 <kamal_rameshan> I have tested the patch. It works,
14:26:52 <edwarnicke> kamal_rameshan: There is a *decent* chance that simply works
14:26:58 <kamal_rameshan> I hve also modified the patch to make it generic
14:27:00 <abhijitkumbhare> :-)
14:27:09 <kamal_rameshan> and given it for review
14:27:11 <abhijitkumbhare> OK
14:27:15 <edwarnicke> kamal_rameshan: That is awesome... I was going to ask next that we look at *other* ordered things :)
14:27:35 <kamal_rameshan> edwarnicke: it takes care of action
14:27:44 <kamal_rameshan> instruction and tablefeatures as of now
14:27:52 <edwarnicke> kamal_rameshan: I am sorry to say this
14:28:08 <edwarnicke> kamal_rameshan: Hang on... let me think
14:28:35 <abhijitkumbhare> So - kamal_rameshan - is there anything else it needs to take care of?
14:28:56 <edwarnicke> kamal_rameshan: I need to ask a couple of questions on this to understand if it gets past API freeze
14:29:01 <kamal_rameshan> edwarnicke: i dont think so
14:29:38 <edwarnicke> It *looks* like what you did will result only in the creation of a new interface Ordered
14:29:53 <kamal_rameshan> Yes, to make it generic.
14:30:05 <kamal_rameshan> So that all ordered items will have one comparator
14:30:09 <edwarnicke> And that everyplace we had a getOrder setOrder still has a getOrder setOrder
14:30:28 <edwarnicke> So this looks like its simply an interface add
14:30:46 <kamal_rameshan> in the controller , yes
14:30:51 <abhijitkumbhare> so we are good - right?
14:31:14 <kamal_rameshan> edwarnicke: you can push your review comments and i can address them
14:31:25 <edwarnicke> abhijitkumbhare: I think this will be fine, but in the spirit of making folks comfortable... I'd kind of like to run it quickly through the API change process to let folks know
14:31:33 <abhijitkumbhare> Sure
14:31:34 <edwarnicke> abhijitkumbhare: Just so there's no nervousness with our consumers
14:31:48 <abhijitkumbhare> Its actually good to remind everyone
14:32:07 <abhijitkumbhare> about the nitty gritty of the API freeze
14:32:45 <abhijitkumbhare> is there a change in interface or an addition of interface?
14:33:07 <kamal_rameshan> Its an addition of  an Interface named Ordered
14:33:14 <abhijitkumbhare> OK
14:33:19 <edwarnicke> kamal_rameshan: The only change really is that we get a new interface that is applied everywhere... the actual methods at the end are the same, corerct?
14:33:32 <kamal_rameshan> edwarnicke: Yes, indeed
14:33:43 <edwarnicke> kamal_rameshan: Would you be willing to kick off the API Freeze consultation process if I point you to it?
14:34:05 <kamal_rameshan> edwarnicke: Yes, i will
14:34:17 <kamal_rameshan> although i will have some questions around it :)
14:34:27 <abhijitkumbhare> Do you want #action this?
14:34:37 <edwarnicke> kamal_rameshan: Make sure to point out this is actually only an interface add... and so *technically* doesn't require agreement... but we want to be good neighbors :)
14:35:19 <kamal_rameshan> ok, sounds good. Please let me know whom do i ask/let know. wahts the process..?
14:35:35 <abhijitkumbhare> OK - I will #action kamal_rameshan
14:36:10 <edwarnicke> abhijitkumbhare: And set up a Trello?
14:36:32 <abhijitkumbhare> #action edwarnicke to point kamal_rameshan to the API Freeze consultation process
14:36:36 <edwarnicke> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium:Suggestions_for_Post_API_Freeze_Exception_Handling -
14:36:36 <abhijitkumbhare> Yes
14:37:08 <abhijitkumbhare> I will skip adding Trello items for things already done during the meeting time
14:37:49 <edwarnicke> abhijitkumbhare: That's fair :)
14:38:03 <abhijitkumbhare> #action kamal_rameshan to kick off the API Freeze consultation process for addition of an Interface named Ordered (even though technically not required)
14:38:42 <abhijitkumbhare> #undo
14:38:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2621c90>
14:38:58 <abhijitkumbhare> #action kamal_rameshan to kick off the API Freeze consultation process for addition of an Interface named Ordered (even though technically not required as it is addition)
14:39:18 <abhijitkumbhare> So shall we move to performance?
14:39:57 <edwarnicke> Sure :)
14:40:07 <abhijitkumbhare> #topic performance
14:41:00 <abhijitkumbhare> jmedved - I have forgotten where we were yesterday with respect to this - we needed to continue to discuss a few things
14:43:09 <abhijitkumbhare> Any update after your email: https://lists.opendaylight.org/pipermail/openflowplugin-dev/2014-August/001739.html
14:43:13 <edwarnicke> abhijitkumbhare: I don't think we have Jan here today
14:43:39 <abhijitkumbhare> I thought I saw him join - a few min back. May be we move then
14:44:02 <abhijitkumbhare> Bugs list?
14:44:03 <kamal_rameshan> i guess , as per Jan, he needed someone to work on FRM
14:44:32 <abhijitkumbhare> Do we have anyone to work on the FRM?
14:44:39 <edwarnicke> abhijitkumbhare: I'll rustle him up for Monday
14:44:42 <abhijitkumbhare> OK
14:45:31 <abhijitkumbhare> #topic Bug scrub & bug list
14:45:39 <kamal_rameshan> anywork to be doneon FRM , should be over 8174
14:45:59 <abhijitkumbhare> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&deadlineto=2014-09-30&list_id=13400&product=openflowplugin&query_format=advanced&resolution=---
14:46:27 <edwarnicke> Looks like we have 38 bugs outstanding
14:46:47 <abhijitkumbhare> #info the above is the query for bugs which are not enhancements - and have deadline before 9/30
14:47:07 <edwarnicke> abhijitkumbhare: Do we know that deadline is the right thing to restrict by?
14:47:21 <abhijitkumbhare> #info if we need to defer any bug - lets put the deadline to be Oct
14:47:27 <edwarnicke> Cool
14:47:41 <abhijitkumbhare> Just something for us
14:47:42 <edwarnicke> Are we picking up bugs without deadlines set as well?
14:47:49 <abhijitkumbhare> Yes - it does
14:48:05 <edwarnicke> Cool
14:48:10 <edwarnicke> abhijitkumbhare: How would you like to walk through it?
14:48:46 <abhijitkumbhare> To be honest - we may have to play with the query in case there are bugs in the way I am querying
14:49:01 <abhijitkumbhare> Sure
14:49:09 <edwarnicke> abhijitkumbhare: Cool... but lets start with what we have
14:49:30 <abhijitkumbhare> Shall we first go to the unassigned bugs?
14:49:52 <kamal_rameshan> Or we can go by priority
14:50:10 <abhijitkumbhare> OK - unassigned then priority?
14:50:21 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:50:38 <kamal_rameshan> ok..
14:51:12 <abhijitkumbhare> Is this the one from Hideyuki that you were looking at kamal_rameshan ?
14:51:25 <edwarnicke> abhijitkumbhare: This I think is the vtn one hideyuki needs
14:51:52 <kamal_rameshan> I have not startted looking at it yet.
14:52:01 <kamal_rameshan> i can take it up if no one has started working on it
14:52:03 <abhijitkumbhare> OK
14:52:19 <edwarnicke> abhijitkumbhare: Shall we assign it to kamal_rameshan then and create a Trello for it?
14:52:21 <abhijitkumbhare> Is it OK for now I assign to you?
14:52:57 <kamal_rameshan> abhijitkumbhare: Yes...please assign it to me
14:53:02 <abhijitkumbhare> OK
14:53:51 <abhijitkumbhare> #action kamal_rameshan https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:54:24 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1403
14:54:50 <abhijitkumbhare> It no longer happens - right?
14:54:58 <abhijitkumbhare> Topology broken?
14:56:09 <abhijitkumbhare> Is this something one of the Pantheon folks can look into edwarnicke ?
14:56:16 <abhijitkumbhare> And close?
14:56:44 <edwarnicke> abhijitkumbhare: Let me look at integration tests to see if its still happening
14:56:53 <abhijitkumbhare> OK
14:58:37 <edwarnicke> OK... looking at the integration tests
14:58:46 <edwarnicke> We have occasional fails on AD-SAL Topology
14:58:54 <edwarnicke> But MD-SAL topology looks solid
14:58:58 <abhijitkumbhare> OK
14:59:02 <edwarnicke> I suspect this may be a bundle ordering issue
14:59:16 <edwarnicke> Where the AD-SAL Topology hasn't come up when we initiall report
14:59:21 <edwarnicke> initially
14:59:45 <abhijitkumbhare> But the reported bug is MD-SAL topology
14:59:54 <edwarnicke> That one I would close
15:00:00 <edwarnicke> Because the integration tests aren't failing on it
15:00:03 <abhijitkumbhare> Shall we ask Luis to create a new one for AD-SAL
15:00:08 <edwarnicke> It reliably passes
15:00:10 <edwarnicke> Please
15:00:12 <abhijitkumbhare> OK
15:01:04 <abhijitkumbhare> We are at 8 am - and others are not there today - do we want to continue or do we want to continue on Monday?
15:01:45 <kamal_rameshan> i think assignment of bugs can be done when we have others as well
15:02:05 <abhijitkumbhare> Yes - my thoughts exactly
15:03:13 <abhijitkumbhare> So lets continue on Monday - there are only two unassigned bugs https://bugs.opendaylight.org/show_bug.cgi?id=1300 & https://bugs.opendaylight.org/show_bug.cgi?id=1395.
15:03:51 <abhijitkumbhare> We also need to start update & giving feedback on the documentation
15:04:14 <abhijitkumbhare> To Sujatha
15:04:29 <edwarnicke> abhijitkumbhare: Create Trello for it so we can review on Monday :)
15:04:36 <abhijitkumbhare> Yes
15:04:56 <abhijitkumbhare> OK - lets endmeeting now
15:05:07 <abhijitkumbhare> #endmeeting