14:02:57 <abhijitkumbhare> #startmeeting OF Plugin meeting
14:02:57 <odl_meetbot> Meeting started Tue Sep  9 14:02:57 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:02:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:57 <odl_meetbot> The meeting name has been set to 'of_plugin_meeting'
14:03:25 <abhijitkumbhare> #info abhijitkumbhare
14:03:43 <abhijitkumbhare> Can you guys # info in?
14:03:46 <kamal_rameshan> #info kamal_rameshan
14:04:05 <vishnoianil> #info vishnoianil
14:04:10 <abhijitkumbhare> Lets discuss the topics we want to cover today
14:04:19 <abhijitkumbhare> Bugs
14:04:22 <vishnoianil> abhijitkumbhare: i have hard stop at 8
14:04:26 <abhijitkumbhare> OK
14:04:47 <abhijitkumbhare> Issues other projects are having
14:04:58 <abhijitkumbhare> What else?
14:05:47 <abhijitkumbhare> Let's start with the issues other projects are having
14:06:33 <abhijitkumbhare> SFC is having issues regarding match
14:06:47 <abhijitkumbhare> Let me try to dig up the thread
14:07:39 <abhijitkumbhare> The following is the issue:
14:07:40 <abhijitkumbhare> https://lists.opendaylight.org/pipermail/openflowplugin-dev/2014-September/001908.html
14:08:03 <abhijitkumbhare> oflibMichal had responded on it
14:10:27 <abhijitkumbhare> Any thoughts anyone?
14:11:21 <abhijitkumbhare> welcome prasanna
14:11:35 <prasanna> Hi abhijitkumbhare
14:12:00 <michal_rehak> #info michal_rehak
14:12:05 <prasanna> #info prasanna
14:12:12 <abhijitkumbhare> prasanna you are in good time - can you take a look at the thread https://lists.opendaylight.org/pipermail/openflowplugin-dev/2014-September/001908.html and see if anything strikes you?
14:12:50 <abhijitkumbhare> Lets move to the bug list
14:12:55 <abhijitkumbhare> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&deadlineto=2014-09-30&list_id=13400&product=openflowplugin&query_format=advanced&resolution=---
14:13:57 <abhijitkumbhare> vishnoianil - do you have any updates that you want to share before you have to go?
14:14:03 <michal_rehak> abhijitkumbhare: the mailinglist issue looks like someone forgot to call .value() method on MacAddress DTO and uses in fact .toString() all the time which yelds MacAddress[...]
14:14:28 <abhijitkumbhare> OK - great
14:14:53 <abhijitkumbhare> can you respond to them as they are blocked on this?
14:15:06 <prasanna> Sure
14:15:19 <abhijitkumbhare> great! thx prasanna
14:15:46 <prasanna> michal_rehak is right
14:15:54 <prasanna> michal_rehak are you responding.
14:16:19 <abhijitkumbhare> OK - one of you can respond :)
14:16:38 <abhijitkumbhare> michal_rehak & kamal_rameshan - the next one https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:17:06 <abhijitkumbhare> actually michal_rehak on that one
14:17:08 <michal_rehak> prasanna: sorry - it would take ages for me to find that mail, if you would be so kind and respond, that would be great
14:17:09 <vishnoianil> abhijitkumbhare: no, nothing as such
14:17:14 <michal_rehak> 1421 is in progress
14:17:20 <abhijitkumbhare> OK
14:17:33 <prasanna> Sure..... michal_rehak
14:17:38 <michal_rehak> it looks like there is one issue in OFJava - something with buffer - there we miss one match
14:17:39 <michal_rehak> and
14:17:44 <michal_rehak> prasanna: thank you
14:17:45 <abhijitkumbhare> I see his last comment - which indicates its a bit better - but not completely done
14:18:03 <michal_rehak> and ovs shows wrong value in cli
14:18:10 <michal_rehak> in statistics it is correct
14:18:11 <abhijitkumbhare> OK
14:18:20 <michal_rehak> but the second flow is trouble
14:18:26 <michal_rehak> works only against cpqd
14:18:38 <michal_rehak> ovs return bad flow error message
14:19:02 <abhijitkumbhare> OK - so must be something that cpqd does as per the spec that ovs does not - but we live in an ovs world
14:19:28 <abhijitkumbhare> (or at least ovs world as well - lest someone gets offended)
14:19:41 <michal_rehak> something with unsupported tag/encap
14:20:05 <abhijitkumbhare> OK
14:20:17 <prasanna> abhijitkumbhare I think we need to document these OVS an CPQD shortcomings some where..... we had the xls sheet
14:20:35 <abhijitkumbhare> sounds like a good idea
14:20:48 <abhijitkumbhare> perhaps we can create a wiki
14:20:48 <prasanna> we had some of these documented in that xls sheet that we used during hydrogen time
14:21:02 <abhijitkumbhare> don't remember that
14:22:07 <abhijitkumbhare> #action abhijitkumbhare add wiki for a list of OVS or CPQd specific issues - have everyone contribute to that
14:22:32 <abhijitkumbhare> OK the next one : https://bugs.opendaylight.org/show_bug.cgi?id=1765
14:23:06 <michal_rehak> abhijitkumbhare: 1421 update: same error occurs  in ovs-2.3.0 - latest release
14:23:15 <abhijitkumbhare> OK
14:23:30 <prasanna> abhjitkumbhare https://docs.google.com/spreadsheet/ccc?key=0AtpUuSEP8OyMdHNTZjBoM0VjOE9BcGhHMzk3N19uamc&usp=sharing%23gid=2#gid=7
14:24:07 <abhijitkumbhare> OK - prasanna
14:24:51 <abhijitkumbhare> #info Some of the OVS/CPQd specific issues documented in  https://docs.google.com/spreadsheet/ccc?key=0AtpUuSEP8OyMdHNTZjBoM0VjOE9BcGhHMzk3N19uamc&usp=sharing%23gid=2#gid=7 (pointed by prasanna )
14:25:34 <abhijitkumbhare> kamal_rameshan - how does your schedule look?
14:25:57 <abhijitkumbhare> are you done with the issues from clustering
14:26:52 <abhijitkumbhare> About - https://bugs.opendaylight.org/show_bug.cgi?id=1765 - is this a new bug?
14:27:31 <kamal_rameshan> i am still stuck on it. for this whole week
14:27:43 <abhijitkumbhare> OK
14:27:59 <abhijitkumbhare> Following is the error message:  <error-message>Schema node "strict" was not found in module.</error-message>
14:28:30 <abhijitkumbhare> any thoughts?
14:28:39 <michal_rehak> looks like broken xml
14:29:20 <michal_rehak> I would remove <strict> at the beginning
14:29:31 <abhijitkumbhare> Can you update the bug?
14:29:49 <abhijitkumbhare> We can ask him to try again then
14:30:18 <michal_rehak> I will try to reach Peter on IM
14:30:23 <abhijitkumbhare> OK
14:30:28 <abhijitkumbhare> thx michal_rehak
14:31:15 <abhijitkumbhare> So michal_rehak - is https://bugs.opendaylight.org/show_bug.cgi?id=1759 also related to https://bugs.opendaylight.org/show_bug.cgi?id=1421 issues filed by VTN ?
14:33:24 <michal_rehak> abhijitkumbhare: I do not think so
14:34:22 <michal_rehak> the seems to be similar to issue where we have old fashioned model for some set_nw_* stamming from OF-1.0 and the same is possible for OF-1.3 via set-field action
14:35:14 <abhijitkumbhare> OK
14:36:44 <abhijitkumbhare> Can we have someone look at this ?
14:37:12 <michal_rehak> yes
14:37:21 <michal_rehak> I can take it
14:37:24 <abhijitkumbhare> thanks michal_rehak
14:37:45 <michal_rehak> if it is the case, than Timo will know fast way how to fix that
14:37:52 <abhijitkumbhare> good
14:38:31 <abhijitkumbhare> kamal_rameshan - any thoughts on when we can have the fix for https://bugs.opendaylight.org/show_bug.cgi?id=1540 ?
14:39:28 <kamal_rameshan> this has been intermittent... will work with moiz to see if this still an issue
14:39:55 <abhijitkumbhare> OK
14:40:32 <kamal_rameshan> currently the OFP distribution is having some issues with karaf, and ds clustering works only with karaf
14:40:56 <abhijitkumbhare> OK
14:41:30 <abhijitkumbhare> what are the issues with karaf and OFP distribution?
14:41:54 <abhijitkumbhare> anything Ed will need to look at?
14:42:24 <kamal_rameshan> i believe the issues are known to him...
14:43:06 <kamal_rameshan> when we take the OFP dist, not all the properties are part of the karaf dist
14:43:32 <abhijitkumbhare> OK
14:43:38 <kamal_rameshan> the properties files like custom.props etc... but the integration and controller dist have those
14:43:55 <abhijitkumbhare> OK
14:45:17 <abhijitkumbhare> any thoughts on https://bugs.opendaylight.org/show_bug.cgi?id=1756 ?
14:47:53 <abhijitkumbhare> Anyone wants to take it?
14:49:02 <kamal_rameshan> If this can be picked up from next week, i can take it. If its to be solved by this week, then i cannot
14:49:32 <abhijitkumbhare> OK
14:52:37 <abhijitkumbhare> Let's finish the meeting for today and sync up for lesser time (15 min) tomorrow
14:52:53 <abhijitkumbhare> (for anything that comes up)
14:53:03 <kamal_rameshan> i think avishnoi has already responded to a related bug : https://bugs.opendaylight.org/show_bug.cgi?id=1553
14:53:13 <abhijitkumbhare> OK
14:54:21 <abhijitkumbhare> #endmeeting