14:06:31 <edwarnicke> #startmeeting OFplugin Daily
14:06:31 <odl_meetbot> Meeting started Thu Aug  7 14:06:31 2014 UTC.  The chair is edwarnicke. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:06:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:31 <odl_meetbot> The meeting name has been set to 'ofplugin_daily'
14:06:38 <edwarnicke> #info edwarnicke
14:06:39 <prasanna> #info prasanna
14:06:42 <kamal_rameshan> #info kamal_rameshan
14:06:44 <jmedved> #info jmedved
14:06:45 <oflibMichal> #info oflibMichal
14:06:45 <avishnoi> #info avishnoi
14:06:55 <hideyuki> #info Hideyuki
14:07:02 <edwarnicke> hideyuki: Welcome! :)
14:07:10 <hideyuki> edwarnicke: Thank you :)
14:07:49 <edwarnicke> Apologies... I am going to wing it a bit, because abhijitkumbhare was tracking things... and he's stuck in traffic
14:07:51 <edwarnicke> *but*
14:07:56 <edwarnicke> We have trello :)
14:08:09 <edwarnicke> #link https://trello.com/b/TtnyEJZr/helium-release - OFplugin Trello
14:09:43 <prasanna> #info moved testing gerrit@9393 to done
14:10:14 <edwarnicke> prasanna: Could folks tell us their results here of testing gerrit9393
14:10:55 <v_demcak> #info vdemcak
14:11:08 <edwarnicke> #link https://git.opendaylight.org/gerrit/#/c/9393/
14:11:10 <jmedved> i have not had the opportunity to test it
14:11:13 <edwarnicke> So... who has tested https://git.opendaylight.org/gerrit/#/c/9393/ ?
14:11:21 <edwarnicke> And what is the result of their testing?
14:11:22 <prasanna> edwarnicke : yes, but my testing was completed , we will hear from others.
14:11:31 <prasanna> I have teste
14:11:43 <edwarnicke> prasanna: Thank you :)
14:12:20 <prasanna> I have verified 3 normal match calls  and the NXM rest call(mentioned in wiki).....the switch was getting programmed correctly
14:12:34 <prasanna> But Stats for NXM may be the a issue
14:12:58 <prasanna> Not seeing NXM stats in postman
14:13:01 <edwarnicke> prasanna: Did you try non-extension stuff?
14:13:25 <prasanna> yes edwarnicke that is what is "3 normal match calls"
14:13:49 <prasanna> thats what I meant.....not clear in my earlier statement
14:13:49 <edwarnicke> And you see the normal flows in stats?
14:14:11 <prasanna> Yes normal flows are showing up in stats
14:15:05 <edwarnicke> jmedved: Did you test 9393 ?
14:15:14 <jmedved> no
14:15:30 <jmedved> i only got to test 8174
14:15:48 <jmedved> (which we need to talk about)
14:15:48 <edwarnicke> abhijitkumbhare: Welcome, please #info in
14:15:50 <abhijitkumbhare> #info abhijitkumbhare here
14:15:52 <avishnoi> i also tested 8174
14:16:03 <edwarnicke> Shall we start with 9393?
14:16:13 <abhijitkumbhare> Yes
14:16:14 <edwarnicke> #topic https://git.opendaylight.org/gerrit/#/c/9393/
14:16:50 <edwarnicke> abhijitkumbhare: to summarize: prasanna has tested 9393, normal flows continue to work, nxm flows are having a stats issue.
14:17:04 <abhijitkumbhare> OK
14:17:25 <abhijitkumbhare> So - what kind of stats issue?
14:17:34 <edwarnicke> prasanna: Could you explain
14:17:47 <prasanna> abhijitkumbhare not able to see the NXM flows in rest
14:18:07 <abhijitkumbhare> In the operational side?
14:18:12 <prasanna> yes
14:18:43 <prasanna> not able to capture the wireshark....because the machine had some issues with tcpdump capture...
14:18:54 <edwarnicke> prasanna: Do you see the flows on the switch?
14:18:58 <prasanna> Yes
14:19:25 <edwarnicke> OK guys... shall we merge 9393?
14:19:41 <abhijitkumbhare> Yes
14:20:04 <avishnoi> +1
14:20:05 <abhijitkumbhare> We just let know we have this issue that is being worked on
14:20:49 <prasanna> +1
14:20:50 <abhijitkumbhare> Who will work on it?
14:21:00 <abhijitkumbhare> The stats issue?
14:21:17 <prasanna> abhijitkumbhare we will just confirm with Rob once
14:21:22 <edwarnicke> abhijitkumbhare: Agreed... who will create the bug and the trello?
14:21:24 <prasanna> regarding Stats
14:21:25 <abhijitkumbhare> OK
14:21:41 <abhijitkumbhare> prasanna will create the bug?
14:22:13 <prasanna> Since Madhu was also was reporting the stats issue , which I feel is same as what we are seeing
14:22:18 <edwarnicke> #action prasanna to file a bug for stats issue with 9393
14:22:20 <prasanna> Yes will create the bug
14:22:46 <edwarnicke> abhijitkumbhare: Will you create the trello?
14:22:50 <abhijitkumbhare> yes
14:23:30 <edwarnicke> #action abhijitkumbhare to create a trello for 9393
14:23:35 <abhijitkumbhare> I will update the Trello with the bug ID when prasanna has filed it
14:23:42 <edwarnicke> OK, who is going to work on the bug?
14:23:55 <abhijitkumbhare> if its a stats bug :-)
14:24:02 <edwarnicke> abhijitkumbhare: Sure
14:24:07 <edwarnicke> But who's going to work on it?
14:24:31 <abhijitkumbhare> do you have any cycles avishnoi ? probably next week?
14:24:32 <avishnoi> I can, but i will be able to do it after next tuesday
14:24:59 <avishnoi> yes, after next tuesday i can pick it
14:24:59 <jmedved> there is another stats bug - 1499. maybe they could be combined. not sure
14:25:10 <jmedved> work really needed on the stats
14:26:23 <avishnoi> I think vaclav is looking at 1499
14:26:36 <v_demcak> 1499 is fixed in 9788
14:26:43 <abhijitkumbhare> good
14:27:38 <prasanna> #info https://bugs.opendaylight.org/show_bug.cgi?id=1501 : created bug for NXM stats issue
14:27:55 <abhijitkumbhare> I will link it prasanna
14:28:17 <jmedved> v_demcak: excellent! :-)
14:30:44 <jmedved> can we move onto 8174?
14:30:55 <abhijitkumbhare> Have created the Trello for bug 1501
14:31:06 <abhijitkumbhare> yes jmedved
14:31:46 <jmedved> bottom line, as i described in the email: major stability improvement. IMO we can merge. did anybody test it?
14:31:54 <jmedved> avishnoi: you said you did?
14:31:59 <jmedved> what’s your resutls?
14:32:46 <v_demcak> :-) 1491
14:33:03 <v_demcak> sorry
14:33:04 <avishnoi> jmedved: edwarnicke : yes i tested it as well
14:33:22 <jmedved> did it work for you?
14:33:31 <avishnoi> i tested pingall scenario and verified that all the flows stats are there
14:33:44 <jmedved> great
14:33:45 <edwarnicke> Apologies
14:33:47 <avishnoi> i tested with rest conf as well
14:33:51 <avishnoi> it was positive
14:34:10 <avishnoi> and i tested it with the case for which we actually were using the comparators
14:34:15 <jmedved> i loaded with 10k flows, which pretty much killed the controller before, and it kept going. all flows got programmed
14:34:25 <jmedved> i +1 the merge
14:34:31 <jmedved> but
14:34:43 <avishnoi> and that also worked as expected. I have few question, which i discussed with vaclav and things look good to me
14:34:46 <jmedved> we still have more work to do on the overall performance & scale
14:34:48 <avishnoi> +1 for merge
14:34:53 <edwarnicke> Did we get a #action assigned for someone to work on but 1501
14:34:54 <edwarnicke> bug
14:36:59 <jmedved> if i see it correctly avishnoi said he will work on it after next tuesday.
14:37:31 <edwarnicke> #action avishnoi to work on https://bugs.opendaylight.org/show_bug.cgi?id=1501 for Tuesday
14:37:31 <abhijitkumbhare> I assigned 1501 to avishnoi
14:37:43 <edwarnicke> abhijitkumbhare: Can I just assign you getting the Trello's for these things?
14:38:00 <avishnoi> thanks
14:38:01 <abhijitkumbhare> I already added trello
14:38:01 <abhijitkumbhare> :-)
14:38:01 <edwarnicke> :)
14:38:07 <edwarnicke> Did we resolve stuff on 8174?
14:38:16 <jmedved> ewarnicke: not 100%
14:38:26 <jmedved> we agreed that it’s good to be merged
14:38:49 <jmedved> and that it improves stability in a major way
14:39:13 <edwarnicke> Who is reviewing and merging 9393 and 8174 ?
14:39:19 <jmedved> we still need more performance improvements. which i’d like to discuss now, because they may require some code reorg
14:39:23 <edwarnicke> Note: 9393 has a companion in integration that needs merge too
14:39:38 <edwarnicke> jmedved: Happy to, but lets get the actions for existing stuff pinned on people first
14:40:14 <jmedved> ewarnicke: ok, +1 on 8174 merge. AI should be on you or any other controller committer
14:40:53 <edwarnicke> #action edwarnicke to review (and unless there is a bad late breaking issue) merge https://git.opendaylight.org/gerrit/#/c/8174/
14:40:55 <abhijitkumbhare> It will be good to get 9393 merged before the TSC meeting in a 2-3 hours - I have back to back meetings till then to finish the review and merge
14:41:22 <edwarnicke> I can do the merge for both 9393 and its companion integration gerrit
14:41:31 <abhijitkumbhare> great
14:41:32 <prasanna> rebased 9393 will merge it
14:41:34 <avishnoi> edwarnicke: i already reviewed statistics manager code and robert/tony already did +1 to this
14:41:53 <edwarnicke> #action edwarnicke to review (and unless there is a bad late breaking issue) https://git.opendaylight.org/gerrit/#/c/9393/ and https://git.opendaylight.org/gerrit/#/c/9614/
14:43:09 <abhijitkumbhare> if prasanna manages to review/merge 9393 before edwarnicke does - that's also fine :-)
14:43:38 <prasanna> abhijitkumbhare I think 9614 needs to be merged by ed
14:43:52 <abhijitkumbhare> OK
14:44:15 <edwarnicke> prasanna: Lets coordinate on these
14:44:29 <edwarnicke> prasanna: Does 9393 require a manual rebase?
14:44:43 <prasanna> Sure edwarnicke no I was able to rebase from gerrit itself
14:44:48 <prasanna> Build is started
14:44:53 <edwarnicke> prasanna: Perfect
14:45:02 <edwarnicke> prasanna: Let me know when you are ready to merge it :)
14:45:14 <edwarnicke> jmedved: You wanted to change topic
14:45:14 <edwarnicke> ?
14:45:28 <jmedved> ewarnicke: yes please
14:45:40 <jmedved> performance (my favorit ;-) )
14:45:41 <edwarnicke> jmedved: What topic?
14:45:47 <edwarnicke> #topic performance
14:46:06 <abhijitkumbhare> we should keep at least a few minutes for hideyuki's issue
14:46:23 <abhijitkumbhare> unless it has been discussed
14:46:23 <jmedved> we have two performance issues:
14:46:29 <jmedved> 1. flow programming rate
14:46:37 <jmedved> 2. stats collection
14:47:00 <edwarnicke> hideyuki: Do you have a bug for action order?
14:47:17 <edwarnicke> jmedved: Do we have performance issues on topology (asking, don't know)
14:47:18 <jmedved> Re #1: when mininet is connected, the flow prgramming rate i observed is about 7 (seven) flows per second
14:47:40 <hideyuki> edwarnicke: yes. https://bugs.opendaylight.org/show_bug.cgi?id=1338
14:47:48 <jmedved> with quite high CPU utilization
14:48:42 <prasanna> jmedved did we profile ?
14:48:58 <jmedved> whne mininet is not connected, the flow programming rate is ~350 flows/sec. not great, but probably not that difficult to improve, since most of the time is spent in restconf (tony is doing new codecs which will fix that) and only one core is utilized
14:49:02 <jmedved> yes
14:49:18 <jmedved> i will send out the profiler output for both cases
14:49:49 <prasanna> jmedved that would be gr8 to identify the time spent in different modules ...we know netty for sure...:)
14:50:40 <prasanna> jmedved Thanks will wait for the mail
14:50:46 <edwarnicke> hideyuki: I have created a trello card for it https://trello.com/b/TtnyEJZr/helium-release
14:50:48 <jmedved> but for the case where mininet is connected, the rate is outrageously low, which we need to improve. my first question is: do we program the flows from FRM into the plugin one by one synchronously? i.e waiting for the programming of a previous flow to finish before we start programming the next flow?
14:51:10 <jmedved> who knows about the FRM?
14:51:55 <prasanna> No  I do think so ...
14:52:11 <jmedved> ok - so somebody needs to go in and analyze
14:52:12 <kamal_rameshan> jmedved are the flows written via restconf
14:52:14 <kamal_rameshan> ?
14:52:18 <jmedved> yes
14:52:46 <kamal_rameshan> then i dont think so that they are queued
14:52:58 <jmedved> as i said, i did 2 runs: one with mininet connected, one where mininet was NOT connected, and the flows were only written into the data store
14:53:19 <jmedved> with mininet connected, the programming rate is 7 flows/sec
14:53:28 <abhijitkumbhare> edwarnicke & hideyuki - is this different Trello card from the one for "Fix behavior of SET_VLAN_ID for openflow 1.3 switches" with bug https://bugs.opendaylight.org/show_bug.cgi?id=1421 ?
14:53:30 <edwarnicke> #nexttopic (ie, we aren't switching yet... but when we do): Action ordering bug... getting it assigned to someone
14:53:33 <jmedved> with data store only, the prgramming rate is 350 flows/sec
14:53:55 <jmedved> yep - who can work wuth me on this? needs an FRM expert
14:53:58 <prasanna> jmedved "and the flows were only written into the data store" does it mean the call get terminated in MD-SAL with a error no switch registered?
14:54:16 <edwarnicke> OK guys... we are close on time
14:54:24 <jmedved> prasanna: i don’t think there is an error
14:54:26 <edwarnicke> What are the concrete actions for tomorrow on performanace?
14:54:29 <jmedved> but yes, that’s the gist of it
14:54:30 <edwarnicke> And who is taking them?
14:54:54 <jmedved> ewarnicke: i will send out the profiler outputs for both runs
14:55:11 <jmedved> but, as is said, we need an FRM expert to start looking at this
14:55:16 <jmedved> who is that?
14:56:13 <prasanna> I can work with jmedved but I am not in office next week
14:56:24 <edwarnicke> prasanna: Mind if I push just a commit message change to 9393... I don't think merging something with DO NOT MERGE is good
14:56:40 <prasanna> edwarnicke will change it thanks
14:57:21 <edwarnicke> prasanna: Cool thanks :)
14:58:02 <hideyuki> abhijitkumbhare: "Fix behavior of SET_VLAN_ID for openflow 1.3 switches" and "Bug 1421" are different problems.
14:58:12 <abhijitkumbhare> We are running out of time - and we have not discussed hideyuki's issues yet
14:58:16 <abhijitkumbhare> OK
14:58:34 <edwarnicke> #topic https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:58:40 <edwarnicke> Who can work on this one
14:59:01 <edwarnicke> there is a fix here https://git.opendaylight.org/gerrit/#/c/9214/ which may even work out of the box
14:59:06 <edwarnicke> But someone needs to test it
14:59:11 <kamal_rameshan> i can take it
14:59:44 <kamal_rameshan> if somebody else is not already working on it
14:59:51 <edwarnicke> #action kamal_rameshan takes https://bugs.opendaylight.org/show_bug.cgi?id=1421  with candidate fix at https://git.opendaylight.org/gerrit/#/c/9214/
15:00:17 <edwarnicke> kamal_rameshan: I added you to the trello
15:00:41 <kamal_rameshan> edwarnicke thanks
15:00:41 <hideyuki> Gerrit 9214 is not for Bug 1421, it is for Bug 1338, right?
15:01:14 <edwarnicke> hideyuki: Did I get the bugs wrong?
15:01:21 <edwarnicke> I had asked about the action order one
15:01:39 <edwarnicke> hideyuki: You are right, 1421 is the wrong bug for action order
15:01:57 <hideyuki> edwarnicke: thank you.
15:02:44 <edwarnicke> I moved it to OFplugin and assigned it to Kamal
15:02:51 <edwarnicke> Now to fix the trello
15:03:28 <edwarnicke> Someone already fixed the trello :)
15:03:36 <edwarnicke> #undo
15:03:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x272e5d0>
15:04:07 <edwarnicke> #action kamal_rameshan takes https://bugs.opendaylight.org/show_bug.cgi?id=1338 with candidate fix at https://git.opendaylight.org/gerrit/#/c/9214/
15:04:07 <kamal_rameshan> hideyuki: as i understand there are 2 issues: 1. action-order-issue (1338) and 2. push-vlan-set-field issue with 1.3 and 1.0
15:04:14 <kamal_rameshan> am i correct?
15:04:34 <hideyuki> And, Bug 1491.
15:04:39 <edwarnicke> hideyuki: I am not dismissing the push_vlan... I can just get someone assigned and working on order easier :)
15:04:39 <hideyuki> There are three issues.
15:06:47 <edwarnicke> hideyuki: What is the third?
15:06:54 <kamal_rameshan> 1338, 1421 and 1491?
15:06:59 <hideyuki> Three issues: 1. action-order-issue (1338), 2. push-vlan-set-field issue with 1.3 and 1.0 (1421), and 3. SET_TP_SRC/SET_TP/DST issue (1491)
15:07:02 <hideyuki> kamal_rameshan: yes.
15:07:17 <hideyuki> https://bugs.opendaylight.org/show_bug.cgi?id=1491
15:09:04 <kamal_rameshan> if i am not wrong they all seem to be related....if yes then this has to be viewed hoslitically and we can come with a solution
15:10:38 <hideyuki> kamal_rameshan: Yes, these are related.
15:12:31 <kamal_rameshan> hideyuki: thanks...
15:15:32 <abhijitkumbhare> So kamal_rameshan - are you looking at all three?
15:18:17 <kamal_rameshan> abhijitkumbhare i will start analyzing all three... and see  there is a solution, since they seem to be related.
15:18:25 <abhijitkumbhare> OK
15:19:10 <kamal_rameshan> has the meeting ended?
15:19:43 <hideyuki> kamal_rameshan: Thank you!
15:21:00 <abhijitkumbhare> Yes - edwarnicke can you do #endmeeting?
15:21:06 <abhijitkumbhare> I will try as well
15:21:12 <abhijitkumbhare> #endmeeting