14:01:18 <edwarnicke> #startmeeting OFplugin Daily
14:01:18 <odl_meetbot> Meeting started Mon Aug 11 14:01:18 2014 UTC.  The chair is edwarnicke. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:01:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:18 <odl_meetbot> The meeting name has been set to 'ofplugin_daily'
14:01:24 <edwarnicke> #topic Rollcall
14:01:28 <edwarnicke> #info edwarnicke
14:01:34 <oflibMichal1> #info oflibMichal
14:01:34 <edwarnicke> OK folks.. please #info in
14:01:54 <edwarnicke> michal_rehak: Madhu_ jmedved are you guys here?
14:02:20 <michal_rehak> #info michal_rehak
14:02:31 <michal_rehak> morning
14:05:49 <odl_meetbot> abhijitkumbhare: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:05:56 <abhijitkumbhare> #info abhijitkumbhare
14:06:13 <abhijitkumbhare> Sorry folks - a little late
14:07:19 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Meeting_Logs
14:07:29 <abhijitkumbhare> #undo
14:07:52 <abhijitkumbhare> #info The meeting logs are available at:
14:07:57 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Meeting_Logs
14:08:08 <edwarnicke> #chair abhijitkumbhare
14:08:08 <odl_meetbot> Current chairs: abhijitkumbhare edwarnicke
14:08:16 <edwarnicke> abhijitkumbhare: It's all yours :)
14:08:21 <abhijitkumbhare> Thanks edwarnicke
14:08:23 <edwarnicke> Run us through :)
14:08:41 <abhijitkumbhare> Just give me a moment
14:09:33 <abhijitkumbhare> Shall we go over https://trello.com/b/TtnyEJZr/helium-release ?
14:09:49 <abhijitkumbhare> and then 2) performance
14:09:58 <abhijitkumbhare> 3) documentation
14:10:04 <abhijitkumbhare> Any other topics?
14:10:13 <abhijitkumbhare> Actually bug list
14:10:36 <abhijitkumbhare> So:
14:10:50 <abhijitkumbhare> #info Agenda
14:10:59 <abhijitkumbhare> #info 1) Bug list
14:11:12 <abhijitkumbhare> #info 2) Trello
14:11:24 <abhijitkumbhare> #info 3) performance
14:11:35 <abhijitkumbhare> #info 4) documentation
14:11:42 <abhijitkumbhare> Anything else?
14:11:57 <Madhu_> hi guys. i have to run shortly.
14:12:08 <abhijitkumbhare> So you want the floor first?
14:12:15 <Madhu_> abhijitkumbhare: yes.
14:12:19 <abhijitkumbhare> Sure
14:12:22 <Madhu_> if you guys are okay with it
14:12:27 <abhijitkumbhare> Sure
14:12:56 <abhijitkumbhare> Go ahead - what are the issues Madhu_ ?
14:13:20 <Madhu_> with michal_rehak's help this morning, i was able to get an external extensible bundle plugged into the OF extensibility framework
14:13:29 <abhijitkumbhare> Great!
14:13:49 <abhijitkumbhare> Welcome back michal_rehak !
14:13:57 <Madhu_> abhijitkumbhare: but we need https://git.opendaylight.org/gerrit/9855 to be merged in ofplugin
14:14:13 <abhijitkumbhare> OK - let's check that
14:14:26 <Madhu_> edwarnicke: as we discussed yesterday,
14:14:40 <Madhu_> we can have an external bundle to participate in the extensibility now
14:14:57 <Madhu_> abhijitkumbhare: though we made it work, i find it extremely complicated :)
14:14:59 <abhijitkumbhare> Just a pom change - so should be easy to merge that
14:15:08 <abhijitkumbhare> OK
14:15:13 <Madhu_> maybe its my lack of expertise in that. but if u look at the changes
14:15:30 <Madhu_> it is quite involved and am not sure how much it will motivate folks to do the right thing
14:15:43 <Madhu_> but it does work once all the bells and whistles are properly aligned
14:16:56 <edwarnicke> Guys... any objections to merging https://git.opendaylight.org/gerrit/9855
14:17:01 <Madhu_> abhijitkumbhare: i haven't tested the stats or other stuffs yet. will do so in the next few days
14:17:06 <abhijitkumbhare> OK - any thoughts michal_rehak ? May not have too much time this release Madhu_ & michal_rehak to make it a lot better than what it is - but ...
14:17:09 <edwarnicke> It looks good to me
14:17:25 <abhijitkumbhare> No objections - edwarnicke
14:17:36 <Madhu_> abhijitkumbhare: yes. i spoke to michal_rehak about that this morning.
14:17:45 <abhijitkumbhare> OK
14:17:47 <Madhu_> abhijitkumbhare: and yes, not for this release for sure :) but for next
14:17:53 <abhijitkumbhare> OK
14:18:25 <michal_rehak> edwarnicke: no objection - just need to test it
14:18:27 <edwarnicke> Madhu_: It can be made dead simple with a fix to the Match API... but that will have to wait for Lithium
14:18:42 <Madhu_> edwarnicke: it is not the match api fix.
14:18:48 <Madhu_> it is the overall strucutre
14:18:54 <Madhu_> i will write a wiki on my experience with this
14:18:58 <edwarnicke> Madhu_: The structure is driven by the Match API
14:18:59 <abhijitkumbhare> Madhu_ - do you want to run thru your recommendations on an email?
14:19:02 <Madhu_> and we can see how we can improve
14:19:10 <abhijitkumbhare> wiki will be great as well
14:19:10 <Madhu_> abhijitkumbhare: yes.
14:19:12 <edwarnicke> Madhu_: With a refactor of the Match API, the structure becomes dead simple
14:19:18 <abhijitkumbhare> (in fact better)
14:19:56 <Madhu_> anyways.. am unblocked once the plugin gerrit is merged
14:20:02 <abhijitkumbhare> Good
14:20:09 <Madhu_> and i will explore further with new extensions to see if I hit any others
14:20:12 <Madhu_> fingers crossed
14:20:14 <abhijitkumbhare> Sure
14:20:22 <Madhu_> btw... RESTCONF isn't working
14:20:28 <abhijitkumbhare> hmm
14:20:38 <Madhu_> I demonstrated it to michal_rehak and he said he will look into it
14:20:47 <Madhu_> RESTCONF for extensions i mean
14:20:47 <abhijitkumbhare> For the extensions - right?
14:20:52 <Madhu_> abhijitkumbhare: yes
14:20:54 <abhijitkumbhare> OK
14:20:58 <Madhu_> i will file a bug if that will  help
14:21:01 <abhijitkumbhare> Sure
14:21:12 <abhijitkumbhare> Will help
14:21:36 <Madhu_> thanks guys. appreciate your help. and i have to sign off now
14:21:42 <abhijitkumbhare> OK - we can start the bugs list then
14:22:27 <abhijitkumbhare> #info Bugs list link:
14:22:32 <abhijitkumbhare> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&deadlineto=2014-09-30&list_id=13400&product=openflowplugin&query_format=advanced&resolution=---
14:23:24 <abhijitkumbhare> I need to be go for a moment - will be back in a min
14:26:14 <abhijitkumbhare> back
14:26:16 <edwarnicke> michal_rehak: Are you wanting to do more testing for https://git.opendaylight.org/gerrit/#/c/9855 ?  It doesn't look like it could hurt anything, it just exposing more packages
14:26:44 <michal_rehak> oh
14:27:04 <michal_rehak> edwarnicke: I think we can merge - I just wonder why didn't we need that sooner
14:28:09 <abhijitkumbhare> So the first bug (going to the unassigned first):
14:28:25 <abhijitkumbhare> #topic Bug list
14:28:47 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1300
14:29:32 <abhijitkumbhare> Any thoughts?
14:30:49 <michal_rehak> abhijitkumbhare: looks like md-sal model change + adapt corresponding convertors in ofplugin
14:31:22 <abhijitkumbhare> Should that be fixed (now that it is after the API freeze)?
14:31:33 <abhijitkumbhare> For Helium I mean
14:32:24 <michal_rehak> abhijitkumbhare: in my opinion this could grow into large change
14:32:29 <abhijitkumbhare> If not I can put the deadline as past Oct 1 - to be a Lithium or a stable Helium
14:32:39 <abhijitkumbhare> I thought so as well
14:33:14 <abhijitkumbhare> So I will put the deadline as Oct 15 (to make it for post Helium)
14:33:31 <michal_rehak> edwarnicke: I am sure you have some comments on how huge this change might get
14:34:34 <abhijitkumbhare> I have already put it as post Helium :-)
14:34:42 <michal_rehak> ok
14:34:52 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1395
14:35:22 <abhijitkumbhare> #info performance degradation 24 hour test
14:36:08 <abhijitkumbhare> This looks important
14:37:16 <abhijitkumbhare> #info Steady drop from 15k flows per sec to 10.5k flows per sec
14:37:39 <abhijitkumbhare> Who wants to tackle this?
14:38:17 <abhijitkumbhare> BTW Prasanna is on a PTO this week and Anil Vishnoi is not available today
14:39:37 <abhijitkumbhare> This bug & performance in general is likely going to need a lot of time on whoever is looking into it
14:40:30 <abhijitkumbhare> I can ping Muthu if he is up to it - if no one else is wanting to take a crack at it (will #action)
14:40:49 <kamal_rameshan> do we know via profiling , which would be area of focus?
14:41:25 <abhijitkumbhare> I don't recollect what was the last update on the profiling
14:41:44 <abhijitkumbhare> I mean the last datapoint from the profilining
14:42:00 <abhijitkumbhare> jmedved - do you have that info?
14:43:05 <edwarnicke> kamal_rameshan: Are you around?
14:43:19 <kamal_rameshan> yes
14:43:42 <kamal_rameshan> joined in late
14:46:29 <kamal_rameshan> edwarnicke: do we have enough +1s for https://git.opendaylight.org/gerrit/#/c/9802/ to be merged?
14:47:45 <abhijitkumbhare> OK - if no one is taking on https://bugs.opendaylight.org/show_bug.cgi?id=1395 right now I will start chasing down Muthu (but he may be on a PTO)
14:48:46 <kamal_rameshan> abhijitkumbhare: i can take on 1395 , but only after i tackle 1491 (VTN bug))
14:49:02 <abhijitkumbhare> #action abhijitkumbhare to check with Muthu if he can take on https://bugs.opendaylight.org/show_bug.cgi?id=1395 & performance. In the meantime - it will be good to have an alternate contact for performance
14:49:25 <abhijitkumbhare> Good kamal_rameshan - but let me
14:50:03 <abhijitkumbhare> meant let's check with Muthu or someone so you can be free for the other bugs
14:50:30 <abhijitkumbhare> but if there is no one - then we will of course need to turn to you
14:50:48 <kamal_rameshan> abhijitkumbhare : ok :)
14:51:16 <abhijitkumbhare> Next:
14:51:22 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1403
14:51:46 <abhijitkumbhare> #info MD-SAL topology does not show link information
14:52:31 <abhijitkumbhare> edwarnicke - who is the expert on this area?
14:52:57 <edwarnicke> Have you checked with Luis to see is thats still an issue?
14:53:02 <kamal_rameshan> there was already a similar bug on compatibility : https://bugs.opendaylight.org/show_bug.cgi?id=1468, wondering both are the same....
14:53:04 <edwarnicke> Because its not showing up integration testing
14:53:04 <abhijitkumbhare> Will check
14:53:19 <abhijitkumbhare> OK (yes - that's true)
14:53:53 <abhijitkumbhare> #action abhijitkumbhare check with Luis if https://bugs.opendaylight.org/show_bug.cgi?id=1403 still happening
14:55:37 <abhijitkumbhare> kamal_rameshan - last comment on the AD-SAL topology bugs seems to be that its not reproducible
14:56:10 <kamal_rameshan> abhijitkumbhare - luis mentioned that he would retest and let me know
14:56:16 <abhijitkumbhare> OK
14:57:58 <abhijitkumbhare> Going on severity/priority now (unassigned are over):
14:58:03 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:58:33 <abhijitkumbhare> Is this the VTN issue? kamal_rameshan
14:59:04 <kamal_rameshan> abhijitkumbhare:yes this is the VTN issue
14:59:17 <kamal_rameshan> i am working on it
14:59:34 <abhijitkumbhare> OK
15:00:24 <abhijitkumbhare> Time is up - we need to be faster next time :-(
15:00:59 <abhijitkumbhare> Let me try to go thru them offline before the next meeting - and ask questions beforehand
15:01:41 <abhijitkumbhare> I mean go thru the bug list beforehand - and get to this meeting only the bugs that need attention
15:01:51 <abhijitkumbhare> that need action I mean
15:02:10 <abhijitkumbhare> Tomorrow is a webex meeting
15:02:27 <kamal_rameshan> abhijitkumbhare: makes sense, also better if its a webex meet. As response is immediate
15:02:34 <abhijitkumbhare> OK
15:02:46 <abhijitkumbhare> So I will end meeting now
15:02:51 <abhijitkumbhare> #endmeeting