14:06:01 <abhijitkumbhare> #startmeeting OpenFlow plugin daily scrum
14:06:01 <odl_meetbot> Meeting started Mon Aug 25 14:06:01 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:06:01 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:01 <odl_meetbot> The meeting name has been set to 'openflow_plugin_daily_scrum'
14:06:10 <abhijitkumbhare> #info abhijitkumbhare
14:06:21 <abhijitkumbhare> Can you guys info in?
14:06:26 <oflibMichal> #info oflibMichal
14:06:32 <kamal_rameshan> #info kamal_rameshan
14:07:19 <abhijitkumbhare> The bug list is here:
14:07:22 <abhijitkumbhare> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&deadlineto=2014-09-30&list_id=13400&product=openflowplugin&query_format=advanced&resolution=---
14:08:46 <abhijitkumbhare> So kamal_rameshan - how goes it on https://bugs.opendaylight.org/show_bug.cgi?id=1421 ?
14:09:37 <kamal_rameshan> i am still working on it.  90% implementaion is done. But the vlan wildcard is yet to be implmented
14:09:48 <edwarnicke> Good morning all :)
14:09:50 <abhijitkumbhare> OK
14:09:50 <kamal_rameshan> Not sure what changes will have to be done to support that
14:10:03 <v_demcak> #info v_demcak
14:10:11 <abhijitkumbhare> Good morning edwarnicke :)
14:10:13 <michal_rehak> #info michal_rehak
14:10:24 <abhijitkumbhare> and v_demcak :)
14:10:39 <abhijitkumbhare> also welcome back michal_rehak :)
14:11:03 <edwarnicke> #info edwarnicke
14:11:08 <michal_rehak> abhijitkumbhare: :-)
14:11:33 <abhijitkumbhare> What’s the problem with vlan wildcard kamal_rameshan ?
14:11:35 <v_demcak> abhijitkumbhare: :-)
14:11:45 <edwarnicke> Guys... I have to split attention starting at 7:30am PST because I have to host Karaf Happy Hour
14:11:58 <abhijitkumbhare> OK  edwarnicke
14:11:59 <edwarnicke> (fyi...  you guys have karaf features, and a karaf distro now... and are in the integration karaf)
14:12:09 <abhijitkumbhare> Thanks edwarnicke :)
14:12:21 <kamal_rameshan> As per Anil Vishnoi's email, a new leaf is to be added to the vlan match fields.
14:12:57 <abhijitkumbhare> will just add vishnoianil - to kamal’s comment
14:12:58 <kamal_rameshan> I am still looking at if any changes are needed to support that leaf in the ofjava too
14:13:26 <vishnoianil> #info vishnoianil
14:13:33 <vishnoianil> hello everyone
14:13:41 <abhijitkumbhare> hi vishnoianil
14:13:51 <vishnoianil> hi abhijitkumbhare
14:13:53 <kamal_rameshan> hi vishnoianil
14:14:09 <abhijitkumbhare> we are going thru the issues kamal_rameshan is having on https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:14:27 <vishnoianil> hi kamal, so that leaf is just to determine the action at the plugin level
14:14:53 <kamal_rameshan> ok.
14:15:10 <vishnoianil> you need to look at the value, determine the scenario which you have to handle and then create the appropriate second flow from the use provided flow and send it across to openflowjava library
14:15:31 <vishnoianil> i don't think there is any change that is required for the OFJava library
14:15:56 <kamal_rameshan> if thats the reason, then i would not need the wildcard leaf
14:16:22 <kamal_rameshan> i will submit a patch and you can review it
14:16:33 <vishnoianil> okay
14:16:34 <abhijitkumbhare> great!
14:17:03 <kamal_rameshan> i will submit a patch today after some testing.
14:17:17 <vishnoianil> kamal_rameshan: sure
14:17:27 <abhijitkumbhare> are there any issues we would like edwarnicke’s help before he needs to disappear at 7:30 am Pacific to the karaf meeting?
14:18:00 <abhijitkumbhare> Next one: https://bugs.opendaylight.org/show_bug.cgi?id=1088
14:18:08 <kamal_rameshan> abhijitkumbhare: on 1421 , no
14:18:24 <abhijitkumbhare> was a general question :)
14:18:43 <abhijitkumbhare> Will just info 1421 in
14:19:12 <abhijitkumbhare> #info Bug 1421 - kamal_rameshan will submit a patch , vishnoianil to review
14:19:46 <abhijitkumbhare> About: Bug 1088 - flow id in operational not matched; after removal not removed completely
14:19:59 <vishnoianil> abhijitkumbhare: On 1088, Robert suggested that we should normalize the case of all the config, but i believe its a long term solution and i am not sure we have time to go that way.  As of now i am looking for some host fix for a temporary fix. We can target next release for some better solution.
14:20:03 <abhijitkumbhare> vishnoianil: you added the comparator - right?
14:21:00 <vishnoianil> Yes, i will push the patch, after some testing
14:21:04 <edwarnicke> Karaf Happy Hour at 7:30am PST on #opendaylight-meeting - come out and get help with your karaf features!
14:21:24 <abhijitkumbhare> Wrong session edwarnicke :)
14:21:30 <edwarnicke> LOL
14:21:33 <edwarnicke> Just a general announcement :)
14:21:38 <abhijitkumbhare> yes :)
14:21:53 <vishnoianil> please don't divert the audience :D
14:22:24 <abhijitkumbhare> So - vishnoianil may be just let Robert know that you are pushin the patch in
14:22:38 <vishnoianil> sure
14:22:50 <abhijitkumbhare> dang - I am very slow using this Windows keyboard with my MAC :)
14:24:42 <abhijitkumbhare> #info Bug 1088 - flow id in operational not matched; after removal not removed completely: vishnoianil will push a patch for the comparator (rather than the whole normalize the case for all config) and will send an email to Robert Varga
14:25:19 <abhijitkumbhare> Next one https://bugs.opendaylight.org/show_bug.cgi?id=1526
14:25:36 <abhijitkumbhare> Good that you are here Madhu :)
14:25:43 <abhijitkumbhare> For https://bugs.opendaylight.org/show_bug.cgi?id=1526
14:30:59 <abhijitkumbhare_> Next one is from networkstatic: https://bugs.opendaylight.org/show_bug.cgi?id=1600
14:34:37 <abhijitkumbhare_> I guess - I will review it/merge it - if anyone else want to check out https://git.opendaylight.org/gerrit/#/c/10159/ that’s fine with me as well
14:34:37 <abhijitkumbhare> #action abhijitkumbhare_ to review & merge https://git.opendaylight.org/gerrit/#/c/10159/
14:34:37 <abhijitkumbhare> #undo
14:34:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2524290>
14:34:48 <abhijitkumbhare> : #action abhijitkumbhare_ to review & merge https://git.opendaylight.org/gerrit/#/c/10159/ for  https://bugs.opendaylight.org/show_bug.cgi?id=1600
14:34:50 <abhijitkumbhare> Next one is https://bugs.opendaylight.org/show_bug.cgi?id=1565 - will be fixed by comparator fix v_demcak & vishnoianil ?
14:36:51 <vishnoianil> yes
14:37:33 <abhijitkumbhare> #action abhijitkumbhare follow up with Luis, Greg and Jakub Tuth about  https://bugs.opendaylight.org/show_bug.cgi?id=1420
14:37:57 <abhijitkumbhare> #info  https://bugs.opendaylight.org/show_bug.cgi?id=1565 - will be fixed by comparator fix
14:38:31 <abhijitkumbhare> Skiping over https://bugs.opendaylight.org/show_bug.cgi?id=1468 - follow up with Luis
14:38:48 <abhijitkumbhare> #action abhijitkumbhare follow up with Luis about https://bugs.opendaylight.org/show_bug.cgi?id=1468
14:39:38 <abhijitkumbhare> #action abhijitkumbhare follow up with Luis and Greg about https://bugs.opendaylight.org/show_bug.cgi?id=1566
14:40:27 <abhijitkumbhare> Next one: https://bugs.opendaylight.org/show_bug.cgi?id=1540  - Notifications not being generated consistently or they just stop working
14:41:44 <abhijitkumbhare> Should this be an MD-SAL bug? Were you going to take a look at this first kamal_rameshan (after 1421) and then move it to controller if needed?
14:43:54 <abhijitkumbhare> For now I will assign 1540 to kamal_rameshan - is that OK?
14:44:51 <abhijitkumbhare> Its already assigned to kamal_rameshan :)
14:45:25 <kamal_rameshan> Yes its already assigned to me. I will work with Moiz on this one, once 1421 is over with
14:45:33 <abhijitkumbhare> OK
14:45:53 <abhijitkumbhare> Next one: Bug 1544 - Explicit LLDP flow to punt whole LLDP packets to the controller for more robust discovery - any news on this from mbobak ?
14:47:02 <oflibMichal> just started to work on this issue
14:47:04 <abhijitkumbhare> Martin Bobak changed the status of this today to be working on it
14:47:44 <oflibMichal> was trying to fix some blocker before switching to this bug
14:48:03 <abhijitkumbhare> OK
14:48:45 <abhijitkumbhare> #info oflibMichal will work on part of the fix for Bug 1544 - Explicit LLDP flow to punt whole LLDP packets to the controller for more robust discovery
14:48:57 <oflibMichal> :-)
14:49:12 <oflibMichal> i mean Martin Bobak just started to work on this bug
14:49:12 <abhijitkumbhare> Next one: https://bugs.opendaylight.org/show_bug.cgi?id=1587
14:49:17 <oflibMichal> my fault
14:49:21 <abhijitkumbhare> OK :)
14:49:26 <oflibMichal> should said that explicitly
14:49:29 <abhijitkumbhare> #undo
14:49:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x251f9d0>
14:49:59 <abhijitkumbhare> #info Martin Bobak will work on part of the fix for Bug 1544 - Explicit LLDP flow to punt whole LLDP packets to the controller for more robust discovery
14:50:12 <abhijitkumbhare> #undo
14:50:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24f84d0>
14:51:14 <abhijitkumbhare> #info Martin Bobak will start work on the fix for Bug 1544 - Explicit LLDP flow to punt whole LLDP packets to the controller for more robust discovery
14:51:28 <abhijitkumbhare> Next one again with Martin Bobak: https://bugs.opendaylight.org/show_bug.cgi?id=1587
14:52:25 <abhijitkumbhare> Should this be a controller or yangtools bug ?
14:52:46 <oflibMichal> Martin haven't started to work on this bug yet
14:53:50 <abhijitkumbhare> OK
14:54:28 <abhijitkumbhare> The next one seems to be just refactoring: https://bugs.opendaylight.org/show_bug.cgi?id=1588
14:54:49 <abhijitkumbhare> Again with Martin Bobak - I will move on
14:55:40 <abhijitkumbhare> Next one - again with Martin Bobak: https://bugs.opendaylight.org/show_bug.cgi?id=1254 (increase unit test coverage) - I will move on for this as well
14:56:46 <abhijitkumbhare> This one is with michal_rehak : https://bugs.opendaylight.org/show_bug.cgi?id=947
14:57:10 <abhijitkumbhare> Last update from Luis is that he sees only one error now
14:57:34 <abhijitkumbhare> I don’t think michal_rehak would have had a chance to look at this during his vacation
14:57:38 <michal_rehak> abhijitkumbhare: 947 was moved to lithium
14:57:59 <abhijitkumbhare> OK - then may be let’s move it
14:58:13 <michal_rehak> abhijitkumbhare: it seems there are always some exceptions pointing to OFPlugin
14:58:41 <abhijitkumbhare> Is that fair or incorrect?
14:59:54 <abhijitkumbhare> Actually I will check up with Luis about https://bugs.opendaylight.org/show_bug.cgi?id=947
15:00:39 <abhijitkumbhare> #action abhijitkumbhare check with Luis if https://bugs.opendaylight.org/show_bug.cgi?id=947 is OK to have targetted for Lithium - Luis really wanted it fixed in Helium
15:01:52 <abhijitkumbhare> Is  https://bugs.opendaylight.org/show_bug.cgi?id=947 something we can remove completely
15:02:25 <michal_rehak> abhijitkumbhare: particulary the exception in last comment has been changed to warning with explanation that sending hello during handshake failed because of disconnection
15:02:40 <abhijitkumbhare> in Helium timeframe I mean
15:03:05 <abhijitkumbhare> OK
15:03:07 <michal_rehak> abhijitkumbhare: no, 947 is fine as there are some exceptions which are not really importat and should not be in error level
15:03:13 <michal_rehak> oh
15:03:50 <abhijitkumbhare> so we should fix it completely over the next month or so - right?
15:03:52 <michal_rehak> abhijitkumbhare: I think we should ask Luis to retest
15:03:56 <abhijitkumbhare> OK
15:04:15 <michal_rehak> abhijitkumbhare: I will add this input as comment
15:04:27 <abhijitkumbhare> OK
15:04:48 <abhijitkumbhare> Next one - I will action myself
15:05:06 <abhijitkumbhare> #action abhijitkumbhare Check with Muthu about https://bugs.opendaylight.org/show_bug.cgi?id=1395
15:05:57 <abhijitkumbhare> Next one: https://bugs.opendaylight.org/show_bug.cgi?id=1398 -  Milestone: Increase regression test success rate
15:06:15 <abhijitkumbhare> Oh - we have gone past the hour - so we can continue tomorrow
15:09:37 <michal_rehak> abhijitkumbhare: 1398 - regression pass rate - currently regression tests are being rewritten by Peter Gubka in order to be a part of integration project and can be executed inside of a regularly executed jenkins job
15:10:01 <abhijitkumbhare> OK - good
17:08:38 <odl_meetbot> networkstatic: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
17:08:59 <networkstatic> #endmeeting