14:03:20 <abhijitkumbhare> #startmeeting OpenFlow plugin daily scrum
14:03:20 <odl_meetbot> Meeting started Wed Aug 27 14:03:20 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:03:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:20 <odl_meetbot> The meeting name has been set to 'openflow_plugin_daily_scrum'
14:03:22 <vishnoianil> I am on other call as well, so might not be prompt in reply
14:04:01 <kamal_rameshan> #info kamal_rameshan
14:04:11 <abhijitkumbhare> OK - we can go over the fixes done today & any major outstanding issues (like the stats issue)
14:04:16 <vishnoianil> #info vishnoianil
14:04:17 <abhijitkumbhare> #info abhijitkumbhare
14:05:08 <abhijitkumbhare> And try to finish within the first half an hour
14:05:26 <abhijitkumbhare> michal_rehak: are you on?
14:05:37 <CASP3R> #info CASP3R
14:05:43 <michal_rehak> #info: michal_rehak
14:05:44 <oflibMichal1> #info oflibMichal
14:05:51 <abhijitkumbhare> Hi CASP3R
14:05:54 <CASP3R> hi
14:06:14 <abhijitkumbhare> So kamal_rameshan - is 1421 over?
14:06:36 <kamal_rameshan> i have submitted a review with the changes mentioned
14:06:55 <kamal_rameshan> i also uncovered a bug awhich i fixed as well along with it
14:06:55 <abhijitkumbhare> OK - so it needs to be reviewed and merged
14:07:00 <kamal_rameshan> yes
14:07:07 <abhijitkumbhare> OK - what was the bug?
14:07:46 <kamal_rameshan> when the match/priority was changed during an update flow, we were performing the remove-flow , but not the add-flow
14:07:58 <abhijitkumbhare> OK
14:08:04 <abhijitkumbhare> That’s a bad one
14:08:28 <kamal_rameshan> yeah, that was regression due to some change made
14:08:59 <abhijitkumbhare> So - the gerrit is https://git.opendaylight.org/gerrit/10348 - michal_rehak - will you be reviewing it?
14:09:00 <michal_rehak> kamal_rameshan: 1421 looks good
14:09:17 <abhijitkumbhare> i spoke too soon :)
14:09:18 <kamal_rameshan> cool
14:09:25 <abhijitkumbhare> thx michal_rehak
14:10:10 <abhijitkumbhare> What about the stats issue that Madhu was referring to yesterday?
14:10:53 <vishnoianil> I did not get any note from madhu, neither i see any update on the bug
14:11:56 <abhijitkumbhare> It was something that apparently happened during michal_rehak’s demo (after I had left)
14:12:06 <abhijitkumbhare> michal_rehak: any info?
14:12:19 <abhijitkumbhare> Can we create a bug for it?
14:12:35 <michal_rehak> like statistics failing for vendor flows?
14:13:02 <abhijitkumbhare> I don’t know the exact issue you folks saw
14:13:09 <michal_rehak> there is fix pushed in yangtools, but not merged yet
14:13:29 <abhijitkumbhare> OK - its being reviewed?
14:13:36 <michal_rehak> https://git.opendaylight.org/gerrit/#/c/10301
14:13:41 <michal_rehak> oh.. should be merged
14:13:44 <michal_rehak> is..
14:13:47 <michal_rehak> we can retest
14:13:59 <abhijitkumbhare> OK
14:14:31 <abhijitkumbhare> Otherwise open a bug so we can keep track
14:15:08 <abhijitkumbhare> Bug 1088 is also fixed today vishnoianil - right?
14:15:34 <vishnoianil> abhijitkumbhare: yes
14:15:38 <abhijitkumbhare> There is a comment on it - https://git.opendaylight.org/gerrit/10371 fixes it
14:15:41 <vishnoianil> i pushed the fix
14:16:05 <abhijitkumbhare> Good
14:16:11 <vishnoianil> i asked vaclav if he can spare some time and to integration testing
14:16:40 <vishnoianil> if its fine then we are good to merge
14:16:47 <abhijitkumbhare> vishnoianil: about https://bugs.opendaylight.org/show_bug.cgi?id=1587 - there is a comment from Tony
14:16:59 <abhijitkumbhare> The comment is:
14:17:01 <abhijitkumbhare> Offending code is statistics manager, since it is only writer of that tree,
14:17:02 <abhijitkumbhare> write conflict could be also caused by inventory manager, since they share subtree (e.g. inventory manager deleted node from operational, statistics manager was trying to write node).
14:17:36 <abhijitkumbhare> I will cc you on the bug
14:18:32 <vishnoianil> okay
14:20:25 <abhijitkumbhare> So -  https://git.opendaylight.org/gerrit/10371  - do you need edwarnicke to merge it (after v_demcak spends time testing https://bugs.opendaylight.org/show_bug.cgi?id=1088) ?
14:20:46 <vishnoianil> yup, i will ping ed to merge
14:21:29 <abhijitkumbhare> #action v_demcak to test  https://bugs.opendaylight.org/show_bug.cgi?id=1088 with  https://git.opendaylight.org/gerrit/10371 - and then edwarnicke to merge it
14:22:46 <abhijitkumbhare> Any other issue we need to talk about?
14:23:16 <abhijitkumbhare> I know CASP3R ’s issue
14:23:37 <abhijitkumbhare> He needs help to set up the profiler
14:24:05 <abhijitkumbhare> for https://bugs.opendaylight.org/show_bug.cgi?id=1395
14:24:57 <CASP3R> abhijitkumbhare one issue is right now none of the test beds i use can run with cbench see https://bugs.opendaylight.org/show_bug.cgi?id=1581
14:25:10 <CASP3R> but it's really odd that Jan not seeing these issues
14:25:37 <abhijitkumbhare> CASP3R: I think you will need to follow up with Muthu about  https://bugs.opendaylight.org/show_bug.cgi?id=1395.
14:26:27 <abhijitkumbhare> v_demcak: do you have any input on https://bugs.opendaylight.org/show_bug.cgi?id=1581 that CASP3R is talking about?
14:27:07 <abhijitkumbhare> That will be a high priority if CASP3R cannot run cbench and any tests like that
14:28:41 <abhijitkumbhare> So CASP3R - you do not see the cbench issue only with the OF Plugin private build?
14:29:14 <CASP3R> i wasn't before but yesterday afternoon i pulled it down and was seeing it there
14:29:26 <abhijitkumbhare> OK
14:30:45 <abhijitkumbhare> v_demcak: any status on  https://bugs.opendaylight.org/show_bug.cgi?id=1581 ?
14:31:54 <v_demcak> #info v_demcak
14:32:45 <abhijitkumbhare> Hello v_demcak -  any status on  https://bugs.opendaylight.org/show_bug.cgi?id=1581 ? The cbench tests are blocked on that
14:33:41 <v_demcak> abhijitkumbhare: hello ... i've checked the integration distribution plugins and drop-tests are missing there
14:34:11 <abhijitkumbhare> OK - but he says that even in the openflow plugin they are not present
14:34:23 <abhijitkumbhare> i mean not working
14:35:18 <v_demcak> openflowplugin distribution/base/ should have it
14:35:23 <abhijitkumbhare> CASP3R said that yesterday he was seeing the issue also with the openflow plugin private build
14:35:41 <CASP3R> v_demcak yea the base doesn't have it but we manually do load it in
14:36:29 <CASP3R> basic we do 3 things      copy in drop-test,   delete arp and simpleforwarding  then change log from  INFO to ERROR
14:37:10 <v_demcak> CASP3R: may I ask you to try https://jenkins.opendaylight.org/integration/job/integration-hydrogen-deploy-controller-latest-base-of13/ws/distributions-base-0.1.1-1-SNAPSHOT-osgipackage.zip
14:37:29 <CASP3R> i can give that a shot
14:38:40 <abhijitkumbhare> #info cbench issue ( https://bugs.opendaylight.org/show_bug.cgi?id=1581) v_demcak & CASP3R investigating
14:39:07 <abhijitkumbhare> There is a new bug: https://bugs.opendaylight.org/show_bug.cgi?id=1626
14:39:24 <abhijitkumbhare> cbench data store performance very poor
14:40:00 <abhijitkumbhare> michal_rehak: do you know who it should be assigned to?
14:40:35 <michal_rehak> probably on me
14:40:45 <abhijitkumbhare> OK - will do
14:41:02 <michal_rehak> we have some pending changes which might solve this
14:41:12 <abhijitkumbhare> OK
14:41:33 <abhijitkumbhare> If there is nothing else - we can meet tomorrow then
14:42:16 <abhijitkumbhare> #endmeeting