14:02:46 <abhijitkumbhare_> #startmeeting OpenFlow Plugin meeting
14:02:46 <odl_meetbot> Meeting started Tue Aug 19 14:02:46 2014 UTC.  The chair is abhijitkumbhare_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:02:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:46 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting'
14:02:52 <edwarnicke> Start the meeting and I'll #info in
14:02:54 <edwarnicke> #info edwarnicke
14:02:56 <prasanna> #info prasanna
14:03:07 <abhijitkumbhare_> #info abhijitkumbhare
14:03:46 <kamal_rameshan> #info kamal_rameshan
14:05:22 <CASP3R> #info CASP3R
14:07:58 <LuisGomez> #info Luis
14:08:10 <abhijitkumbhare_> Just checking over webex - if  everyone OK with the IRC format
14:08:15 <v_demcak> #info Vaclav
14:08:40 <abhijitkumbhare_> Or if anyone has any topics that they want to bring forth
14:10:05 <abhijitkumbhare_> #info The suggestion on Webex was that going forward - if anyone wants a topic discussed over Webex - it should be added to the meeting wiki & we can discuss it over the Webex at the start of the meeting
14:10:11 <edwarnicke> Apologies... I can't jump on the call just now... but can be on IRC
14:10:34 <abhijitkumbhare_> No - that’s fine edwarnicke - we are moving to the IRC now
14:10:49 <abhijitkumbhare_> I will keep the Webex open though
14:11:03 <abhijitkumbhare_> Just in case any one joins there
14:11:10 <edwarnicke> abhijitkumbhare_: That sounds smart :0
14:12:00 <abhijitkumbhare_> So shall we move back to the bugs list - or someone has topics that they want to discuss first?
14:12:07 <oflibMichal> #info oflibMichal
14:12:19 <avishnoi> #info avishnoi
14:12:38 <abhijitkumbhare_> slime1: rgowrishankar - you guys can #info in
14:13:02 <rgowrishankar> #info rgowrishankar -ramkumar gowrishankar
14:13:12 <slime1> #info slime1
14:13:16 <abhijitkumbhare_> LuisGomez: & CASP3R - do you guys want to say anything from the integration side?
14:13:44 <LuisGomez> CASP3R, do we still have CBench issues?
14:13:46 <CASP3R> Only thing to bring up was that Droptest (one we were using for performance testing doesn't seem to be working"
14:14:22 <v_demcak> #info vdemcak
14:14:28 <edwarnicke> FYI... a bum patch went in and has been reverting, and the merge job is in flight
14:14:32 <abhijitkumbhare_> Is that broken recently?
14:14:39 <abhijitkumbhare_> OK
14:15:05 <mbobak> #info mbobak
14:15:06 <abhijitkumbhare_> ok - edwarnicke (sounds this is getting worked on)
14:15:09 <LuisGomez> I see today ofplugin is also broken in master, is that what Ed is saying?
14:15:18 <edwarnicke> LuisGomez: yes
14:15:22 <LuisGomez> ok
14:15:22 <CASP3R> It broke around Friday/Thursday for the RPC level
14:15:35 <abhijitkumbhare_> The drop test?
14:15:36 <LuisGomez> yesterday was fine
14:16:06 <LuisGomez> i mean the ofplugin, not the cbech
14:16:28 <abhijitkumbhare_> OK - so how long is the droptest not working?
14:17:23 <LuisGomez> since last Thu/Fri according to CASP3R
14:17:50 <abhijitkumbhare_> Can you open a bug?
14:18:04 <abhijitkumbhare_> If not already
14:18:31 <LuisGomez> #actio CASP3R to open a bug for Cbecnh if not done yet
14:18:53 <abhijitkumbhare_> #action CASP3R to open a bug for Cbecnh if not done yet
14:18:53 <CASP3R> Jan said he was opening a bug if he hasn't i do it today
14:18:59 <abhijitkumbhare_> OK
14:19:09 <LuisGomez> ok
14:19:31 <abhijitkumbhare_> So - should we move to
14:19:31 <abhijitkumbhare_> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate%2Cpriority%2Cbug_severity&deadlineto=2014-09-30&list_id=13400&order=bug_severity%2Cassigned_to%2Cpriority&product=openflowplugin&query_based_on=&qu
14:19:32 <abhijitkumbhare_> format=advanced&resolution=---
14:19:56 <abhijitkumbhare_> #topic Bug list
14:20:15 <abhijitkumbhare_> #link
14:20:15 <abhijitkumbhare_> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate%2Cpriority%2Cbug_severity&deadlineto=2014-09-30&list_id=13400&order=bug_severity%2Cassigned_to%2Cpriority&product=openflowplugin&query_based_on=&qu
14:20:16 <abhijitkumbhare_> format=advanced&resolution=---
14:20:17 <abhijitkumbhare_> [07:19am] abhijitkumbhare_: #topic Bug list
14:20:33 <abhijitkumbhare_> First bug
14:20:40 <abhijitkumbhare_> https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:20:54 <abhijitkumbhare_> kamal_rameshan: ?
14:21:29 <kamal_rameshan> Its still being worked on. Slightly convulted Will get it done by EDO tomorrow along with testing
14:21:50 <abhijitkumbhare_> OK
14:22:32 <abhijitkumbhare_> #info Bug 1421  - MD-SAL app cannot create a flow entry which adds a VLAN tag with the specified VLAN ID into untagged frame: ETA Aug 20
14:22:55 <abhijitkumbhare_> Next bug
14:22:57 <abhijitkumbhare_> https://bugs.opendaylight.org/show_bug.cgi?id=1491
14:23:46 <abhijitkumbhare_> Status of this was: Timotej Kubas will write a hotfix in ActionConverter in order to ship the change port action as set-field encapsulated stuff if of-1.3 and later we will clean md-sal models and fix that in sal-compatibility - deadline Aug 22 (Friday) - but trying to finish by the Tuedsay before. (abhijitkumbhare, 14:17:26)
14:24:35 <mbobak> abhijitkumbhare : Tomotej says he is testing his fix right now, and if all testts will pass, he'll push the fix
14:24:46 <abhijitkumbhare> OK - good
14:25:31 <abhijitkumbhare> #info Bug 1491 - OF plugin does not handle SET_TP_SRC/SET_TP_DST actions: Timotej testing the fix; if all tests pass will push the fix
14:25:54 <abhijitkumbhare> Next bug:
14:25:56 <abhijitkumbhare> Bug 1088 - flow id in operational not matched; after removal not removed completely
14:26:03 <abhijitkumbhare> avishnoi: ?
14:26:40 <abhijitkumbhare> actually v_demcak
14:26:51 <avishnoi> abhijitkumbhare: yes, show 574 gerrit ist not fixing the issue entirely
14:27:12 <avishnoi> abhijitkumbhare: we still need comparator for populating initial metadata like flow-cookie to flow-id map
14:27:28 <abhijitkumbhare> do you mean https://git.opendaylight.org/gerrit/#/c/8174 ?
14:27:29 <avishnoi> i found a bug in comparator and also i have tentative fix for that as well
14:27:36 <avishnoi> yes
14:27:58 <avishnoi> i need to discuss alternate solution  for the fix with robert/tony for
14:28:16 <avishnoi> so i sent a mail to robert,tony,ed,you and vaclav to discuss that
14:28:35 <avishnoi> if that alternate solution is not possible, will push my patch
14:28:52 <abhijitkumbhare> are u getting a response or do u need any help from edwarnicke ?
14:29:12 <avishnoi> i just dropped a mail to all the above mentioned folks
14:29:21 <edwarnicke> avishnoi: Are there patches that need review?
14:29:26 <avishnoi> will wait for response
14:29:33 <abhijitkumbhare> OK
14:30:16 <avishnoi> edwarnicke: nope, its just that i had some alternate approach to fix the issue, and that solution might require bit change the way we generate equals for MacAddress/EthernetMatch classes
14:30:56 <abhijitkumbhare> do u want to update the bug avishnoi ?
14:31:21 <avishnoi> sure will update the bug
14:31:30 <abhijitkumbhare> thx
14:31:55 <abhijitkumbhare> Will skip over Bug 1526 - RESTCONF POST fails with java.lang.IllegalArgumentException (Child is not present in tree)
14:32:36 <abhijitkumbhare> #action abhijitkumbhare Get response from Madhu about “Bug 1526 - RESTCONF POST fails with java.lang.IllegalArgumentException (Child is not present in tree)” if that is fixed
14:33:24 <abhijitkumbhare> Next one - also skip (https://bugs.opendaylight.org/show_bug.cgi?id=974)
14:34:02 <abhijitkumbhare> #action abhijitkumbhare : Make https://bugs.opendaylight.org/show_bug.cgi?id=974 to be duplicate of the LLDP flow & the whole pkt bug
14:34:51 <abhijitkumbhare> Will need to assign the next one:
14:34:54 <abhijitkumbhare> https://bugs.opendaylight.org/show_bug.cgi?id=725
14:36:08 <abhijitkumbhare> edwarnicke:  - should I assign the bugs that we need Pantheon team help to Viera?
14:36:49 <edwarnicke> abhijitkumbhare: ?
14:37:02 <edwarnicke> Which bugs, and I think we have several of the Pantheon folks online
14:37:20 <abhijitkumbhare> Ok
14:37:39 <abhijitkumbhare> So - want https://bugs.opendaylight.org/show_bug.cgi?id=725 assigned to someone
14:37:59 <abhijitkumbhare> Bug 725 - Openflowplugin-IT - Tests Failures
14:38:28 <mbobak> abhijitkumbhare: you can assing 725 to me
14:38:33 <abhijitkumbhare> LuisGomez: says on the bug “This looks like a Java test you have in your repo, I cannot confirm if the issue is there or not."
14:38:35 <abhijitkumbhare> OK
14:38:49 <edwarnicke> abhijitkumbhare: Reading https://bugs.opendaylight.org/show_bug.cgi?id=725 I am not sure there's enough there to work with...
14:39:15 <abhijitkumbhare> Yes - there is not
14:39:24 <abhijitkumbhare> Just checked the attach
14:39:34 <abhijitkumbhare> But I will let mbobak follow up
14:40:08 <abhijitkumbhare> Assigned it to mbobak
14:40:16 <mbobak> abhijitkumbhare: thanks
14:40:26 <abhijitkumbhare> Next one
14:40:28 <abhijitkumbhare> Bug 770 - java.lang.Long.parseLong throws NumberFormatException for input string on switch OFPT_HELLO
14:41:52 <mbobak> that seems to be fixed, buf just needs to be revalidated and closed
14:42:36 <abhijitkumbhare> #action abhijitkumbhare to follow up with Ermin Sakic for revalidating/closing “Bug 770 - java.lang.Long.parseLong throws NumberFormatException for input string on switch OFPT_HELLO”
14:43:05 <abhijitkumbhare> There was no response from Ermin on the bugzilla comment - will write an email
14:43:37 <abhijitkumbhare> Next bug
14:43:39 <abhijitkumbhare> Bug 1420 - AD-SAL Flowprogrammer does not work on HW OF switch
14:44:08 <abhijitkumbhare> Is Jakub here?
14:44:33 <oflibMichal> Jakub is not present
14:45:12 <abhijitkumbhare> OK - needed an update on this one - will action him for tomorrow
14:45:26 <v_demcak> abhijitkumbhare: Jakub is not here now, but the deadline is set for 2014-09-01
14:45:31 <abhijitkumbhare> OK
14:45:47 <edwarnicke> v_demcak: Could we get Jakub here tomorrow?
14:46:59 <abhijitkumbhare> #action v_demcak to ask Jakub to update “Bug 1420 - AD-SAL Flowprogrammer does not work on HW OF switch” or come to the meeting
14:47:00 <v_demcak> edwarnicke: Jakub is a student so I can not promise it to you. But I'll able to bring actual status for it.
14:47:09 <abhijitkumbhare> OK
14:47:23 <edwarnicke> v_demcak: OK... if we can't get him in the next day or two, we may need to reassign
14:47:42 <v_demcak> edwarnicke: understand ...
14:47:56 <abhijitkumbhare> Next bug
14:47:59 <abhijitkumbhare> Bug 1566 - Set VLAN PCP does not work
14:48:14 <abhijitkumbhare> ghall: any thoughts/status?
14:48:33 <abhijitkumbhare> I see there is in the comments
14:49:32 <LuisGomez> i believe ghall is working on it
14:49:37 <abhijitkumbhare> OK
14:50:02 <abhijitkumbhare> Next one:
14:50:04 <abhijitkumbhare> https://bugs.opendaylight.org/show_bug.cgi?id=1468
14:50:15 <abhijitkumbhare> Bug 1468 - AD-SAL topology unstable
14:50:34 <abhijitkumbhare> kamal_rameshan: LuisGomez - still an issue?
14:50:42 <LuisGomez> this one is not clear after recent changes topology was stable
14:50:59 <LuisGomez> but i cannot tell anymor because of the breakage today
14:51:08 <abhijitkumbhare> OK
14:51:20 <LuisGomez> leave it open and if we get plugion stable for 1 week i can check topology stability
14:51:42 <abhijitkumbhare> OK - will check it for the next week
14:51:47 <kamal_rameshan> i can assign this defect to luis
14:51:52 <abhijitkumbhare> OK
14:52:34 <abhijitkumbhare> #action LuisGomez to monitor Bug 1468 - AD-SAL topology unstable till Aug 26
14:53:27 <abhijitkumbhare> https://bugs.opendaylight.org/show_bug.cgi?id=1544
14:53:41 <abhijitkumbhare> Bug 1544 - Explicit LLDP flow to punt whole LLDP packets to the controller for more robust discovery
14:54:14 <mbobak> abhijitkumbhare: that bug is assigned to me, I expecto to start working on it on thursday
14:54:23 <abhijitkumbhare> OK
14:55:07 <abhijitkumbhare> #info Bug 1544 - Explicit LLDP flow to punt whole LLDP packets to the controller for more robust discovery: mbobak to work starting Aug 21
14:55:30 <abhijitkumbhare> Next:
14:55:32 <abhijitkumbhare> Bug 1545 - Set default switch configuration for packet-in to send the whole packet to controller
14:55:41 <abhijitkumbhare> https://bugs.opendaylight.org/show_bug.cgi?id=1545
14:56:00 <mbobak> abhijitkumbhare: i'm performning robot test on fix for that bug right now, expect to push fix tomorrow
14:56:06 <abhijitkumbhare> OK
14:56:35 <abhijitkumbhare> #info Bug 1545 - Set default switch configuration for packet-in to send the whole packet to controller: mbobak expects to fix Aug 20
14:57:10 <abhijitkumbhare> Next
14:57:13 <abhijitkumbhare> Bug 1254 - Milestone: increase unit test coverage
14:57:34 <mbobak> abhijitkumbhare: working on it whenever there's some time left
14:57:45 <abhijitkumbhare> OK
14:58:11 <abhijitkumbhare> Looks like mbobak has quite a few
14:58:40 <abhijitkumbhare> Next:
14:58:41 <abhijitkumbhare> Bug 1557 - OFP: crypting error during CSIT
14:59:12 <abhijitkumbhare> Needs code review
14:59:15 <abhijitkumbhare> https://git.opendaylight.org/gerrit/#/c/9990/
14:59:33 <v_demcak> abhijitkumbhare: I hope, that's fixed
14:59:46 <abhijitkumbhare> Yes - needs code review
15:00:34 <abhijitkumbhare> #action abhijitkumbhare edwarnicke review/merge https://git.opendaylight.org/gerrit/#/c/9990/
15:01:12 <edwarnicke> abhijitkumbhare: Has https://git.opendaylight.org/gerrit/#/c/9990/ been tested against: https://jenkins.opendaylight.org/integration/job/integration-master-csit-base-of13/
15:01:16 <abhijitkumbhare> We are out of meeting time
15:01:28 <abhijitkumbhare> Not sure
15:02:01 <edwarnicke> abhijitkumbhare: Until it has been, and we have a comment indicating it has, I would suggest not merging it
15:02:33 <abhijitkumbhare> Yes - I was also thinking it may be better to hold this one off till Michal R is back on Monday
15:02:41 <abhijitkumbhare> #undo
15:03:26 <abhijitkumbhare> We have 7 more bugs to go thru for now
15:03:49 <abhijitkumbhare> We can continue those tomorrow
15:04:04 <abhijitkumbhare> In the meantime - I will check them out as well
15:04:16 <abhijitkumbhare> #endmeeting