14:01:22 <abhijitkumbhare> #startmeeting OpenFlow Plugin scrum
14:01:22 <odl_meetbot> Meeting started Thu Sep  4 14:01:22 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:01:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:22 <odl_meetbot> The meeting name has been set to 'openflow_plugin_scrum'
14:02:41 <abhijitkumbhare> Hello kamal_rameshan michal_rehak vishnoianil v_demcak oflibMichal , etc.
14:02:49 <abhijitkumbhare> #info abhijitkumbhare
14:03:03 <kamal_rameshan> Hi abhijitkumbhare
14:03:08 <abhijitkumbhare> Can you guys info in?
14:03:10 <vishnoianil> #info vishnoianil
14:03:10 <michal_rehak> #info michal_rehak
14:03:14 <vishnoianil> hi abhijit
14:03:17 <kamal_rameshan> #info kamal_rameshan
14:03:29 <oflibMichal> #info oflibMichal
14:04:12 <abhijitkumbhare> Before we really start - trying to locate the M5 status email
14:04:36 <abhijitkumbhare> Rather the template that George Zhao sent
14:05:35 <abhijitkumbhare> OK - found it
14:05:59 <abhijitkumbhare> There is one question
14:06:03 <abhijitkumbhare> String Freeze Complete? [Yes |No ]
14:06:38 <abhijitkumbhare> I will copy paste the entire text - but it may come out a bit strange
14:07:01 <abhijitkumbhare> ===M5 Deliverable Status: ===
14:07:01 <abhijitkumbhare> Code Freeze Complete? [Yes |No ]
14:07:01 <abhijitkumbhare> String Freeze Complete? [Yes |No ]
14:07:01 <abhijitkumbhare> ===Karaf Related Deliverables Status: ===
14:07:01 <abhijitkumbhare> Project Karaf Bundles: [Not Started | Defined (WIP)| Built and Integrated]
14:07:02 <abhijitkumbhare> Project High Level (User visible) Features [Not Started | Defined | Built]
14:07:02 <abhijitkumbhare> ===Testing Related Deliverables Status:===
14:07:03 <abhijitkumbhare> - Unit test status [Not Started | Started | Complete | N/A]
14:07:03 <abhijitkumbhare> - Unit Test reporting in Sonar [Yes |No |N/A]
14:07:04 <abhijitkumbhare> - Feature integration test status [Not Started | Started | Complete | N/A]
14:07:04 <abhijitkumbhare> - Feature integration test reporting in Sonar [Yes |No |N/A]
14:07:05 <abhijitkumbhare> - Feature System Test [Not Started | Started | Complete | N/A]
14:07:05 <abhijitkumbhare> ===Documentation Related Deliverables Status: ===
14:07:06 <abhijitkumbhare> Documentation type based on
14:07:49 <abhijitkumbhare> Going to the question about the string complete - marking it as yes
14:08:24 <abhijitkumbhare> If anyone disagrees please let me know
14:09:01 <abhijitkumbhare> (not sure what exactly string freeze means - but I guess all the external facing strings)
14:10:15 <michal_rehak> any hints what is meant by string freeze?
14:11:00 <abhijitkumbhare> edwarnicke - for Project Karaf Bundles: I am marking it as "Built and Integrated";  Project High Level (User visible) Features as "Built" - is that mistaken?
14:11:26 <abhijitkumbhare> michal_rehak - I think it refers to external facing strings
14:11:32 <michal_rehak> ok
14:14:03 <abhijitkumbhare> How about "Unit test status" - most features we have completed prior to M4 (and not added anything afterwards - bug fixes only) - I believe - the status for that is Complete. Any one thinks their feature is not unit test complete?
14:14:57 <abhijitkumbhare> The next one is - Unit Test reporting in Sonar :
14:15:24 <abhijitkumbhare> I don't think we are doing this - are we?
14:15:34 <michal_rehak> we have cca 40%
14:16:04 <michal_rehak> https://sonar.opendaylight.org/dashboard/index/org.opendaylight.openflowplugin:openflowplugin-parent
14:16:46 <abhijitkumbhare> what is cca?
14:16:46 <edwarnicke> abhijitkumbhare: I think Michal is still working on getting the drop-test and test-provider in today
14:16:46 <abhijitkumbhare> OK
14:16:46 <abhijitkumbhare> Into sonar ?
14:17:00 <abhijitkumbhare> edwarnicke - I mistook your answer was for sonar
14:17:09 <abhijitkumbhare> & not karaf
14:17:43 <michal_rehak> oh, cca means approximately
14:18:13 <abhijitkumbhare> OK
14:18:58 <abhijitkumbhare> 42.6 % ?
14:18:58 <abhijitkumbhare> Today I mean
14:19:09 <abhijitkumbhare> Thanks for the link michal_rehak
14:20:00 <abhijitkumbhare> michal_rehak How about Feature integration test reporting in Sonar [Yes |No |N/A] ?
14:20:50 <michal_rehak> no idea how are features even displayed in sonar
14:21:58 <abhijitkumbhare> I am not sure we have quite separated out feature integration tests from unit tests - right? Should I put N/A or a No?
14:22:02 <edwarnicke> abhijitkumbhare: There is no code in features/
14:22:08 <edwarnicke> If memory serves
14:22:20 <abhijitkumbhare> OK - I will put it as N/A
14:23:19 <abhijitkumbhare> Feature System Test [Not Started | Started | Complete | N/A] -
14:25:38 <abhijitkumbhare> I believe this is "Started" - as I am not sure LuisGomez and team are complete on this (especially experimenter framework which is the main feature) -
14:28:16 <abhijitkumbhare> About Project Development Status Summary: - one of the deliverables for M5 is new integration tests
14:28:44 <abhijitkumbhare> Have there been any added?
14:29:04 <abhijitkumbhare> mbobak has been adding unit tests
14:30:34 <abhijitkumbhare> If there is - michal_rehak can you send me via email?
14:30:55 <abhijitkumbhare> Shall we move to the bugs list?
14:31:06 <abhijitkumbhare> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&deadlineto=2014-09-30&list_id=13400&product=openflowplugin&query_format=advanced&resolution=---
14:31:20 <abhijitkumbhare> First one: https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:31:32 <abhijitkumbhare> kamal_rameshan - https://bugs.opendaylight.org/show_bug.cgi?id=1421
14:31:54 <kamal_rameshan> i have not yet started the fixes over the issues mentioned by Hideyuki
14:32:05 <kamal_rameshan> i have to get to them
14:32:29 <kamal_rameshan> will have it done by early next week
14:32:53 <michal_rehak> abhijitkumbhare: there are some new tests in integration project covering OFPlugin code, but it is still in progress
14:33:21 <abhijitkumbhare> I think those should be at a high priority if we can - as Hideyuki may be needing them earlier (not sure if he has put the VTN as a week behind because of that in his status)
14:34:17 <kamal_rameshan> i am held up in some controller clustering work this week. So if anybody else has bandwidth , they can pick it
14:35:09 <abhijitkumbhare> OK - michal_rehak - do you think you can look into this one?
14:35:49 <michal_rehak> abhijitkumbhare: I am fully loaded this week :-(
14:37:50 <abhijitkumbhare> So kamal_rameshan - we may have to go with early next week as you are saying unless we come up with someone who can pick it up
14:38:19 <kamal_rameshan> yes, i can try to squeeze before that but no gurantees
14:38:39 <abhijitkumbhare> OK
14:39:15 <abhijitkumbhare> michal_rehak & edwarnicke  - about karaf one filed by Devin - https://bugs.opendaylight.org/show_bug.cgi?id=1681 - is that done?
14:39:46 <abhijitkumbhare> I guess we can close it as its merged
14:41:32 <abhijitkumbhare> vishnoianil - about https://bugs.opendaylight.org/show_bug.cgi?id=1565 . Is the status we have to get LuisGomez to verify?
14:42:45 <vishnoianil> abhijitkumbhare: yes, updating the bug with few more details
14:42:49 <vishnoianil> to clarify the issue
14:42:52 <abhijitkumbhare> OK
14:44:20 <abhijitkumbhare> michal_rehak since timotej is not here - asking you about https://bugs.opendaylight.org/show_bug.cgi?id=1581
14:45:14 <abhijitkumbhare> any news apart from what's in the bug?
14:47:46 <abhijitkumbhare> We have a bunch of bugs with Martin Bobak - which we need to get a status from (I will get it via an email as before) - but we should have him here. Can we get him on Monday meeting?
14:48:26 <michal_rehak> hi discovered a change in controller after which this happens
14:48:47 <michal_rehak> now he is trying to inspect the probelm with profiler
14:48:56 <abhijitkumbhare> Actually tomorrow meeting will be good to have Martin Bobak (if the time is not too late for Slovakia)
14:48:59 <michal_rehak> I guess it might be cracked by tomorrow
14:49:05 <abhijitkumbhare> OK - good
14:49:28 <abhijitkumbhare> So tomorrow we can discuss Martin Bobak's bugs
14:50:11 <abhijitkumbhare> and also LuisGomez - can we discuss your bugs or shall we do that on Monday (as you may need some time to get back on those)?
14:50:42 <abhijitkumbhare> thanks michal_rehak about Timotej bug status
14:52:03 <abhijitkumbhare> OK - so lets adjourn for today & meet tomorrow briefly (hopefully very short time to discuss Martin Bobak's bugs)
14:52:42 <abhijitkumbhare> and on Monday I will try to get LuisGomez (I will send him an email)
14:53:10 <LuisGomez> hi abhijit, please send me email with bugs you want me to check by Monday
14:53:26 <LuisGomez> i am catching up with mails now
14:53:33 <abhijitkumbhare> #action abhijitkumbhare send an email to Martin Bobak to provide status on bugs & attend meeting Friday
14:53:40 <abhijitkumbhare> Sure - will do LuisGomez
14:54:59 <abhijitkumbhare> #action abhijitkumbhare Send bug list to LuisGomez for status on Monday meeting
14:55:15 <abhijitkumbhare> #endmeeting