15:03:33 <abhijitkumbhare> #startmeeting OpenFlow plugin weekly meeting Nov 20
15:03:33 <odl_meetbot> Meeting started Thu Nov 20 15:03:33 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:33 <odl_meetbot> The meeting name has been set to 'openflow_plugin_weekly_meeting_nov_20'
15:05:24 <abhijitkumbhare> #topic Spreadsheet used by Ed for the controller
15:05:29 <abhijitkumbhare> #link https://docs.google.com/spreadsheets/d/1xXDMQRzJtsF6-KASWQ_ywBO9uwGKclavZCTPvJcidP4/edit#gid=0
15:06:46 <abhijitkumbhare> #info Keith's spreadsheet for GBP - good release template
15:06:51 <abhijitkumbhare> #link https://docs.google.com/spreadsheets/d/15nBWBNxCy3518o3tj808HjKaz2n7qyUgxQWDUKZEmy4/edit#gid=0
15:07:20 <vishnoianil> #info vishnoianil
15:09:30 <abhijitkumbhare> #info abhijitkumbhare
15:12:30 <abhijitkumbhare> #info Definition of offsets in the release plan - offset 0 - core; offset 1 - dependent on offset 0 - plus there are projects dependent on offset 1; offset 2 - leaf projects
15:13:09 <abhijitkumbhare> #info vishnoianil thinks OFplugin should be offset 1
15:14:42 <abhijitkumbhare> #info OFPlugin welcomes Jonathan from Inocybe
15:15:22 <edwarnicke> Welcome jfokkan :)
15:16:42 <edwarnicke> #link http://icodebythesea.blogspot.com/2014/11/ktop-update-and-opendaylight-mdsal.html info on the mdsal status command
15:18:40 <abhijitkumbhare> Helium backlog: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Backlog
15:18:55 <abhijitkumbhare> #info Helium backlogs: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Backlog
15:19:49 <abhijitkumbhare> #info Potential Lithium items: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Potential_Lithium_Items
15:28:31 <abhijitkumbhare> #info Chris O'Shea had expressed interest in being the test contact for the OpenFlow plugin - vishnoianil, edwarnicke & abhijitkumbhare were OK with this
15:31:32 <abhijitkumbhare> #undo
15:31:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2392ad0>
15:31:46 <abhijitkumbhare> #topic Project contacts - leads
15:33:22 <abhijitkumbhare> #info abhijitkumbhare is the only nominee for the OpenFlow plugin project lead. We will commence vote on the OpenFlow plugin project lead
15:33:31 <abhijitkumbhare> #info Chris O'Shea had expressed interest in being the test contact for the OpenFlow plugin - vishnoianil, edwarnicke & abhijitkumbhare were OK with this
15:34:21 * tbachman realizes he is late to the party ;)
15:34:25 <tbachman> webex link?
15:36:12 <abhijitkumbhare> Will look for it tbachman
15:36:18 <tbachman> abhijitkumbhare: found it ;)
15:36:19 <tbachman> am on
15:36:30 <abhijitkumbhare> https://wiki.opendaylight.org/view/Weekly_Project_Meeting_List#OpenFlow_Plugin
15:36:38 <abhijitkumbhare> OK - saw you are on :)
15:37:26 <tbachman> #info lots of people new to ODL and the openflowplugin get confused about the AD-SAL/MD-SAL
15:37:46 <tbachman> #info rgowrishankar asks whether the AD-SAL can be deprecated
15:37:57 <tbachman> #info edwarnicke says this is a bigger discussion than just the openflowplugin
15:38:29 <tbachman> #info there would have to be a recommendation and agreement to do this, and it would have to be marked as deprecated in a release before it would be removed in a subsequent release
15:38:59 <tbachman> #info rgowrishankar asks if the AD-SAL compatibility is under the openflowplugin
15:39:08 <tbachman> #info edwarnicke says that this is actually in the controller project
15:39:45 <tbachman> #info rgowrishankar asks if the AD-SAL compatibility can be moved into the openflowplugin, and subsequently deprecate
15:40:36 <tbachman> #info edwarnicke says that in the design summit there was a discussion about the controller project being too big, tho breaking things up is a non-trivial process
15:40:49 <tbachman> #info edwarnicke says as a first step he’s moved all the AD-SAL bits into their own directory
15:41:07 <tbachman> #info edwarnicke is also pushing patches to put the AD-SAL pieces into ordered chunks
15:41:32 <tbachman> #info edwarnicke would (personally) like to take some of the flow models and flow-based-service things and have those moved to the openflowplugin
15:43:23 <tbachman> #info rgowrishankar asks what the next steps would be here
15:44:15 <tbachman> #info edwarnicke recommends that rgowrishankar open a discussion on controller-dev or discuss on deprecating the AD-SAL
15:44:30 <abhijitkumbhare> +1 :)
15:44:45 <abhijitkumbhare> #info abhijitkumbhare says +1 :)
15:46:16 <tbachman> #action rgowrishankar to start thread on controller-dev and openflowplugin-dev, cc’ing discuss, vtn, opendov, and ovsdb-dev, on deprecating the AD-SAL
15:46:57 <tbachman> #info rgowrishankar asks if we can deprecate the openflow AD-SAL APIs
15:48:14 <tbachman> #info edwarnicke says if you deprecate the AD-SAL flow APIs, you end up largely deprecating the AD-SAL, due to cross-linkage
15:48:34 <tbachman> #info edwarnicke as an example, the host tracker doesn’t keep it’s own data, but stores it in the topology manager
15:49:22 <tbachman> #info abhijitkumbhare asks if the NSFs are essentially the MD-SAL plugins
15:49:50 <tbachman> #info edwarnicke says the things that we’re calling NSFs are essentially MD-SAL plugins, but some we probably don’t want to be separate plugins (e.g. inventory)
15:51:13 * tbachman sees the release template he created on abhijitkumbhare’s desktop :)
15:51:27 <abhijitkumbhare> :)
15:54:15 <rgowrishankar> #info There are multiple topology trees and openflow and bgp write to different topology trees. There are ways of linking nodes between the different trees to denote that nodes on the different tree correspond to the same physical box
15:54:31 <tbachman> rgowrishankar: thx!
15:56:40 <tbachman> #info rgowrishankar asks whether the HP contributions are planned for the openflowplugin
15:57:05 <tbachman> #info abhijitkumbhare says he’s seen a few proposals, some at the design forum
15:57:20 <tbachman> #info rgowrishankar asks about their netty.io and other mechanisms
15:57:40 <tbachman> #info edwarnicke says we should have a discussion with them about whether they plan to contribute
15:58:00 <tbachman> #info Anil says that they already pushed some code
15:58:25 <tbachman> #info edwarnicke says that they pushed more than just their openflow plugin, so it wasn’t clear what could be done with all of that (scope)
15:58:51 <abhijitkumbhare> #endmeeting