14:03:23 <abhijitkumbhare> #startmeeting  OpenFlowplugin daily scrum
14:03:23 <odl_meetbot> Meeting started Wed Aug 20 14:03:23 2014 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:03:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:23 <odl_meetbot> The meeting name has been set to 'openflowplugin_daily_scrum'
14:03:35 <v_demcak> abhijitkumbhare: hi :D
14:03:41 <abhijitkumbhare> #info abhijitkumbhare
14:03:52 <v_demcak> #info v_demcak
14:04:06 <kamal_rameshan> #info kamal_rameshan
14:04:10 <CASP3R> #info CASP3R
14:04:22 <abhijitkumbhare> Give me a moment while I set up my laptop
14:05:34 <abhijitkumbhare> I think we had a few to go thru yesterday
14:05:48 <abhijitkumbhare> We can continue from that
14:06:04 <abhijitkumbhare> And try to wrap up early if possible
14:06:36 <abhijitkumbhare> I was at https://bugs.opendaylight.org/show_bug.cgi?id=1557
14:07:29 <abhijitkumbhare> This looks merged (https://git.opendaylight.org/gerrit/#/c/9990/)
14:07:30 <v_demcak> abhijitkumbhare: it is merged
14:08:13 <abhijitkumbhare> Next one in my query is: https://bugs.opendaylight.org/show_bug.cgi?id=1565
14:09:31 <abhijitkumbhare> Luis has the last comment - asking v_demcak & avishnoi if this is fixed now (based on Vaclav’s comment regarding https://bugs.opendaylight.org/show_bug.cgi?id=1088)
14:10:07 <abhijitkumbhare> i.e. v_demcak comment saying it is the same problem
14:10:17 <v_demcak> abhijitkumbhare: I've suggested to make "hot-fix" from avishnoi and wait for yangtools team to possible support overwrite equal method for MacAddress
14:10:43 <oflibMichal> #info oflibMichal
14:11:14 <v_demcak> avishnoi: what is your opinion ?
14:11:49 <abhijitkumbhare> avishnoi: - if you are around - is that hotfix related to your email about “Ethernet address comparison issue”?
14:12:07 <abhijitkumbhare> Welcome oflibMichal
14:12:07 <avishnoi> #info avishnoi
14:12:11 <avishnoi> abhijitkumbhare: yes abhijit
14:12:35 <avishnoi> abhijitkumbhare: i am working on the fix and push it my tomorrow some time
14:12:57 <avishnoi> i encounter one more issue while debugging, which i will discuss with vaclav
14:13:23 <abhijitkumbhare> OK - I saw there was no response to your email (I believe Tony may be on a vacation - how about Robert)
14:13:47 <avishnoi> I will send follow-up mail to robert
14:14:04 <abhijitkumbhare> OK
14:15:03 <abhijitkumbhare> The next one is https://bugs.opendaylight.org/show_bug.cgi?id=1571
14:16:36 <v_demcak> abhijitkumbhare: I can't reproduce described behavior in actual master ... but I can not say, it is fixed
14:17:11 <abhijitkumbhare> OK - what about Tony’s suggestion about storing empty lists?
14:17:44 <abhijitkumbhare> Is that a good defensive mechanism we can do?
14:19:06 <v_demcak> abhijitkumbhare: the SalService could add only one item (no lists) ... but I'm investigation similar behavior in StatisticManager (new api migration) so I  hope, I could find some general solution soon
14:19:20 <abhijitkumbhare> OK
14:19:47 <abhijitkumbhare> The next one is https://bugs.opendaylight.org/show_bug.cgi?id=1569
14:20:15 <abhijitkumbhare> Martin Bobak is assigned to it
14:20:26 <abhijitkumbhare> Is he here?
14:20:52 <v_demcak> abhijitkumbhare: he's joining ... but he has no chance to look at it today
14:21:01 <abhijitkumbhare> OK
14:21:35 <mbobak> hello *
14:21:49 <mbobak> #info
14:21:58 <mbobak> #info mbobak
14:21:59 <abhijitkumbhare> Hi mbobak - don’t know whether you have had a chance to look at https://bugs.opendaylight.org/show_bug.cgi?id=1569
14:22:09 <mbobak> not yet
14:22:15 <abhijitkumbhare> OK
14:22:25 <mbobak> it's in the queue
14:22:57 <abhijitkumbhare> My initial list is over - but there may be 2-3 new ones
14:23:44 <abhijitkumbhare> First one is https://bugs.opendaylight.org/show_bug.cgi?id=1540
14:23:56 <abhijitkumbhare> Bug 1540 - Notifications not being generated consistently or they just stop working
14:24:22 <abhijitkumbhare> And the second one I see is https://bugs.opendaylight.org/show_bug.cgi?id=1581
14:24:33 <abhijitkumbhare> Bug 1581 - DroptestRPC doesn't work with Cbench
14:24:51 <abhijitkumbhare> I think that is the one CASP3R mentioned yesterday
14:25:02 <CASP3R> That's the one
14:26:03 <abhijitkumbhare> What’s the priority for that one? Is it stopping your progress?
14:26:26 <CASP3R> It's stopping all performance testing
14:27:03 <abhijitkumbhare> OK - then we may want to get someone on this at a higher priority than some of the other bugs
14:27:08 <v_demcak> abhijitkumbhare: I can take 1581
14:27:35 <abhijitkumbhare> Great v_demcak !
14:27:35 <CASP3R> Thanks v_demcak
14:27:39 <abhijitkumbhare> Thanks
14:27:45 <v_demcak> :-) you welcome
14:28:57 <abhijitkumbhare> You may want to do this before  your other bugs - as its stopping CASP3R ’s perf test - are there any which is higher prio?
14:29:28 <CASP3R> I just check the current CSIT test and they seem to be all passing
14:30:03 <CASP3R> other than the large scale Topo one but i think Luis is monitoring that as it sometimes fails
14:30:21 <abhijitkumbhare> OK
14:30:33 <abhijitkumbhare> Another new one: https://bugs.opendaylight.org/show_bug.cgi?id=1587
14:30:52 <abhijitkumbhare> Bug 1587 - Continuous WARN logs in o.o.c.m.s.d.s.i.InMemoryDOMDataStore - Store Tx: DOM-OPER-3635 Data Precondition failed for (urn:opendaylight:inventory?revision=2013-08-19)nodes/(urn:opendaylight:inventory?revision=2013-08-19)node/(urn:opendaylight:inventory?rev
14:30:56 <v_demcak> abhijitkumbhare: I'm going to fix it as soon as is possible
14:31:20 <abhijitkumbhare> Which one (https://bugs.opendaylight.org/show_bug.cgi?id=1581)?
14:31:31 <abhijitkumbhare> Or https://bugs.opendaylight.org/show_bug.cgi?id=1587 ?
14:32:34 <abhijitkumbhare> v_demcak: are you talking about fixing ASAP https://bugs.opendaylight.org/show_bug.cgi?id=1581 or https://bugs.opendaylight.org/show_bug.cgi?id=1587 ?
14:33:28 <abhijitkumbhare> If v_demcak is not looking at https://bugs.opendaylight.org/show_bug.cgi?id=1581 - then may be oflibMichal you can take a look at it?
14:34:03 <v_demcak> abhijitkumbhare: I'm going to look at 1581 asap. (performance test issue)
14:34:12 <abhijitkumbhare> OK
14:34:42 <abhijitkumbhare> I meant oflibMichal - can you take a look at https://bugs.opendaylight.org/show_bug.cgi?id=1587  ?
14:35:27 <oflibMichal> i am affraid that that I don't know anything related to Datastore
14:35:44 <oflibMichal> that's not in my knowledge domain
14:36:17 <abhijitkumbhare> OK
14:36:39 <abhijitkumbhare> We will need to revisit it then
14:37:10 <mbobak> I can take care of 1587
14:37:27 <abhijitkumbhare> OK - great!
14:37:59 <abhijitkumbhare> Also anyone for https://bugs.opendaylight.org/show_bug.cgi?id=1540 (Notifications not being generated consistently or they just stop working) ?
14:40:59 <abhijitkumbhare> I can check with Kamal if he can take up 1540: Notifications not being generated consistently or they just stop working (after he is done with 1421)
14:41:56 <abhijitkumbhare> #action abhijitkumbhare check with kamal_rameshan if he can take up 1540: Notifications not being generated consistently or they just stop working (after he is done with 1421)
14:42:43 <abhijitkumbhare> The following needs a review: https://bugs.opendaylight.org/show_bug.cgi?id=1491
14:43:32 <abhijitkumbhare> I think oflibMichal has already reviewed it (https://git.opendaylight.org/gerrit/#/c/10067/) - need to merge it
14:43:42 <oflibMichal> yes I did
14:43:54 <oflibMichal> it has been rebased and retested
14:44:25 <abhijitkumbhare> So - good for merge?
14:44:28 <oflibMichal> yes
14:44:39 <abhijitkumbhare> OK - will merge it after the meeting
14:44:45 <oflibMichal> ok, thanks
14:45:17 <abhijitkumbhare> avishnoi: https://bugs.opendaylight.org/show_bug.cgi?id=1088 is the same as the MAC address comparator issue?
14:45:30 <avishnoi> abhijitkumbhare: yes
14:45:44 <abhijitkumbhare> OK
14:46:36 <abhijitkumbhare> We are done except asking Madhu about https://bugs.opendaylight.org/show_bug.cgi?id=1526
14:47:24 <abhijitkumbhare> Is Jozef Gloncak full time?
14:47:37 <abhijitkumbhare> Or intern?
14:47:57 <abhijitkumbhare> I will just cc him when I ask Madhu
14:48:25 <v_demcak> abhijitkumbhare: I'm not fully sure, but I expect he is.
14:48:44 <abhijitkumbhare> OK - lets end meeting - hopefully tomorrow we can shorten it (as our first pass thru the bug list is done)
14:48:53 <abhijitkumbhare> Thanks everyone!
14:48:59 <abhijitkumbhare> #endmeeting