16:19:42 <abhijitkumbhare> #startmeeting IRC sync up
16:19:42 <odl_meetbot> Meeting started Tue May 19 16:19:42 2015 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:19:42 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:19:42 <odl_meetbot> The meeting name has been set to 'irc_sync_up'
16:19:55 <abhijitkumbhare> Hi michal_rehak
16:20:10 <abhijitkumbhare> and vishnoianil
16:20:26 <abhijitkumbhare> any thoughts on Anton's changes?
16:20:48 <tbachman> #info abhijitkumbhare asks if anyone has any thoughts on Anton’s changes
16:20:58 <abhijitkumbhare> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2015-May/003101.html
16:21:16 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/20704 The gerrit proposed in that email
16:22:06 <kot-begemot> Just to be clear - this is round one of the cleanup. There needs to be like 10 rounds. It should work though
16:22:22 <kot-begemot> Passes all tests I have thrown at it so far
16:22:29 <abhijitkumbhare> kot-begemot  - are you Anton?
16:22:33 <kot-begemot> Yes
16:22:39 <abhijitkumbhare> cool :)
16:22:43 <tbachman> #info kot-begemot says this is round one fo the cleanup — there needs to be many more (but it should work); all tests he’s used pass so far
16:24:07 <abhijitkumbhare> Do you agree with kot-begemot's changes michal_rehak ?
16:24:35 <tbachman> #info abhijitkumbhare asks michal_rehak if he agrees with kot-begemot’s changes
16:25:09 <michal_rehak> oh - I need to review Anton's change
16:25:22 <abhijitkumbhare> OK
16:25:29 <michal_rehak> we can probably do it via irc after meeting
16:25:30 <tbachman> #action michal_rehak to review kot-begemot’s gerrit
16:25:37 <abhijitkumbhare> Sure
16:25:57 <kot-begemot> I am going to backport it to He too. I tried cherry-picking, but git did not like some of it.
16:25:57 <abhijitkumbhare> #topic Updates
16:26:20 <abhijitkumbhare> Any updates folks?
16:26:21 <tbachman> #info kot-begemot says he’s planning on backporting his patch to stable/helium
16:26:30 <tbachman> #info abhijitkumbhare asks if there are any updates
16:26:48 <jamoluhrsen> CI is better for He codebase flow-services tests.
16:26:57 <abhijitkumbhare> Great jamoluhrsen
16:27:01 <jamoluhrsen> I don't know why.
16:27:05 <tbachman> #info jamoluhrsen says CI is better for stable/helium codebase flow-services tests
16:27:10 <tbachman> jamoluhrsen: lol!
16:27:19 <tbachman> jamoluhrsen: magic ;)
16:27:34 <abhijitkumbhare> Like magic - sometimes ... :)
16:27:42 <jamoluhrsen> tbachman: magic is good with me.  I'm dense enough to believe in it :)
16:28:00 <abhijitkumbhare> jamoluhrsen - I believe you have filed a set of new bugs
16:28:19 * tbachman is in the same camp as jamoluhrsen
16:28:48 <abhijitkumbhare> #info Bugs 3261, 3262, 3264, 3265, 3266
16:28:49 <jamoluhrsen> Right, abhijitkumbhare.  6 bugs.  I'm guessing they can mostly be marked fixed now, but would be good to know of some patch that did the fixing.
16:28:54 <tbachman> #info abhijitkumbhare says jamoluhrsen has filed a new set of bugs
16:28:58 <jamoluhrsen> Li codebase CI is still not good.
16:29:19 <tbachman> #info jamoluhrsen says he’s filed 6 buts. He guesses they can mostly be marked fixed now, but it woudl be good to know of some patch(es) that did the fixing
16:29:25 <abhijitkumbhare> Don't know how you missed getting 3263 :)
16:29:43 <jamoluhrsen> LOL.  that was kind of irritating :)
16:29:44 <kot-begemot> Quick question - Li codebase. What exactly does jenkins run by default on submission - full CI?
16:29:53 <kot-begemot> Or a subset?
16:30:13 <tbachman> #inf kot-begemot asks what does jenkins run by default on submission for the Lithium code base — full CI, or a subset?
16:30:31 <jamoluhrsen> kot-begemot:  we have duplicate suites.  one with odl-ofp-flow-services-ui feature, then another with -li feature if that makes sense over IRC
16:30:39 <tbachman> #info kot-begemot asks what does jenkins run by default on submission for the Lithium code base — full CI, or a subset?
16:31:03 <tbachman> #info jamoluhrsen says we have duplicate suites — one with odl-ofp-flow-services-ui feature, then antoerh with -li feature
16:31:03 <kot-begemot> It makes sense (over IRC) :)
16:32:35 <abhijitkumbhare> tbachman - are u two timing writing notes? :)
16:32:59 <tbachman> abhijitkumbhare: trying ;)
16:33:03 <abhijitkumbhare> I was going to ask Moiz a question about https://bugs.opendaylight.org/show_bug.cgi?id=3249 :)
16:33:22 <tbachman> abhijitkumbhare: he’s on the MD-SAL interest call
16:33:25 <tbachman> you can bug him there ;)
16:33:42 <abhijitkumbhare> Yes - but I have not joined the call
16:33:51 <abhijitkumbhare> over phone I mean
16:34:13 <tbachman> #info abhijitkumbhare says he needs to ask moizer a question about bug 3249
16:34:31 <abhijitkumbhare> #undo
16:34:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x194a3d0>
16:35:07 <abhijitkumbhare> #info abhijitkumbhare says he wanted to know the status on bug 3249 from moizer
16:35:13 <tbachman> abhijitkumbhare: thx ;)
16:35:23 <abhijitkumbhare> :)
16:35:35 <abhijitkumbhare> That seems to be one of our blocker bugs
16:36:18 <tbachman> 3051?
16:36:24 <abhijitkumbhare> Other blocker bugs:
16:36:26 <abhijitkumbhare> https://bugs.opendaylight.org/show_bug.cgi?id=3272
16:36:40 <abhijitkumbhare> Yes - https://bugs.opendaylight.org/show_bug.cgi?id=3051
16:37:17 <kot-begemot> #info 3051 if we stay with Li codebase still needs to be cascaded to the hashing code
16:37:34 <abhijitkumbhare> kot-begemot - about https://bugs.opendaylight.org/show_bug.cgi?id=3051 - what should be our next steps?
16:37:35 <kot-begemot> #info if we go back to He it needs to be backported
16:37:57 <kot-begemot> Verify, test, merge and then it depends which codebase we stay with
16:38:21 <kot-begemot> Li - one more round of cleanup and cascade changes to hashing, He - port the bugfix
16:38:31 <kot-begemot> Half a day or so each
16:38:43 <abhijitkumbhare> OK - thanks for your work on it
16:39:00 <tbachman> #info abhijitkumbhare asks kot-begemot what should be the next steps for 3051
16:39:34 <tbachman> guys — ttkacik is covering this in opendaylight-meeting
16:39:58 <tbachman> he says that they’re waiting for downstream projects to fix their stuff before they merge the fix for 3051 into stable/lithium (i.e. in yangtools)
16:39:58 <abhijitkumbhare> OK - let me just join the call then
16:40:35 <kot-begemot> joining too
16:41:19 <abhijitkumbhare> Need to find a room
16:41:28 <abhijitkumbhare> (a few moments)
16:43:02 <tbachman> fwiw, they’ve moved on
16:44:27 <abhijitk_> OK
16:45:51 <abhijitk_> But will ask question about it
16:46:04 <tbachman> abhijitk_: k
16:46:26 <abhijitk_> kot-begemot - you are also joined - right?
16:46:40 <tbachman> abhijitk_: you’ll have to just pipe in — they’ve moved on from that bug
16:47:02 <abhijitk_> I pressed wrong button - so disconnected
16:47:20 <tbachman> lol!
16:47:49 <kot-begemot> Yes - I am on the call
16:53:22 <kot-begemot> Basically - there are at least 2 families of utility functions to deal with the prefix creation, ip conversion, matcher conversion, etc.
16:53:47 <abhijitk_> You want to say this on the other session?
16:53:56 <kot-begemot> I said it :)
16:54:01 <kot-begemot> It needed cleanup
16:54:08 <abhijitk_> OK :)
16:54:10 <kot-begemot> Which I did :)
16:54:34 <tbachman> kot-begemot: that’s covered in https://git.opendaylight.org/gerrit/#/c/20704, right?
16:54:39 <kot-begemot> Yes
16:54:58 <kot-begemot> It fixes the passing of prefixes, it fixes the utility classes and merges them and it fixes the testcases
16:55:22 <kot-begemot> And it reuses the same code where possible for v4 and v6 so it does not break again
16:55:41 <kot-begemot> Because v4 was part-fixed at some point by someone - just that fix did not propagate to v6
16:56:05 <tbachman> #info tbachman asks kot-begemot if this is covered in https://git.opendaylight.org/gerrit/#/c/20704
16:56:21 <tbachman> #info kot-begemot says it fixes passing of prefixes, it fixes the utility classes and merges them and it fixes the testcases
16:56:34 <tbachman> #info kot-begemot says it reuses the same code where possible for v4 and v6 so it does not break again
16:56:54 <tbachman> #info kot-begemot says this is because v4 was part-fixed at some point by someone — just that fix did not propagate to v6
16:57:49 <tbachman> abhijitk_: so, I guess we’ll want an ETA for openflowplugin?
16:58:41 <abhijitk_> Yes - I think kot-begemot said in the next day (after a round of cleanup)
16:58:49 <abhijitk_> right kot-begemot ?
16:59:25 <kot-begemot> I said a day worth
16:59:30 <tbachman> now down to one meeting :)
16:59:47 <kot-begemot> Looking at my schedule I can probably do most of it tomorrow.
17:00:01 <kot-begemot> Someone needs to review the MatchConvertor specifically
17:00:15 <abhijitk_> OK - if michal_rehak you can review it - will be great
17:00:19 <tbachman> #info kot-begemot says he can problaby do most of the fixes for openflowplugin tomorrow, but someone needs to review the MatchConverter specifically
17:00:29 <kot-begemot> This desperately needs a BIG round of cleanup and abstraction, but at the very least if the fixes do their job now
17:01:00 <abhijitk_> Yes - sounds like it kot-begemot
17:01:03 <tbachman> #info kot-begemot  says this desperately needs a BIG round of cleanup and abstraction, but at the very least if the fixes do their job now
17:01:06 <tbachman> #action michal_rehak to review MatchConverter
17:01:21 * tbachman is action-oriented today ;)
17:01:30 <abhijitk_> That's good tbachman :)
17:01:31 <tbachman> lol
17:01:40 <tbachman> abhijitk_: especially when I’m not actioning myself ;)
17:01:41 <tbachman> lol
17:01:51 <abhijitk_> np :)
17:02:37 <tbachman> abhijitk_: anything else we want/need to cover here today?
17:02:42 <abhijitk_> So - should we check up again on Thursday? We can do an IRC meeting only
17:03:35 <abhijitk_> Phil said he does not have a Webex for the same time - we could do slightly different time - but IRC may be more convenient for most folks
17:03:56 <tbachman> #info abhijitk_ asks if we should meet via IRC on Thursday
17:04:01 <tbachman> abhijitk_: time?
17:04:06 <kot-begemot> Fine with me
17:04:24 <abhijitk_> Let's meet at 9 am Pacific / 6 pm CET / 9:30 pm India
17:04:48 <abhijitk_> Again - thanks for your work on this kot-begemot :)
17:04:49 <tbachman> #info abhijitk_ says we’ll do an IRC meeting at 9am PDT on Thursday
17:04:54 * tbachman agrees
17:05:27 <abhijitk_> I will end meeting - since we are out of time
17:05:37 <tbachman> abhijitk_: okay
17:05:43 <abhijitk_> We will continue Thursday
17:05:45 * tbachman can’t… he’s not chair
17:05:50 <abhijitk_> #endmeeting
17:05:59 <tbachman> weird
17:06:01 <abhijitk_> Argh
17:06:07 <tbachman> wrong NIC ;)
17:06:08 <abhijitk_> I am not chair as well
17:06:09 <tbachman> loll
17:06:15 <tbachman> change your NIC, and you will be
17:06:21 <abhijitk_> It was abhijitkumbhare
17:06:23 <tbachman> right
17:06:32 <tbachman> you can just do /NIC abhijitkubmhare
17:06:37 <tbachman> sorry
17:06:43 <tbachman> there you go :)
17:06:45 <abhijitkumbhare> #endmeeting