17:16:58 <abhijitkumbhare> #startmeeting OpenFlow plugin bug scrub
17:16:58 <odl_meetbot> Meeting started Fri Sep 25 17:16:58 2015 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:16:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:16:58 <odl_meetbot> The meeting name has been set to 'openflow_plugin_bug_scrub'
17:17:12 <abhijitkumbhare> #chair LuisGomez
17:17:12 <odl_meetbot> Current chairs: LuisGomez abhijitkumbhare
17:17:47 <abhijitkumbhare> #topic Bugs list (blocker, critical, major)
17:17:59 <abhijitkumbhare> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&list_id=39862&product=openflowplugin&query_format=advanced&resolution=---
17:18:06 <abhijitkumbhare> #undo
17:18:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1d33090>
17:18:36 <abhijitkumbhare> Cannot seem to link it one line
17:18:42 <abhijitkumbhare> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&list_id=39862&product=openflowplugin&query_format=advanced&resolution=---
17:19:27 <abhijitkumbhare> Anyway the first one
17:19:54 <abhijitkumbhare> Before that is anyone else joining beside LuisGomez and me?
17:20:47 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=3735 “flows not removed from the switch when 80k flows configured”
17:21:29 <abhijitkumbhare> Looks like this will be addressed as part of reconciliation
17:21:56 <LuisGomez> it seems so but I do not full get the problem here, is it not a mininet issue?
17:23:18 <abhijitkumbhare> Let me go thru a bit more
17:23:37 <abhijitkumbhare> I assigned it to Muthu - but we can check on that
17:23:47 <LuisGomez> also if you configure 80K flows with controller and then you restat mininet, 80K flows will be reprogrammed right?
17:24:18 <LuisGomez> i do not quite follow the test procedure here…
17:24:46 <LuisGomez> Ah, i get it now
17:24:58 <LuisGomez> the test script adds and deletes flows
17:25:15 <LuisGomez> the mininet disconnect is before the flows are fully deleted
17:25:23 <abhijitkumbhare> Yes
17:25:27 <LuisGomez> this explains but i do not see issue then
17:25:36 <LuisGomez> just wait for delete
17:25:53 <LuisGomez> it does not even look like a bug
17:26:21 <abhijitkumbhare> yes - it may not be a bug
17:26:53 <LuisGomez> so low down priority?
17:27:06 <abhijitkumbhare> yes
17:28:33 <abhijitkumbhare> Next
17:28:51 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=3741 “groups and meters tests fails for Li design ofp”
17:29:20 <abhijitkumbhare> Peter says test should be updated
17:29:31 <abhijitkumbhare> Will ask him for an update
17:30:16 <abhijitkumbhare> I guess Peter’s comment is based on Michal’s comment
17:31:13 <LuisGomez> i already did, so bug closed
17:31:25 <abhijitkumbhare> i will also lower the priority of this to normal - since michal has already fixed the issue
17:31:31 <abhijitkumbhare> ok
17:31:41 <LuisGomez> i mean not now but 2 days ago
17:32:09 <abhijitkumbhare> OK
17:32:17 <abhijitkumbhare> Next
17:32:44 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=3762 “flows statistics unstable when 80k flow configured”
17:34:24 <abhijitkumbhare> Looks like she is not able to reproduce this - but may be we can change the deadline for this to be after M5 - so it can be worked during the RC cycle
17:35:40 <abhijitkumbhare> I will put vishnoianil on the cc for this bug
17:36:49 <LuisGomez> if it cannot be recreated is an issue
17:37:14 <LuisGomez> also the jenkins job seems unstable
17:37:49 <abhijitkumbhare> yes - there must be an issue
17:38:39 <LuisGomez> i am not sure how to do with these bugs that cannot be easily reproduced
17:39:10 <LuisGomez> as a minimum return them to the requestor
17:39:23 <abhijitkumbhare> for now will just add vishnoianil to the cc - to check for his comment on this one (without reassigning) - and also check with Peter
17:39:33 <LuisGomez> ok
17:40:44 <LuisGomez> next
17:41:08 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4104 “Problems observed when connecting openflow switches to multiple instances of controller"
17:41:48 <LuisGomez> this is part of the cluster work
17:41:50 <abhijitkumbhare> Looks cluster
17:41:58 <LuisGomez> to kamal then
17:42:07 <abhijitkumbhare> Yes - I think kamal with cc to kavitha
17:42:22 <LuisGomez> lower prio as the feature is not ready
17:42:48 <abhijitkumbhare> yes
17:43:54 <abhijitkumbhare> next
17:44:28 <abhijitkumbhare> #info 4104 assigned to Kamal
17:44:49 <abhijitkumbhare> #info 4104 prio lowered as the feature not ready
17:45:21 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4062 “Flow Reconciliator does not account for flow-deletions when the switch connection is disrupted"
17:45:46 <abhijitkumbhare> #info Muthu has already picked this up
17:45:54 <abhijitkumbhare> #undo
17:45:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ce0610>
17:46:11 <abhijitkumbhare> #info Muthu has already picked 4062
17:46:17 <abhijitkumbhare> next
17:46:53 <LuisGomez> yes
17:46:55 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=3039 “NxmNxTunIpv4Src not supported”
17:46:58 <LuisGomez> reconciliation work
17:47:37 <abhijitkumbhare> I will lower the priority of this to normal
17:48:20 <abhijitkumbhare> and reassign it to michal
17:50:12 <LuisGomez> yes
17:50:16 <LuisGomez> the flow works
17:50:23 <LuisGomez> but there is an alien issue
17:50:38 <LuisGomez> that is global issue of less priority
17:51:06 <abhijitkumbhare> #info lowered priority of 3039 to normal (due to only the alien issue remaining) - assigned it to Michal Rehak for his thoughts on this
17:51:19 <abhijitkumbhare> next
17:51:23 <LuisGomez> yes
17:51:39 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=3774 “stats for 80k fows not collected properly after mininet restart”
17:52:32 <abhijitkumbhare> I guess Kavitha has taken this
17:53:17 <abhijitkumbhare> #info Kavitha has taken 3774 - most likely she intends to do this later - will ask update on this on the bug
17:54:09 <abhijitkumbhare> Next
17:54:35 <LuisGomez> this is related to the first one we showed
17:54:42 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4069 “[GROUP RECONCILIATION] Group Chaining fails during reconciliation”
17:55:10 <abhijitkumbhare> #info Related to reconciliation - assigning it to Shuva
17:55:38 <LuisGomez> yes
17:55:51 <LuisGomez> that is a big issue addressed by reconciliation
17:56:03 <abhijitkumbhare> next
17:56:38 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=3754 “NPE at org.opendaylight.openflowplugin.openflow.md.core.ConnectionConductorImpl.updatePort(ConnectionConductorImpl.java:299)[256:org.opendaylight.openflowplugin:0.1.0.SNAPSHOT]”
17:57:34 <abhijitkumbhare> #info Fixed but need to check if has been pushed to stable/lithium
17:57:43 <abhijitkumbhare> #undo
17:57:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ce0a10>
17:57:48 <LuisGomez> ok
17:58:06 <abhijitkumbhare> #info Fixed but need to check with Martin if has been pushed to stable/lithium
17:58:30 <abhijitkumbhare> I think we are out of time for the others - due to your meeting
17:58:57 <abhijitkumbhare> So I will just note them here - so we can pick them up later
17:59:04 <LuisGomez> ok
17:59:18 <abhijitkumbhare> I don’t think I will be able to join next Friday
17:59:26 <LuisGomez> do we want to continue later today?
17:59:29 <abhijitkumbhare> sure
17:59:45 <abhijitkumbhare> when?
17:59:53 <LuisGomez> i am free after 12
18:00:05 <LuisGomez> any time after 12 is fine
18:00:07 <abhijitkumbhare> ok - or at 1 pm?
18:00:10 <LuisGomez> yes
18:00:12 <LuisGomez> 1 works
18:00:18 <abhijitkumbhare> so we can have lunch first :)
18:00:31 <LuisGomez> sure
18:00:31 <abhijitkumbhare> I will not do end meeting till then
18:00:35 <LuisGomez> ok
18:00:43 <abhijitkumbhare> see you at 1 pm
20:01:20 <abhijitkumbhare> LuisGomez: - shall we continue if you are back?
20:02:01 <LuisGomez> sure
20:02:36 <LuisGomez> i am just trying to reproduce a new bug i saw in customer lab
20:02:37 <abhijitkumbhare> OK - lets try to recover the last bug :)
20:02:41 <LuisGomez> so please go ahead
20:02:45 <abhijitkumbhare> OK
20:03:26 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4099 “[GROUP RECONCILIATION]Groups pointing to ports donot reconcile if ports come up late”
20:03:42 <abhijitkumbhare> again reconc
20:04:00 <LuisGomez> reconsiliation stuff
20:04:06 <LuisGomez> yes
20:04:13 <LuisGomez> this is all important work yes
20:04:46 <abhijitkumbhare> will assign it to Shuva
20:05:26 <abhijitkumbhare> #info assigned to Shuva since this is reconciliation related
20:05:29 <abhijitkumbhare> Next
20:05:35 <LuisGomez> shoot
20:06:00 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4111 “[FLOW RECONCILIATION]Expirable flows appear in the switch post reconnect”
20:06:20 <abhijitkumbhare> I think same here :)
20:06:42 <LuisGomez> same here
20:07:03 <abhijitkumbhare> #info assigned to Shuva as part of reconciliation work
20:07:06 <LuisGomez> it would be awesome if we can address all these issues with reconciliation
20:07:12 <abhijitkumbhare> yes
20:07:26 <abhijitkumbhare> next
20:07:50 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=3548 “LLDP speaker does not start/stop sending LLDP packets on port up/down events"
20:08:59 <abhijitkumbhare> so is this fixed or not?
20:09:09 <abhijitkumbhare> with vishnoianil’s change?
20:09:19 <LuisGomez> i do not think so but i can double check
20:09:34 <LuisGomez> my last comment was it is not fixed :)
20:09:47 <abhijitkumbhare> OK :)
20:09:52 <vishnoianil> abhijitkumbhare, LuisGomez , i think i fixed it
20:10:15 <LuisGomez> not this particular one but i may be wrong.
20:10:34 <abhijitkumbhare> OK - may be LuisGomez can double check some time - the fix seems to be in stable/helium
20:10:44 <vishnoianil> https://git.opendaylight.org/gerrit/#/c/23795/
20:10:47 <LuisGomez> is it 3233 bug you are talking?
20:11:07 <abhijitkumbhare> so may be there was a timing issue - that it was not fixed in lithium when LuisGomez tried it
20:11:27 <LuisGomez> this fix is for add/remove openflow ports
20:11:49 <LuisGomez> the one we are talking is port up/down
20:12:26 <abhijitkumbhare> may be we assign it back to vishnoianil - and he can check it when he gets time
20:12:36 <LuisGomez> although the title in the gerrit seems to address port up/down, i think the issue is still there but i can recheck
20:12:43 <abhijitkumbhare> OK
20:13:02 <LuisGomez> action on me
20:13:05 <abhijitkumbhare> #info LuisGomez to recheck bug 3548
20:13:10 <abhijitkumbhare> #undo
20:13:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x194a690>
20:13:21 <abhijitkumbhare> #action LuisGomez to recheck bug 3548
20:13:57 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4064 “[GROUP-CHAINING]Deleting a child Indirect-Group from a parent All-group does not delete the parent from the config DS"
20:16:04 <LuisGomez> am i getting this correct? they want a parent group to disapear when there is no children?
20:16:06 <abhijitkumbhare> I don’t think it is addressed by reconciliation - but will ask Muthu if it is
20:16:12 <abhijitkumbhare> on the bug
20:16:25 <LuisGomez> i do not think this is a bug
20:17:29 <abhijitkumbhare> I think they are asking it as a feature
20:17:35 <abhijitkumbhare> may be
20:17:57 <LuisGomez> if i i am confused
20:18:33 <LuisGomez> they also say when they delete the group from config, the group is still in config…
20:19:43 <abhijitkumbhare> I guess they want the parent to be deleted if all the children are deleted
20:20:03 <abhijitkumbhare> so sounds like bit of a feature request
20:20:16 <LuisGomez> that what i undesrtood in the beginning but reading after i got confused
20:20:44 <LuisGomez> yes it is like an enhancement they are asking but i am not sure we even want that
20:21:28 <abhijitkumbhare> in any case - asking muthu will be good since he will be sitting close to the filer of the bug (who is also from Ericsson)
20:21:29 <LuisGomez> an application can create an empty group in the beginning and then add/remove children as they see fit wothout deleting the parent
20:21:56 <abhijitkumbhare> yes - that seems correct
20:22:19 <LuisGomez> empty group should not be a concern
20:22:55 <LuisGomez> if this is what they are concerned
20:23:39 <abhijitkumbhare> i have asked for a clarification
20:24:18 <LuisGomez> good
20:24:39 <abhijitkumbhare> #action Muthu to check 4064 is really a bug - and whether an empty group should be a concern?
20:24:52 <abhijitkumbhare> Last bug
20:25:00 <LuisGomez> go ahead
20:25:10 <abhijitkumbhare> Not really a code bug
20:25:14 <abhijitkumbhare> but imp
20:25:21 <LuisGomez> what is it?
20:25:30 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=2985 “Detailed Documention of different ways of programming flows, meters, groups including acks/barriers, DS vs RPCs, operational vs cfg DS"
20:25:46 <LuisGomez> ah ok
20:25:58 <LuisGomez> good luck with that :)
20:26:03 <LuisGomez> all devs will jump for sure
20:26:09 <abhijitkumbhare> I believe had asked Michal about this in the meeting :)
20:26:24 <LuisGomez> hopefully he can help
20:26:30 <LuisGomez> one more thing
20:26:36 <LuisGomez> i added this bug 2664
20:26:43 <LuisGomez> to the critical list
20:26:45 <abhijitkumbhare> so I will assign it to him - otherwise I am sure vishnoianil and kamalr are jumping up and down to grab it :)
20:26:58 <abhijitkumbhare> OK
20:27:16 <abhijitkumbhare> We can check that as well - just will action Michal
20:27:18 <LuisGomez> group FF cannot be used wothout 2664
20:27:23 <abhijitkumbhare> for this bug
20:27:51 <LuisGomez> anil created temporary fix for me but did not upstreamed it yet i think
20:28:12 <LuisGomez> vishnoianil
20:28:15 <LuisGomez> you there?
20:28:27 <vishnoianil> LuisGomez, yup
20:28:33 <LuisGomez> what is your take with bug 2664
20:28:48 <LuisGomez> https://bugs.opendaylight.org/show_bug.cgi?id=2664
20:28:49 <vishnoianil> group FF, i think the owner of the bug planned to push a fix
20:29:04 <LuisGomez> but you already got one
20:29:10 <LuisGomez> ok, we can wait
20:29:11 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=2664 “Buckets in groups are not ordered"
20:29:33 <vishnoianil> Ioakeim Samaras, told me that he will push the patch, because there was integration test that was failing with the path
20:29:37 <vishnoianil> s/path/patch
20:30:07 <LuisGomez> vishnoianil, the patch you did for me also failed int test?
20:30:23 <abhijitkumbhare> Who is Iokim Samaras?
20:30:31 <vishnoianil> i didn't run integration test for that :)
20:30:38 <LuisGomez> ah ok
20:30:40 <vishnoianil> he is the bug reported
20:30:44 <abhijitkumbhare> ok
20:30:47 <vishnoianil> s/reported/reporter/
20:31:57 <abhijitkumbhare> No I think he is not the reporter
20:32:28 <LuisGomez> ok i added comment for ETA
20:32:31 <abhijitkumbhare> but from the same org
20:32:57 <abhijitkumbhare> OK
20:33:52 <abhijitkumbhare> #action vishnoianil LuisGomez checking with Ioakeim Samaras about his fix
20:34:00 <LuisGomez> also i saw issues in longevity tests i will report for next week bug scrum
20:34:04 <abhijitkumbhare> #undo
20:34:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1cb7a10>
20:34:18 <abhijitkumbhare> : #action vishnoianil LuisGomez checking with Ioakeim Samaras about his fix for 2664
20:34:27 <abhijitkumbhare> OK LuisGomez
20:34:49 <LuisGomez> is this all or we have more?
20:34:53 <abhijitkumbhare> I think we can end the meeting now
20:35:12 <LuisGomez> very good
20:35:28 <abhijitkumbhare> we have the normal priority ones - but that will be many more - we can take them in the future
20:36:11 <abhijitkumbhare> #action abhijitkumbhare LuisGomez to discuss the priority “normal” in the future
20:36:23 <abhijitkumbhare> #endmeeting