16:01:47 <abhijitkumbhare> #startmeeting OpenFlow Plugin meeting June 1
16:01:47 <odl_meetbot> Meeting started Mon Jun  1 16:01:47 2015 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:47 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_june_1'
16:02:36 <abhijitkumbhare> #info Topics to be discussed:
16:02:47 <abhijitkumbhare> #info Bug 3350 (OVS 2.0, etc.)
16:02:56 <abhijitkumbhare> #undo
16:02:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b98150>
16:03:10 <abhijitkumbhare> #info 1) Bug 3350 (OVS 2.0, etc.)
16:03:30 <abhijitkumbhare> #info 2) Documentation - useability
16:04:11 <abhijitkumbhare> #info 3) Default OpenFlow plugin (integration repo)
16:04:28 <abhijitkumbhare> #info 4) Blocking bugs
16:05:28 <abhijitkumbhare> #info 4) Third party plugins we are using extremely old (topic for Beryllium)
16:05:40 <abhijitkumbhare> #undo
16:05:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1942890>
16:05:49 <abhijitkumbhare> #info 5) Third party plugins we are using extremely old (topic for Beryllium)
16:09:11 <abhijitkumbhare> #info odlcasey says the 3rd party plugins do not have sources - we need to update to latest stable versions for security/stability
16:11:10 <abhijitkumbhare> #info zxiiro will likely reach out to projects (to find this out)
16:11:16 <abhijitkumbhare> #undo
16:11:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a27910>
16:11:42 <abhijitkumbhare> #info zxiiro will likely reach out to projects (we need to find this out)
16:12:14 <abhijitkumbhare> #topic Bug 3350 (OVS 2.0, meters/groups, etc.)
16:14:13 <abhijitkumbhare> #info Discussion whether 3350 is a blocker bug
16:15:58 <abhijitkumbhare> #info Plan is to make these features (groups, meters, etc.) optional
16:16:18 <abhijitkumbhare> #info 3350 will be fixed by June 3
16:18:30 <abhijitkumbhare> #info kot-begemot asks whether making the features optional will add the possibility to override features
16:19:15 <abhijitkumbhare> #info martin says override will not be provided at the moment
16:19:51 <abhijitkumbhare> #topic Documentation
16:21:54 <abhijitkumbhare> #info Developers are currently busy on blocking issues - we need to figure out exactly when we can start documentation (most likely documentation)
16:22:37 <abhijitkumbhare> #info vishnoianil says we need to have at least documentation on what the users need to do (to use old or new plugin)
16:26:20 <abhijitkumbhare> #info vishnoianil says not much has changed user facing - so the old docs will still apply - some of the gaps can be addressed
16:27:03 <abhijitkumbhare> #action vishnoianil will start on some of the gaps in docs
16:27:21 <abhijitkumbhare> #topic Default OpenFlow plugin
16:28:14 <abhijitkumbhare> #info No default as such
16:28:43 <abhijitkumbhare> #info Dependent projects using the old flow services (Helium design)
16:28:48 <jamoluhrsen> sorry guys.  I have to dial out.
16:31:09 <vishnoianil> @info vishnoianil
16:31:14 <vishnoianil> #info vishnoianil
16:32:15 <vishnoianil> #info from openflowplugin project perspective there is no default setting as such for features
16:32:38 <vishnoianil> #info it's all dependent on the projects who want to consume it, they can use either of the implementation
16:33:15 <abhijitkumbhare> #topic Blocking bugs
16:33:36 <abhijitkumbhare> #info Bug https://bugs.opendaylight.org/show_bug.cgi?id=2862
16:33:47 <vishnoianil> #info given that we are at the end of the  release process, i am not sure project will be ready for doing that exercise
16:33:48 <abhijitkumbhare> #info Bug 2862 is a regression
16:34:11 <vishnoianil> #info but i believe it's individual projects decision on which version they want to use
16:34:23 <abhijitkumbhare> #undo
16:34:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a9c390>
16:34:25 <abhijitkumbhare> #undo
16:34:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1947690>
16:34:27 <abhijitkumbhare> #undo
16:34:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1947310>
16:34:28 <abhijitkumbhare> #undo
16:34:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19d7dd0>
16:34:29 <abhijitkumbhare> #undo
16:34:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1947e10>
16:34:45 <abhijitkumbhare> #info given that we are at the end of the  release process, i am not sure project will be ready for doing that exercise
16:34:52 <abhijitkumbhare> #info but i believe it's individual projects decision on which version they want to use
16:35:07 <abhijitkumbhare> #topic Blocking bugs
16:35:16 <abhijitkumbhare> #info Bug https://bugs.opendaylight.org/show_bug.cgi?id=2862
16:35:26 <abhijitkumbhare> #info Bug 2862 is a regression
16:39:03 <abhijitkumbhare> #info LuisGomez says in Helium the flow ID in config and operational used to match - and was very convenient
16:39:10 <abhijitkumbhare> #undo
16:39:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a2c110>
16:39:24 <abhijitkumbhare> #info LuisGomez says in Helium the flow ID in config and operational used to match - and was very convenient for the user
16:40:03 <abhijitkumbhare> #info In Lithium the flow ID is always shown as an alien flow
16:41:19 <abhijitkumbhare> #info vishnoianil says without the flow IDs matching - without the flow IDs matching - this will break applications & having the flow in operational will be useless
16:44:12 <abhijitkumbhare> #info vishnoianil & Martin say this should not have changed in the old design - so the applications need to be tested
16:45:19 <abhijitkumbhare> #info LuisGomez & vishnoianil think this is a blocker
16:45:31 <abhijitkumbhare> #action vishnoianil to look into this bug
16:48:50 <abhijitkumbhare> #action Jozef to continue looking into the bug for the new design
16:49:17 <abhijitkumbhare> #undo
16:49:17 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ba9590>
16:49:19 <abhijitkumbhare> #undo
16:49:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19d9b10>
16:49:26 <abhijitkumbhare> #action vishnoianil to look into this bug 2862
16:49:33 <abhijitkumbhare> #action Jozef to continue looking into the bug 2862 for the new design
17:03:11 <abhijitkumbhare> #action Martin will check if there is a clear instruction on the wiki on how to use the Lithium Karaf featureset and Helium featureset - and add it if not present
17:03:18 <abhijitkumbhare> #endmeeting