17:02:47 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting Nov 16
17:02:47 <odl_meetbot> Meeting started Mon Nov 16 17:02:47 2015 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:47 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_nov_16'
17:03:37 <abhijitkumbhare> #info Agenda
17:03:43 <abhijitkumbhare> #undo
17:03:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2606990>
17:03:57 <abhijitkumbhare> #topic Agenda for the meeting
17:04:07 <abhijitkumbhare> #info Graduation Review
17:04:30 <abhijitkumbhare> #info API changes
17:05:59 <abhijitkumbhare> #info OpenFlow Cluster Test
17:07:08 <abhijitkumbhare> #info General Issues
17:07:20 <abhijitkumbhare> #topic Graduation Review
17:07:58 <abhijitkumbhare> #info Template for Graduation review
17:08:02 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/Graduation_Reviews/Template
17:11:48 <michal_rehak> #info what is still missing for OFP:
17:12:20 <michal_rehak> #info Active Community: Prospective new developers can learn how to get involved here...
17:12:35 <michal_rehak> #info Committers vote on seeking graduation
17:13:53 <michal_rehak> #action Abhijit will send out formal vote
17:14:16 <abhijitkumbhare> #agreed Meeting participants feel OpenFlow plugin should seek graduation review
17:14:41 <abhijitkumbhare> #topic API changes and the API freeze
17:15:05 <abhijitkumbhare> #info michal_rehak notes there are several API change related gerrits that need to merge
17:15:33 <michal_rehak> #link https://git.opendaylight.org/gerrit/#/q/status:open++project:openflowplugin+branch:master
17:16:17 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:openflowplugin+branch:master+topic:experimenterMsg - Experimenter Message
17:16:47 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/28267 OpenflowProgrammer: a common middle layer for openflow programming
17:16:56 <abhijitkumbhare> #undo
17:16:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x25f4fd0>
17:18:13 <abhijitkumbhare> #info OK to merge pending code review
17:18:50 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/28267 OpenflowProgrammer: a common middle layer for openflow programming
17:20:12 <abhijitkumbhare> #action abhijitkumbhare to follow up with Yi Yang whether it is ready
17:20:20 <abhijitkumbhare> #undo
17:20:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2241f10>
17:20:46 <abhijitkumbhare> #action abhijitkumbhare to follow up with Yi Yang whether OpenFlowProgrammer is ready for merge
17:21:34 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/29357 Make the statistics polling interval configurable    Merge Conflict    Renato Aguiar
17:22:09 <abhijitkumbhare> #info OK to merge pending code review / build fixing
17:22:29 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/27382 BUG-4062: Flows,Groups,Meters not getting deleted during switch flap        Muthukumaran Kothandaraman
17:24:06 <abhijitkumbhare> michal_rehak: can you share your IRC session or give me the control?
17:24:33 <michal_rehak> abhijitkumbhare: done
17:24:34 <abhijitkumbhare> thx michal_rehak
17:27:54 <abhijitkumbhare> #info This code not affecting if switch connected (in that case flows/groups deleted as before) - this affects only when switch not connected
17:28:58 <abhijitkumbhare> #action vishnoianil will review this patch
17:29:17 <abhijitkumbhare> #info OK to merge pending code review
17:29:49 <abhijitkumbhare> #info Behavior not changing - just reconciliation made robust
17:31:27 <abhijitkumbhare> #info Knob to turn on this behavior - default old behavior (turned off)
17:32:00 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/29484 BUG-2188: To populate the port_number of switches - yang model
17:32:57 <abhijitkumbhare> #undo
17:32:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2418590>
17:34:00 <abhijitkumbhare> #info Additional change for port reconciliation - bug 4099 - being reviewed internally by Muthu / Shuva and will be shared for review by others Nov 17
17:34:19 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/29484 BUG-2188: To populate the port_number of switches - yang model
17:36:14 <abhijitkumbhare> #info No functional change - corresponding code needs to be added but michal_rehak wants the API to be present
17:36:48 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/28563/ Add PipelineManager application        Renato Aguiar
17:38:57 <abhijitkumbhare> #action abhijitkumbhare vishnoianil michal_rehak to check how Yi Yang’s patch overlap and how to merge these together
17:39:27 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/29266 Support for statistics collection per flow    Merge Conflict    Renato Aguiar
17:40:02 <abhijitkumbhare> #info OK to merge pending code review & merge fixing
17:40:30 <abhijitkumbhare> #topic OpenFlow Cluster Test
17:41:35 <abhijitkumbhare> #info Not specifically testing OF HA, but also devices that don’t support HA?
17:42:04 <abhijitkumbhare> #info LuisGomez says simple test plan - 3 node cluster test
17:42:30 <abhijitkumbhare> #info LuisGomez suite for this not yet merged
17:43:27 <abhijitkumbhare> #info However a few basic things not working - need investigation
17:44:29 <abhijitkumbhare> #info kamal will investigate RPCs
17:45:06 <abhijitkumbhare> #info Cluster test meeting on Wednesdays - LuisGomez will provide the info
17:46:40 <abhijitkumbhare> #undo
17:46:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2605410>
17:47:10 <abhijitkumbhare> #info Cluster test meeting on Wednesdays - LuisGomez has sent the info to the OpenFlow plugin mailing list
18:16:21 <LuisGomez> #info there are al least 3-4 bugs visible in the current basic OF cluster test
18:16:25 <abhijitkumbhare> #action LuisGomez  Kamal to respond to the meeting minutes email with the summary of the cluster test discussion - and folks can reply to that
18:16:47 <LuisGomez> #info I will send detailed mail after MoM
18:16:53 <abhijitkumbhare> Sure :)
18:17:05 <abhijitkumbhare> should i do endmeeting?
18:17:26 <abhijitkumbhare> LuisGomez: should I do endmeeting?
18:17:51 <abhijitkumbhare> will be sending meeting minutes immediately after
18:18:07 <abhijitkumbhare> #endmeeting