16:05:50 <abhijitkumbhare> #startmeeting OpenFlow Plugin Sept 14
16:05:50 <odl_meetbot> Meeting started Mon Sep 14 16:05:50 2015 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:05:50 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:50 <odl_meetbot> The meeting name has been set to 'openflow_plugin_sept_14'
16:06:52 <abhijitkumbhare> #topic Inventory/topology
16:07:27 <vishnoianil> #info vishnoianil
16:07:59 <abhijitkumbhare> #info michal_rehak checking if he will have spare cycles for this in October
16:08:21 <abhijitkumbhare> #topic Moving openflow plugin to mature
16:16:14 <abhijitkumbhare> #info Introduced the concept of moving projects to mature state in project life cycle
16:17:01 <abhijitkumbhare> #info Will be discussed in more detail later - as to what specific actions we need to do to move OF plugin to mature
16:17:25 <abhijitkumbhare> #topic OF extensions: circuit switch project requirements
16:18:20 <abhijitkumbhare> #info Will use multi part experimenter messages
16:18:43 <abhijitkumbhare> #info Need to get port stats
16:18:54 <abhijitkumbhare> #undo
16:18:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b7dc50>
16:19:14 <abhijitkumbhare> #info Need to get port DESC STATUS
16:19:40 <abhijitkumbhare> #info Currently PORT_DESC_STATUS not available as an RPC
16:21:26 <abhijitkumbhare> #info kamalr asks when PORT_DESC_STATUS gets put into operational DS - why can we not listen for notification?
16:22:32 <abhijitkumbhare> #info Aneesha says this is not available for circuit switch (which is a multi part experimental message)
16:23:47 <abhijitkumbhare> #info vishnoianil thinks if the multi part messages are OF 1.3 compliant - this should be handled as long as it is not proprietary
16:26:06 <abhijitkumbhare> #info vishnoianil plugin can dump the standard experimenter stuff into the Oper DS (using the current experimenter framework) - and after that the OFEXTENSIONS circuitsw should handle it
16:26:39 <abhijitkumbhare> #info Aneesha says for multi part experimenter message not present
16:27:36 <abhijitkumbhare> #info michal_rehak says we do not have models for multi part experimenter messages not present
16:28:54 <abhijitkumbhare> #action abhijitkumbhare to create a Trello card for experimenter multi part message
16:29:30 <abhijitkumbhare> #action michal_rehak will add details on the Trello card for experimenter multi part message
16:31:25 <Hari_> #info bug  547 changes (getPortDescription on demand) were reverted because the multipart request/reply can result in stale port status ... not sure if it applies for Aneesha's requirement...
16:32:24 <Hari_> this was the change.... https://git.opendaylight.org/gerrit/24568
16:32:43 <abhijitkumbhare> #info Aneesha does not have the cycles for picking up the task for experimenter multi part message, but will participate in the Beryllium release only if this support is added into OpenFlow plugin
16:35:29 <abhijitkumbhare> #action abhijitkumbhare to send an email to the OpenFlow plugin mailing list seeking a volunteer for supporting experimenter multi part message
16:37:04 <abhijitkumbhare> #topic Reconciliation
16:38:13 <abhijitkumbhare> #info Some confusion exists about what is reconciliation - Muthu will clarify
16:38:22 <abhijitkumbhare> #undo
16:38:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a8c750>
16:38:34 <abhijitkumbhare> : #info Some confusion exists about what is reconciliation - Muthu will clarify via email
16:39:23 <abhijitkumbhare> #topic Parity between Lithium and existing designs
16:39:47 <abhijitkumbhare> #info Bug 4117 : Li: Enable Yang notifications for backward compatibility
16:40:06 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4117
16:40:25 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/25965/
16:41:38 <abhijitkumbhare> #info vishnoianil thinks that the patch talks about deprecation of notifications
16:41:46 <abhijitkumbhare> #undo
16:41:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab5610>
16:42:12 <abhijitkumbhare> #info vishnoianil says that the patch talks about deprecation of notifications
16:42:44 <abhijitkumbhare> #info vishnoianil lot of folks are using notifications - and want to keep this path in the plugin for performance reasons
16:42:59 <abhijitkumbhare> #undo
16:42:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab5d50>
16:43:21 <abhijitkumbhare> #info vishnoianil says lot of folks are using notifications - and want to keep this path in the plugin for performance reasons
16:46:14 <abhijitkumbhare> #info Are we willing to say that we have to always go through the data store? However consumers of OpenFlow plugin are using it
16:46:21 <abhijitkumbhare> #undo
16:46:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19b8d90>
16:46:41 <abhijitkumbhare> : #info Are we willing to say that we have to always go through the data store? However consumers of OpenFlow plugin are likely using it
16:48:18 <abhijitkumbhare> #info vishnoianil thinks the language of deprecating notifications may not be acceptable for some folks
16:48:49 <abhijitkumbhare> #unfo
16:48:53 <abhijitkumbhare> #undo
16:48:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19b8b90>
16:49:12 <abhijitkumbhare> #info vishnoianil thinks the language of deprecating notifications may not be acceptable for some applications
16:50:18 <abhijitkumbhare> #info michal_rehak says that applications needing higher performance can directly wait for the flow programming result
16:56:27 <abhijitkumbhare> #info kamalr says the patch provides backward compatibility - but there is a performance impact
17:02:26 <colindixon> abhijitkumbhare: are you winding down?
17:02:47 <abhijitkumbhare> We have stopped recording
17:03:28 <colindixon> ok
17:03:34 <colindixon> let me try grabbing the host key again
17:03:39 <colindixon> and see if that borks us
17:03:48 <abhijitkumbhare> sure
17:03:59 <abhijitkumbhare> we are stopping colindixon
17:05:12 <abhijitkumbhare> #info abhijitkumbhare asked michal_rehak if we could write a wiki / guide for application developers to migrate to Lithium design
17:05:51 <abhijitkumbhare> #info There was a discussion on this - in short:
17:06:14 <abhijitkumbhare> #undo
17:06:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a27050>
17:06:27 <abhijitkumbhare> #info this will need to be taken to the mailing lists
17:06:37 <abhijitkumbhare> #endmeeting