15:04:06 <abhijitkumbhare> #startmeeting OpenFlow Plugin June 30, 2016
15:04:06 <odl_meetbot> Meeting started Thu Jun 30 15:04:06 2016 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:06 <odl_meetbot> The meeting name has been set to 'openflow_plugin_june_30__2016'
15:04:37 <abhijitkumbhare> #chair jbacigal shuva
15:04:37 <odl_meetbot> Current chairs: abhijitkumbhare jbacigal shuva
15:04:55 <abhijitkumbhare> #topic Agenda
15:05:33 <abhijitkumbhare> #info Deprecation of Models (Miroslav)
15:06:17 <abhijitkumbhare> #info Feature reorganization (Andrej)
15:07:25 <abhijitkumbhare> #info Extensibility framework (time permitting - Manohar)
15:07:41 <abhijitkumbhare> #info M5 deadline July 21
15:08:07 <abhijitkumbhare> #topic Deprecation of Models (Miroslav)
15:08:53 <abhijitkumbhare> #info Bug/task to deprecate notifications
15:10:18 <abhijitkumbhare> #info shuva notes that we had decided to keep the flow removed notifications (needed by VTN & VPN services)
15:16:49 <abhijitkumbhare> #info jbacigal thinks that notifications could have problems regarding the performance and other issues, Vinayak thinks the lack of notifications can lead to performance problems
15:17:50 <abhijitkumbhare> #info One of the problems is that notifications can arrive out of order - which the applications need to handle. Vinayak thinks that is an acceptable tradeoff to the applications
15:19:52 <abhijitkumbhare> #info Vinayak says we already have a knob to have notifications or not
15:21:40 <ManoharSL> #info Actually, it was decided to use the FLOW_MOD message flag to register for Flow Removal notification
15:22:16 <ManoharSL> #info If an particular NSF does not need the notification, then it has to not ask for flow removed notification
15:22:27 <ManoharSL> #info by setting the flag in FLOW_MOD message itself
15:23:15 <abhijitkumbhare> #info Miroslav says the reason for removing notifications is to have a clean API and only a single channel
15:23:43 <abhijitkumbhare> #undo
15:23:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2334990>
15:24:07 <abhijitkumbhare> #info Miroslav says the reason for removing notifications is to have a clean API and only have a single channel
15:24:14 <ManoharSL> #info The flag name is: OFPFF_SEND_FLOW_REM
15:24:25 <abhijitkumbhare> #undo
15:24:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2334990>
15:24:28 <abhijitkumbhare> #undo
15:24:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2334810>
15:24:38 <abhijitkumbhare> #info The flag name is: OFPFF_SEND_FLOW_REM
15:24:49 <abhijitkumbhare> #info Miroslav says the reason for removing notifications is to have a clean API and only have a single channel
15:31:03 <shuva> #info need to measure the cost of turning notification off and turning statistics on for large use-cases liek a million flows
15:33:59 <abhijitkumbhare> #agreed We will be going with the knob for Carbon
15:34:35 <abhijitkumbhare> #topic Feature reorganization
15:35:03 <abhijitkumbhare> #info anleitne says nothing special with respect to feature reorganization
15:36:04 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=5572 - FRM features.xml reorganize
15:36:24 <abhijitkumbhare> #info anleitne waiting for a patch merge in SDN-app
15:36:42 <abhijitkumbhare> #info after that patch merge - we should be good
15:39:11 <abhijitkumbhare> #topic M5 deadline July 21
15:39:18 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Plan
15:42:44 <abhijitkumbhare> #action jbacigal to send an email to abhijitkumbhare , muthu, vishnoianil , shuva, anleitne, etc. about singleton clustering & what may not make it in Boron
15:45:01 <abhijitkumbhare> #topic Extensibility framework
15:45:29 <vishnoianil> abhijitkumbhare, i am at hackfest, so i was not able to join the meeting
15:46:22 <abhijitkumbhare> np vishnoianil
15:47:36 <shuva> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Backlog:Extensibility
15:47:45 <abhijitkumbhare> #info ManoharSL wants to know if any changes are planned in OpenFlow Library for extensibility
15:47:49 <shuva> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Openflow_Protocol_Library%27s_extensibility
15:48:10 <abhijitkumbhare> #action ManoharSL to send out an email starting discussion on this topic
15:50:12 <abhijitkumbhare> #endmeeting