15:05:26 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting Jun 16
15:05:26 <odl_meetbot> Meeting started Thu Jun 16 15:05:26 2016 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:05:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:26 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_jun_16'
15:05:56 <abhijitkumbhare> #topic Agenda
15:06:47 <abhijitkumbhare> #info Li migration changing default
15:07:20 <abhijitkumbhare> #info Flow removed notification
15:07:54 <abhijitkumbhare> #info Code reviews
15:09:15 <abhijitkumbhare> #topic Flow removed notification
15:10:51 <abhijitkumbhare> #info Manohar says some use cases depend on flow removed notification
15:11:30 <abhijitkumbhare> #info Previously yang notifications were present in the He design
15:12:21 <abhijitkumbhare> #info Can be worked around in Li design - but it depends currently on the stats collection being present
15:14:30 <abhijitkumbhare> #info In general Manohar agrees with having data tree change - but for the short term need to have the yang notification on a config parameter (default no yang notification)
15:15:28 <abhijitkumbhare> #info In general need we need to give more thought on this - on how to solve this
15:16:55 <abhijitkumbhare> #info vishnoianil asks why yang notification for flow removed is a bad idea - currently we already have pkt in & some other yang notifications
15:26:04 <abhijitkumbhare> #info vishnoianil says some apps using RPCs for flow programming; it would be odd for them to listen for data change notification
15:26:54 <abhijitkumbhare> #info vishnoianil says that stats manager based approach can be performance intensive
15:28:48 <abhijitkumbhare> #info vishnoianil says muthu, shuva and he were discussing we should add a verifier mode - which does not need stats mgr for operational data store update
15:30:49 <abhijitkumbhare> #info jbacigal concerned about the performance of yang notification - and thinks it needs to be characterized
15:34:14 <abhijitkumbhare> #info vishnoianil thinks even if we are not going with yang notification - to update to the data store we will need to process the flow removed notification to update the data store
15:36:59 <abhijitkumbhare> #info vinayak & vishnoianil think that yang based notification would be higher performance
15:43:27 <abhijitkumbhare> #action Manohar to summarize why we need the flow removed notifications; and the cons
15:43:48 <abhijitkumbhare> #undo
15:43:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x291e190>
15:44:11 <abhijitkumbhare> #action Manohar to summarize why we need the flow removed notifications; and the cons and send the email to the list on June 17
15:44:38 <abhijitkumbhare> #topic Li migration changing default
15:46:08 <ManoharSL> Hi Abhijith
15:46:17 <ManoharSL> Just joined in to IRC :-)
15:48:00 <abhijitkumbhare> #info abhijitkumbhare to send the weather report
15:48:38 <abhijitkumbhare> #topic Code reviews
15:51:24 <hideyuki> https://git.opendaylight.org/gerrit/39102
15:51:30 <hideyuki> https://git.opendaylight.org/gerrit/39524
15:51:35 <hideyuki> https://git.opendaylight.org/gerrit/40429
15:52:07 <abhijitkumbhare> #info some patches needing reviews as per hideyuki
15:52:07 <hideyuki> https://git.opendaylight.org/gerrit/#/c/36452/
15:52:11 <hideyuki> https://git.opendaylight.org/gerrit/#/c/35359/
15:52:20 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/39102
15:52:30 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/39524
15:52:42 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/40429
15:52:58 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/36452/
15:53:10 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/35359/
15:54:13 <hideyuki> #link https://git.opendaylight.org/gerrit/#/c/40346/
15:54:25 <hideyuki> #link https://git.opendaylight.org/gerrit/#/c/40181/
15:57:10 <abhijitkumbhare> Email on “Query regarding odl-openflowplugin-nsf-model  feature”
16:00:20 <abhijitkumbhare> #endmeeting