16:02:04 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting May 16, 2016
16:02:04 <odl_meetbot> Meeting started Mon May 16 16:02:04 2016 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:04 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:04 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_may_16__2016'
16:02:16 <abhijitkumbhare> #chair jbacigal
16:02:16 <odl_meetbot> Current chairs: abhijitkumbhare jbacigal
16:02:35 <abhijitkumbhare> #chair eshuvka_
16:02:35 <odl_meetbot> Current chairs: abhijitkumbhare eshuvka_ jbacigal
16:03:14 <abhijitkumbhare> #topic Agenda
16:03:25 <abhijitkumbhare> #info M3 deliverables
16:03:39 <abhijitkumbhare> #info New FRM
16:03:53 <vishnoianil> #info vishnoianil
16:04:11 <abhijitkumbhare> #undo
16:04:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x290f290>
16:04:24 <abhijitkumbhare> #info Stats RPC - bug 5692
16:05:05 <abhijitkumbhare> #info API compatibility with the old (Helium) design
16:05:28 <abhijitkumbhare> #info Miscellaneous
16:05:39 <abhijitkumbhare> #topic M3 deliverables
16:07:03 <abhijitkumbhare> #info API compatibility
16:08:21 <abhijitkumbhare> #info Bug 4117 was added for this (notifications)
16:10:06 <abhijitkumbhare> #info There were a set of unmerged patches  https://git.opendaylight.org/gerrit/#/q/project:openflowplugin+branch:master+topic:BUG-4117
16:10:25 <abhijitkumbhare> #action eshuvka_ to take over these patches and merge them
16:11:24 <abhijitkumbhare> #info Swap the default plugin design
16:14:02 <vishnoianil> #link https://bugs.opendaylight.org/show_bug.cgi?id=5867
16:14:07 <eshuvka_> #info 5867 blocking for netvirt
16:14:10 <abhijitkumbhare> #undo
16:14:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x28bd850>
16:14:14 <abhijitkumbhare> #undo
16:14:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x28c87d0>
16:14:18 <abhijitkumbhare> #undo
16:14:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x28bd590>
16:14:33 <abhijitkumbhare> #topic Swap the default plugin design
16:14:53 <vishnoianil> #link https://bugs.opendaylight.org/show_bug.cgi?id=5873
16:14:55 <abhijitkumbhare> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=251530127 Tracking spreadsheet
16:15:05 <abhijitkumbhare> #undo
16:15:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x28c8450>
16:15:08 <abhijitkumbhare> #undo
16:15:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x293ef90>
16:15:18 <abhijitkumbhare> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=251530127 Tracking spreadsheet
16:15:43 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=5867 Blocking bug for NetVirt to migrate
16:15:59 <abhijitkumbhare> #info 5867 blocking for netvirt
16:16:49 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=5873 Not blocking for NetVirt migration - but fix needed
16:21:29 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4671 - VTN raised bug
16:24:30 <abhijitkumbhare> #info hideyuki need send Barrier flag - vishnoianil points that michal_rehak had responded that the RPC is already present
16:24:56 <abhijitkumbhare> #info hideyuki says it will take some time to implement the send barrier RPC in VTN project
16:26:14 <abhijitkumbhare> #action hideyuki will check how long it will take to implement the send barrier RPC in VTN project
16:28:40 <abhijitkumbhare> #info hideyuki wonders if the patch https://bugs.opendaylight.org/show_bug.cgi?id=5574 will solve the 4671 bug
16:29:27 <abhijitkumbhare> #action hideyuki & jbacigal to figure if the patch https://bugs.opendaylight.org/show_bug.cgi?id=5574 is related to https://bugs.opendaylight.org/show_bug.cgi?id=4671
16:33:57 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=5602 VTN raised bug - patch available from eshuvka_
16:34:21 <hideyuki> Awesome! Thanks for patches!!!
16:35:04 <abhijitkumbhare> #action hideyuki to test out eshuvka_ patch (https://git.opendaylight.org/gerrit/#/c/38639) for bug 5602
16:37:57 <abhijitkumbhare> #action jbacigal & co. to test out https://bugs.opendaylight.org/show_bug.cgi?id=5867 locally
16:39:31 <abhijitkumbhare> #topic Ne FRM
16:39:35 <abhijitkumbhare> #undo
16:39:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x28bd510>
16:39:41 <abhijitkumbhare> #topic New FRM
16:42:18 <abhijitkumbhare> #info anleitne going thru the new FRM ideas
16:43:12 <abhijitkumbhare> #info Important changes:
16:43:29 <abhijitkumbhare> #info 1) Sending only the diffs
16:43:41 <abhijitkumbhare> #info 2) Batching the RPCs
16:45:24 <abhijitkumbhare> #info These optimizations transparent to the user
16:46:42 <abhijitkumbhare> #info eshuvka_ how is group chaining handled?
16:47:06 <abhijitkumbhare> #info anleitne says currently futures chained
16:49:48 <abhijitkumbhare> #info eshuvka_ asks the performance implications when large amount of data has to be diff’ed - anleitne says will need to check
16:51:49 <abhijitkumbhare> #info New FRM will be merged - but will monitor how this works and if things are working then switch the FRM
16:52:30 <abhijitkumbhare> #info The old FRM currently will remain the default - but post test we will change if things are working
16:54:47 <abhijitkumbhare> #info LuisGomez asks how to test this? Is there an new RESTCONF? The answer is no - this is transparent to the user.
16:55:18 <abhijitkumbhare> #info jbacigal would like to brainstorm with LuisGomez about how this could be tested
16:56:07 <abhijitkumbhare> #info jbacigal & LuisGomez agree more tests would be good to have
16:57:37 <abhijitkumbhare> #info abhijitkumbhare asks eshuvka_ if bulk-o-matic can be used for testing this
16:57:54 <abhijitkumbhare> #info eshuvka_ says probably
17:00:41 <abhijitkumbhare> https://wiki.opendaylight.org/view/Weekly_Project_Meeting_List
17:00:46 <abhijitkumbhare> TWS meeting
17:00:53 <abhijitkumbhare> #endmeeting