15:08:21 <shuva> #startmeeting OpenFlow Plugin Meeting Oct 20, 2016
15:08:21 <odl_meetbot> Meeting started Thu Oct 20 15:08:21 2016 UTC.  The chair is shuva. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:08:21 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:21 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_oct_20__2016'
15:08:47 <shuva> #agenda blocking bugs for SR!
15:09:20 <shuva> #info miro working on bug 6917, fix ix already in place, luis to test and get back
15:10:33 <shuva> #info Anil was doing some internal testing 10 switches with 20 groups and 50 flows pointing to the groups
15:11:11 <shuva> #info it worked for 3-4 times and then stopped after sometime, stopped to collect group statistics
15:11:44 <shuva> #info hashwheel timertask killed due to Transaction not ready
15:12:01 <shuva> #info Anil to open a bug on this,
15:12:50 <shuva> #info there are more exceptions in the logs
15:13:13 <shuva> #chairs abhijitkumbhare
15:15:52 <shuva> #info BUG6956, BUG6575 are also blockers
15:16:36 <shuva> #info 6575 Luis is in conversation with l2switch folks
15:16:42 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=6575
15:16:57 <shuva> #info Luis feels its not impacting functionality and hence can be downgraded
15:17:16 <shuva> #info l2switch folks still investigating
15:17:31 <abhijitkumbhare> #info LuisGomez can be downgraded to critical
15:18:32 <shuva> #link https://bugs.opendaylight.org/show_bug.cgi?id=6956
15:19:21 <shuva> #info jbacigal feels its a l2switch bug not ofplugin
15:19:30 <abhijitkumbhare> #info Blocker bug raised by Alexis
15:19:48 <abhijitkumbhare> #undo
15:19:59 <shuva> #info adelathouet to put the bug into l2switch bucket
15:21:42 <shuva> #info LuisGomez thinks we need l2switch involvement for 6575, more logs and understanding of the application logic
15:22:34 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=6917
15:23:00 <abhijitkumbhare> #info Miroslav pushing a patch for this
15:25:39 <shuva> #info LuisGomez ran Miro's patch 3ce, passed 1nce, but failed 2ce
15:26:49 <shuva> #info LuisGomez feels that the patch is in good direction. but not sure if that is a problem with the patch or something else
15:27:35 <shuva> #info LuisGomez working on new set of tests on longevity, soak testing
15:28:20 <abhijitkumbhare> #topic Agenda again
15:28:50 <abhijitkumbhare> #info Bulk-o-matic PoC & testing required on it
15:29:32 <abhijitkumbhare> #info Performance in 3-node cluster
15:30:02 <abhijitkumbhare> #info Split connection layer proposal
15:31:09 <abhijitkumbhare> #info Discussions about the current test methodology
15:31:55 <abhijitkumbhare> #topic Bulk-o-matic PoC & testing required on it
15:34:54 <abhijitkumbhare> #info Tomas tried to reuse the OpenFlow Java model directly in the bulk-o-matic tests
15:35:19 <shuva> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Bulk-o-matic_enhancements
15:37:05 <abhijitkumbhare> #info LuisGomez suggests expose bulk-o-matic bulk API
15:37:11 <abhijitkumbhare> #undo
15:37:30 <abhijitkumbhare> #info LuisGomez suggests it may be useful to expose some bulk-o-matic bulk API
15:42:52 <abhijitkumbhare> #action Tomas to send the wiki about the bulk-o-matic test using OpenFlow Java model directly
15:42:59 <abhijitkumbhare> #undo
15:43:34 <abhijitkumbhare> #action Tomas to send to the mailing list the wiki about the bulk-o-matic test using OpenFlow Java model directly - and we can see if it can be run on the ODL infra
15:44:15 <abhijitkumbhare> #topic Performance in a 3-node cluster
15:44:49 <abhijitkumbhare> #info jbacigal was asking about the current tests - whether the performance tests are single node or cluster
15:45:18 <abhijitkumbhare> #info LuisGomez says most are single node test performance tests
15:46:07 <abhijitkumbhare> #info LuisGomez thinks that scalability and longevity tests need to be moved to cluster
15:48:25 <abhijitkumbhare> #topic Discussions about the current test methodology
15:51:18 <shuva> #info Prasanna feels that fixing statistics on lI is better that fixing he
15:51:29 <shuva> #undo
15:51:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a00750>
15:51:39 <shuva> #info Prasanna feels that fixing statistics on lI is better that fixing li
15:52:29 <shuva> #info Prasanna offers to go though the test cases in a meeting to see where we can do apples to apples comparison
15:53:10 <shuva> #info Prasanna to present li-plugin test-findings in about a week's time
15:54:06 <shuva> #info Prasanna feels that if it really becomes problematic, we need to take a call
16:06:05 <shuva> #info have a community call on monday to discuss the connection handling part
16:06:26 <shuva> #endmeeting