#opendaylight-ovsdb: OVSDB weekly call

Meeting started by Madhu at 19:08:14 UTC (full logs).

Meeting summary

    1. 🐱 (dave_tucker, 19:08:40)

  1. emoji exploration ;) (Madhu, 19:08:43)
    1. bro hugging = 👬 (dave_tucker, 19:09:07)
    2. : PartyPoopers : 🎉💩 (Madhu, 19:09:24)
    3. devstack = 💩 (dave_tucker, 19:09:41)
    4. floating IP work is done (tbachman, 19:12:21)

  2. Trello Updates (dave_tucker, 19:12:44)
    1. Floating IP's are tested to work - thanks tbachman (dave_tucker, 19:13:00)
    2. Ashwin posted code gerrit for schema change — not complete, but getting closer (tbachman, 19:13:19)
    3. PAX-exam patch submitted, but not merged yet. (tbachman, 19:13:48)
    4. ACTION: networkstatic to merge (tbachman, 19:13:54)
    5. https://git.opendaylight.org/gerrit/#/c/7773/ (dave_tucker, 19:14:29)
    6. ofplugin switch proposal : https://git.opendaylight.org/gerrit/#/c/7841/ (Madhu, 19:17:51)
    7. gerrit was proposed to remove OF1.0 plugin. If this is the case, there will need to be changes for OVSDB to adapt. (tbachman, 19:20:40)
    8. networkstatic to talk about NXM extensions (dave_tucker, 19:20:47)
    9. OVS allows NXMs and OXMs to be used interchangably. (tbachman, 19:21:24)
    10. networkstatic ragequits 😡 (dave_tucker, 19:26:05)
    11. stable/hydrogen is done (tbachman, 19:26:09)
    12. LBaaS support. shague_ is looking at how the existing LB works in OpenStack (dave_tucker, 19:27:15)
    13. current implementation uses HAProxy (software LB) (dave_tucker, 19:27:50)
    14. we can use OVS to load-balance instead of HAProxy (dave_tucker, 19:28:42)
    15. chris is looking at how to create a load-balancer using flows in ovs (dave_tucker, 19:29:27)
    16. we are trying to create a distributed load-balancer (dave_tucker, 19:31:59)
    17. dave_tucker asks whether we can leverage more sophisticated metrics other than just heartbeat for load balancing (tbachman, 19:36:14)
    18. flaviof has been working on L3 supprot (dave_tucker, 19:36:42)

  3. Release Plan (dave_tucker, 19:38:37)
    1. Ryan O’Hara joined the call — HAProxy guru (tbachman, 19:39:08)
    2. M2 milestone is today (dave_tucker, 19:39:42)
    3. Release plan : https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Helium_Release_Plan (Madhu, 19:40:10)
    4. https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Helium_Release_Plan Release plan (tbachman, 19:40:27)

  4. Release Plan (tbachman, 19:41:18)
  5. HAProxy/Load Balancer (tbachman, 19:41:41)
    1. goal is to implement as natively as possible using OVSDB and OpenFlow (tbachman, 19:42:38)
    2. goal is to remove the middlebox from the network. (tbachman, 19:43:39)
    3. HAProxy is a reverse proxy (tbachman, 19:44:09)
    4. In IPVS, you have to set up the NAT-ing rules yourself (tbachman, 19:45:32)
    5. HAProxy does the NAT-ing for you, in user-space (tbachman, 19:45:42)
    6. HAProxy maintains its own table of connections. (tbachman, 19:46:20)
    7. The back end (i.e. links being load balanced across) will see all traffic coming from HAProxy’s IP address (tbachman, 19:46:41)
    8. HAProxy is stateful in the sense that traffic proxied thru HAProxy has state about those TCP connections and how they’re mapped through the proxy (tbachman, 19:47:31)
    9. Madhu asks what if we have to remove HAProxy completely, and have OVS do the load balancing. (tbachman, 19:48:01)
    10. cdub notes that advanced health metrics probably won’t be doable in OVS (tbachman, 19:55:52)


Meeting ended at 20:01:50 UTC (full logs).

Action items

  1. networkstatic to merge


Action items, by person

  1. networkstatic
    1. networkstatic to merge


People present (lines said)

  1. tbachman (24)
  2. dave_tucker (18)
  3. Madhu (6)
  4. odl_meetbot (4)
  5. odp-gerritbot (1)
  6. networkstatic (0)


Generated by MeetBot 0.1.4.