#opendaylight-ovsdb: ovsdb_weekly_call

Meeting started by tbachman at 19:00:08 UTC (full logs).

Meeting summary

  1. Agenda (tbachman, 19:00:32)
    1. Trello: update on Trello cards; add new cards; Other: discuss some of the test coverage for OVSDB that we need to add for Lithium; Sonar tool coverage; code walk thru (tbachman, 19:02:32)
    2. https://trello.com/b/ddIvDQE0/ovs-openstack (shague, 19:04:25)
    3. https://trello.com/b/ddIvDQE0/ovs-openstack (flaviof, 19:05:14)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:DRAFT_Lithium_Release_Plan_ckd Lithium Release Plan (tbachman, 19:06:00)
    5. https://trello.com/b/ddIvDQE0/ovs-openstack OVSDB Trello Board (tbachman, 19:06:18)

  2. Trello Board (tbachman, 19:11:02)
    1. karaf distribution is working now on stable/helium and master (tbachman, 19:11:44)
    2. Issue had to do with bundle dependency/ordering (tbachman, 19:14:10)
    3. flaviof has been working on the L3 forwarding, and is down to one bug (floating IPs) (tbachman, 19:14:57)
    4. flaviof is working with shague on why the sonar reporting isn’t working (tbachman, 19:15:15)
    5. dfarrell07 is working on Integration Team stuff — no OVSDB updates for this meeting (tbachman, 19:18:20)

  3. sonar reporting (tbachman, 19:19:21)
    1. Every time you submit or merge code, jenkins jobs are run. (tbachman, 19:19:44)
    2. http://sonar.opendaylight.org/ (flaviof, 19:20:03)
    3. Jenkins jobs do various things, but one of the functions is to collect test status and report it to sonar (tbachman, 19:20:10)
    4. the current sonar reporting has been broken since Sept. 4th — flaviof and shague are working to fix this (tbachman, 19:23:47)
    5. ACTION: shague to figure out how to get sonar reporting information on local builds (tbachman, 19:30:49)
    6. shague recommends creating a single unit test for every bundle so that all the bundles show up in sonar (tbachman, 19:31:58)
    7. ACTION: tbachman to see if unit test coverage can exclude getters/setters (tbachman, 19:34:34)
    8. People interested in contributing should put their name on the appropriate trello card (tbachman, 19:38:33)

  4. code walk through (tbachman, 19:41:22)
    1. https://www.youtube.com/watch?v=vACyoKdefRs YouTube video created by Srini on the plugin part of the OVSDB code (tbachman, 19:42:17)
    2. The majority of the integration tests are in their own bundle (tbachman, 19:44:30)
    3. There are two distribution builds — karaf, and the legacy OSGI build (tbachman, 19:45:29)
    4. the library package uses the OVS schemas (vswitchd and vtep), and contains the code that uses the tables with this schema (tbachman, 19:50:58)
    5. The northbound package contains the v2 and v3 northbound APIs (tbachman, 19:51:21)
    6. The of-extension package has the nicira extensions used by OVS (tbachman, 19:51:38)
    7. The team is looking into restructuring the code (e.g. move nicira extensions and openstack into separate things) (tbachman, 19:53:40)
    8. The net-virt-provider contains the OpenFlow pipeline (tbachman, 19:57:24)
    9. The net-virt package is the insfrastructure under the net-virt-provider package (tbachman, 19:58:17)
    10. the plugin-mdsal-adapter adds the node to the MD-SAL (tbachman, 19:59:05)


Meeting ended at 20:01:00 UTC (full logs).

Action items

  1. shague to figure out how to get sonar reporting information on local builds
  2. tbachman to see if unit test coverage can exclude getters/setters


Action items, by person

  1. shague
    1. shague to figure out how to get sonar reporting information on local builds
  2. tbachman
    1. tbachman to see if unit test coverage can exclude getters/setters


People present (lines said)

  1. tbachman (39)
  2. odl_meetbot (5)
  3. dfarrell07 (4)
  4. flaviof (2)
  5. shague (1)


Generated by MeetBot 0.1.4.