#opendaylight-ovsdb: ovsdb_weekly_call

Meeting started by tbachman at 20:01:12 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 20:07:10)
    1. trello board (tbachman, 20:07:49)
    2. schema integration tests (tbachman, 20:07:56)
    3. other items (tbachman, 20:08:00)

  2. status (tbachman, 20:09:19)
    1. flaviof is working the openstack jenkins issue with tykeal and mestery (tbachman, 20:09:53)
    2. edwarnicke is making changes on the neutron side of things, which flaviof is trying (gerrit 12654) (tbachman, 20:10:40)
    3. https://git.opendaylight.org/gerrit/#/c/12654 gerrit that edwarnicke proposed (tbachman, 20:10:47)
    4. Currently seeing 500 errors (tbachman, 20:11:01)
    5. flaviof is hitting issues even w/o gerrit 12654 (tbachman, 20:12:31)
    6. tykeal says that django is not installed with their vagrant, and isn’t part of the build job, so it must be getting installed by devstack (?) (tbachman, 20:13:23)
    7. tykeal says that their vagrant is a modified version of what dave_tucker_zzz had, in order to work in the rackspace env (tbachman, 20:13:48)
    8. mestery notes that the Red Hat CI tests multiple versions of Fedora and CentOS, and maybe even RHEL (tbachman, 20:14:29)
    9. mestery is trying with a new version of django (tbachman, 20:15:05)
    10. shague_ says that the folks who are doing the bug fixes on the static analysis and are bringing up their dev environments could update the OVSDB wiki page that might help others in the future (tbachman, 20:17:18)
    11. tbachman asks if OVSDB is an offset 1 project (tbachman, 20:19:09)
    12. colindixon says that it’s certainly not an offset 0 project, and probably shouldn’t be an offset 2 project (tbachman, 20:19:29)
    13. colindixon notes that this makes it challenging for the OVSDB project, b/c some of the OVSDB dependencies (e.g. openflowplugin) would be releasing at the same time they are (tbachman, 20:19:56)
    14. flaviof says he’d prefer being an offset 2 project b/c of the dependencies on the openflowplugin (tbachman, 20:20:45)
    15. colindixon says that if OVSDB was 2 projects, then the protocol plugin would be offset 1, and the neutron support would be offset 2 (tbachman, 20:21:36)
    16. colindixon notes that if the project is split up before M1, then that makes things easier (tbachman, 20:21:59)
    17. colindixon says that if the project isn’t divided, then being an offset 2 project requires negotiating this with projects that depend on OVSDB (tbachman, 20:23:05)
    18. shague_ says that VTN is using OVSDB, and GBP is using the Nicira extensions (tbachman, 20:23:50)
    19. shague_ asks if there’s a way to determine who’s a user of OVSDB? (tbachman, 20:26:32)
    20. colindixon says you can grep all the projects to see where they make reference to OVSDB (tbachman, 20:27:11)
    21. ACTION: flaviof to check for which projects depend on OVSDB (tbachman, 20:27:29)
    22. https://wiki.opendaylight.org/view/File:ODL-Helium-dependency.png the dependency diagram from Helium (might not be totally accurate by now) (colindixon, 20:29:23)
    23. colindixon points out that the offsets are there to create inter-project coordination (tbachman, 20:30:47)
    24. colindixon says that if projects can agree on how to work things out, then this is less of an issue (tbachman, 20:31:04)
    25. flaviof says that there’s a change to the jenkins jobs to bump the version to 3.1.1 (tbachman, 20:32:18)
    26. flaviof asks why the guava version is related to the version of mvn (tbachman, 20:33:56)


Meeting ended at 20:35:12 UTC (full logs).

Action items

  1. flaviof to check for which projects depend on OVSDB


Action items, by person

  1. flaviof
    1. flaviof to check for which projects depend on OVSDB


People present (lines said)

  1. tbachman (44)
  2. mestery (6)
  3. odl_meetbot (5)
  4. phrobb2 (3)
  5. edwarnicke (2)
  6. colindixon (1)
  7. flaviof (0)
  8. shague_ (0)


Generated by MeetBot 0.1.4.