19:06:20 <colindixon> #startmeeting OSVSDB weekly call
19:06:20 <odl_meetbot> Meeting started Tue Mar 24 19:06:20 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:06:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:06:20 <odl_meetbot> The meeting name has been set to 'osvsdb_weekly_call'
19:06:30 <colindixon> #topic OpenStack CI
19:08:27 <colindixon> #info flaviof and mestery have gotten the Tempest tests running reliably (although with failures)
19:09:09 <colindixon> #info there are some issues where are intermitent and might be related to tomcat issues
19:09:14 <odp-gerritbot> Gabriel Robitaille-Montpetit proposed a change to ovsdb: Added version leaf to ovsdb-node-attributes of type yang::uuid  https://git.opendaylight.org/gerrit/17002
19:09:49 <colindixon> #info shague asks if this will go away with Lithium as we move away from tomcat
19:11:48 <colindixon> #info edwarnicke says that there should be no tomcat in servicing the neutron API in Lithium and so that might help some
19:14:55 <colindixon> #info the higher-level question is how easy it is to go from tempest test failures to a root cause
19:17:15 <colindixon> #link https://jenkins.opendaylight.org/releng/view/ovsdb/job/ovsdb-openstack-gerrit/ this is the job that runs the openstack CI for the ODL plugin
19:23:19 <flaviof> #link https://jenkins.opendaylight.org/sandbox/job/flavio-ovsdb-openstack-gerrit/ sample of openstack job where we pull in today's Lithuim snapshot
19:25:05 <colindixon> #action flaviof to work with colindixon to work on getting the job to run so that we can test Lithium and track how we’re making progress
19:25:43 <mohnish> sam: I will be helping out in tempest tests.
19:25:59 <mestery> flaviof: Gotta drop off now
19:29:02 <colindixon> mohnish: awesome!
19:29:44 <colindixon> #Info mohnish will help flaviof with tempest testing (the first part is to get the tempest tests to run as part of pushing patches)
19:29:48 <colindixon> #topic MD-SAL migration
19:30:02 <colindixon> #info the removing of AD-SALisms from the netvirt code is essentially done
19:30:14 <colindixon> #info we’re mostly done with the MD-SAL SB API for OVSDB
19:30:53 <colindixon> #info we still have the overlay model that needs implementation
19:35:24 <shague> https://trello.com/b/ctunVAEr/ovsdb-mdsal-southbound
19:35:42 <flaviof> high level ovsdb cards: https://trello.com/b/ddIvDQE0/ovs-openstack
19:55:26 <mohnish> regXboi: Just trying to understand. Since ODL is operating in L2, why support for IPv6 API calls required?
19:55:55 <regXboi> uh
19:56:00 <regXboi> I suspect OPNFV
19:56:04 <regXboi> mestery?
19:56:57 <mohnish> regXboi: I see. Does that mean ODL is required to support L3 in these scenarios?
19:57:11 <regXboi> are you on the bridge?
19:57:15 <mohnish> yes
19:57:19 <regXboi> ok
19:57:37 <regXboi> mohnish: I suspect the answer will be yes, but I don't know
19:57:44 <mohnish> thanks
19:57:55 <regXboi> and frankly, neutron is IPv6 aware now
20:00:39 <colindixon> #info people should keep things up-to-date in trello to help newcomers
20:00:56 <colindixon> #info if you’re working on something and there’s not a card for it, add the card
20:01:05 <colindixon> #info if you finish a card, move it to done
20:01:43 <colindixon> #info if you finish part of card, then write a comment or somehow track it
20:07:47 <odp-gerritbot> Alexis de Talhouët proposed a change to ovsdb: Add JUnit testing of TenantNetworkManagerImpl class  https://git.opendaylight.org/gerrit/17076
20:15:10 <tbachman> colindixon: is the OVSDB team meeting still going on?
20:19:31 <shague> tbachman: of course, it's the place to be :)
20:19:39 <tbachman> lol
20:19:42 <colindixon> tbachman: :p
20:19:46 * tbachman goes to pull up calendar invite
20:19:52 <colindixon> I stopped taking IRC notes at some point
20:19:56 <colindixon> *sigh*
20:19:59 <colindixon> bad colindixon, bad
20:20:07 <tbachman> lol
20:20:15 <tbachman> I can’t join, b/c the meeting is *supposed* to be over ;)
20:20:23 <shague> colindixon: yeah, we need super-bach-man to get good notes
20:20:34 <tbachman> someone have the webex link?
20:20:37 <colindixon> #chair tbachman
20:20:37 <odl_meetbot> Current chairs: colindixon tbachman
20:20:47 <tbachman> tho I bet I still won’t be able to join
20:20:49 <tbachman> silly webex :(
20:21:11 <colindixon> tbachman: I lost my link
20:21:16 <colindixon> I’m surprised you can’t join
20:21:59 * tbachman knows when he isn’t wanted ;)
20:22:01 <tbachman> lol
20:22:45 <tbachman> phrobb has sent me an email saying the recording stopped
20:22:56 <tbachman> (or the auto-mailer did at least)
20:24:27 <odp-gerritbot> A change was merged to ovsdb: Add dpdkvhost interface type  https://git.opendaylight.org/gerrit/17073
20:31:30 <odp-gerritbot> Anil Vishnoi proposed a change to ovsdb: Define Models for Port/Interface attributes and implemented port/interface create operation to configure port/interface on the ovsdb managed bridge. This patch only enables creation of port/interface with optional inputs.  https://git.opendaylight.org/gerrit/17063
22:17:15 <odp-gerritbot> A change was merged to ovsdb: Define Models for Port/Interface attributes and implemented port/interface create operation to configure port/interface on the ovsdb managed bridge. This patch only enables creation of port/interface with optional inputs.  https://git.opendaylight.org/gerrit/17063
00:13:08 <mohnish> ed/regXboi: I am seeing a IPv6 parsing error from neutron.spi. This seems to be one of main culprit for Mechanism driver subnet errors.
00:16:42 <mohnish> ed/regXboi: It couldn't parse "2003::1" string. Error location: NeutronSubnet_IPAllocationPool.java:90. Is somebody already working on it?
00:21:52 <mohnish> I meant is it a known issue. :-)
00:31:27 * tbachman still waits for someone to end the OVSDB meeting
00:31:37 <tbachman> #endmeeting