20:01:11 <tbachman> #startmeeting ovsdb_weekly_call
20:01:11 <odl_meetbot> Meeting started Tue Jan 13 20:01:11 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:01:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:11 <odl_meetbot> The meeting name has been set to 'ovsdb_weekly_call'
20:01:16 <tbachman> #chair shague
20:01:16 <odl_meetbot> Current chairs: shague tbachman
20:01:32 <tbachman> #topic agenda
20:02:08 <tbachman> #link https://meetings.opendaylight.org/opendaylight-ovsdb/2014/ovsdb_weekly_call/opendaylight-ovsdb-ovsdb_weekly_call.2014-12-09-20.10.html Last meeting that had minutes (the previous meeting didn’t have minutes)
20:02:25 <tbachman> anyone else want a chair? :)
20:04:23 <shague> mestery: joining meeting?
20:04:23 <tbachman> shague: lots of background noise
20:04:40 * tbachman looks for flaviof
20:05:54 <shague> flaviof won't be joining today.
20:06:06 <shague> I am having rouble with my audio and mic.
20:06:12 <tbachman> shague: got it
20:06:17 <tbachman> anything we can do to help?
20:06:45 <tbachman> shague: ack, but background noise
20:06:49 <tbachman> did you hear me?
20:06:55 * tbachman has been having issues with his mic
20:07:20 <mestery> shague: Double booked, can't make the meeting today unfourtanetly, will sync with you in-channel later today :(
20:10:44 <tbachman> shague: anything we can do to help?  Do you want srini to run the meeting?
20:12:38 <tbachman> shague: do you have the trello board link?
20:13:07 <tbachman> #info shague says they’re trying to figure out if there are any gaps in what’s supported with neutron and OpenStack
20:13:21 <tbachman> #info going thru L2/L3 to see what’s missing, then will move on to services
20:13:36 <tbachman> #info L2 looks mostly good
20:13:56 <tbachman> #info shague_ says that mestery and flaviof are pulling stuff out of neutron into stackforge
20:14:24 <tbachman> #info shague_ wants to wait for mestery on this, as he has all the relevant status
20:15:07 <tbachman> #link https://trello.com/b/ddIvDQE0/ovs-openstack link to OVSDB Trello Board
20:15:29 <tbachman> #info shague_ says they’re looking into what it takes to move OVSDB to MD-SAL
20:15:47 <tbachman> #info shague_ says there are a bunch of AD-SAL dependencies
20:16:42 <tbachman> #info srini084 says that on the AD-SAL side, their netvirt uses AD-SAL OVSDB; srini asks how many projects are using the AD-SAL OVSDB?
20:16:49 <tbachman> #info edwarnicke says he can find this answer
20:17:15 <tbachman> #info shague_ says there are various components in OVSDB that need to be converted, the biggest being the plugin, which has a lot of AD-SAL dependencies
20:18:33 <tbachman> #info edwarnicke says that it’s a big problem, b/c pulling in the AD-SAL pieces affects the performance of the controller
20:18:55 <tbachman> #info shague_ says they’re going through the components over the next couple of weeks to see what it would take to remove some of those dependencies
20:19:51 <tbachman> #info edwarnicke says that the projects using the AD-SAL plugin for OVSDB, he found (via grepping pom files), it’s VTN, Toolkit, OVSDB netvirt
20:20:17 <tbachman> #info srini084 says they’ll have a conversation with the VTN project
20:22:26 <tbachman> #info shague_ says that the MD-SAL adapter is only there to populate the MD-SAL with the OVSDB node
20:22:41 <tbachman> #info shague_ says that converting all the DB stuff over would take quite a bit of work
20:23:01 <tbachman> #info edwarnicke asks if the MD-SAL is just a read-only adapter
20:23:11 <tbachman> #info srini084 says it looks like a read-only adapter
20:23:47 <tbachman> #info shague_ says the adapter was written by dave_tucker, so that you could query the MD-SAL to find all the OVSDB nodes
20:23:57 <tbachman> #info paulq_ asks if you can only query
20:24:05 <tbachman> #info shague_ says that yes, it’s only for queries
20:25:14 <tbachman> #info edwarnicke asks what kinds of things aren’t doable
20:25:35 <tbachman> #info shague_ says everything — projects that want to query bridges, ports, interfaces, etc. these are all columns in the DB
20:25:59 <tbachman> #info srini084 says that the columns are already predefined, and each info you insert can be a pointer to another table
20:29:38 <tbachman> #info edwarnicke asks that in order to find a way forward, is there a way to get the 80% of what we need
20:30:35 <tbachman> #info shague_ says that to go to MD-SAL, you have to go to a model, but they have this data stored internally; there’s a difference between creating an adapter on top of this, and moving all this to an MD-SAL model
20:31:16 <tbachman> #info edwarnicke says he wonders if we need to migrate all of the data to the MD-SAL, or just the pieces that we need.
20:31:50 <tbachman> #info srini084 says the bridge and the port were all that they were really using
20:32:05 <tbachman> #info paulq_ says tunnel is a form of port and attributes of that (e.g. interfaces, tags, etc.)
20:32:39 <tbachman> #info shague_ agrees it’s a smaller subset, but the problem is overall state management
20:34:15 <tbachman> #info shague_ says port/bridge/controller are probably the main things that are important
20:34:27 <tbachman> #info alagalah asks about QOS, etc.
20:34:41 <tbachman> #info shague_ says that SFC probably doesn’t care about those, but he can see how GBP might
20:34:59 <tbachman> #info alagalah says that anything in the data path, GBP may want to have CRUD access
20:35:21 <tbachman> #info edwarnicke says he’d like to understand the timing of when things are needed, as that can affect what gets prioritized
20:35:55 <tbachman> #info alagalah says if it’s a choice, he agrees it would be the three that shague_  mentioned
20:37:34 <tbachman> #info edwarnicke says that the place he’d worry is how state works in a clustered environment
20:40:11 <tbachman> #info paulq_ says they want a clear API that maps to service chain ops (build tunnel with following attributes, etc.)
20:40:38 <tbachman> #info shague_ says that’s consistent with his understanding, and says that interface exists, but it’s an AD-SAL implementation
20:40:51 <tbachman> #info paulq_ asks if there’s a place to look at this API, or do we have to look at the code
20:41:07 <tbachman> #info shague_ says you kind of have to look at the code. VTN might be a good project to look at
20:41:23 <tbachman> #info shague_ says you just insert rows into the schema tables to create things
20:41:40 <tbachman> #info paulq_ asks if this assumes there’s something that renders this into the appropriate OVSDB info
20:43:13 <alagalah> Swami: Can you mute yourself?
20:45:33 <tbachman> #info shague_  the question of MD-SAL is how quickly we can get this done (e.g. how can this work be done in time for the Li release)?
20:46:09 <tbachman> #info shague_ asks if the project has to be full MD-SAL in order to support clustering
20:46:28 <tbachman> #info those are questions we’d want answers to in order to schedule it all
20:46:57 <tbachman> #info shague_ asks alagalah how important clustering support is to GBP
20:47:39 <tbachman> #info alagalah says it’s not so much clustering, but it will become important
20:47:55 <tbachman> #info alagalah says it’s more about getting the ability to do CRUD operations
20:48:03 <Swami> alagalah: already muted
20:48:23 <tbachman> Swami: must be a different one
20:48:38 <tbachman> There’s a Swami on the call that wasn’t muted (now is)
20:49:20 <tbachman> #info edwarnicke says projects have had issues when they keep certain local state (e.g. local hash-maps)
20:50:01 <tbachman> #info shague_ says you can do all these CRUD operations today, as VTN uses it… just not MD-SAL
20:50:28 <tbachman> #info paulq_ says they’d prefer not to drag AD-SAL along with SFC
20:51:30 <tbachman> #info shague_ says it’s one thing to have the mirroring piece for the 3 tables; but all the stuff in hash maps that not in the MD-SAL is a lot
20:56:57 <tbachman> #info edwarnicke asks what happens if more than one controller node talks to the OVSDB server
20:57:13 <tbachman> #info shague_ says you’d have multiple managers writing to the database, and updates are reported up to the controllers
20:57:19 <paulq_> https://lists.opendaylight.org/pipermail/discuss/2014-December/004153.html
20:57:28 <tbachman> #info edwarnicke says that with the mirroring approach, they would probably be okay
21:02:57 <tbachman> #link https://lists.opendaylight.org/pipermail/discuss/2014-December/004153.html email thread talking about MD-SAL
21:03:19 <tbachman> #info edwarnicke says there’s also a question to separate out the netvirt pieces as well
21:03:32 <tbachman> #info shague_  says that’s a whole different issue
21:03:46 <tbachman> #info alagalah says that GBP would also prefer not to pull in the whole AD-SAL stuff
21:03:56 <tbachman> #info shague_ says that’s the long-term goal, but more of a question on how to get there
21:04:15 <tbachman> #info alagalah asks if there’s a postman collection to become familiar with the V3 APIs
21:04:45 <tbachman> #info shague_ says that’s the NB v3 API, but the CRUD operations don’t have a good document
21:05:02 <tbachman> #info shague_ says he’ll find some good code to point alagalah to for CRUD operations
21:05:34 <tbachman> #info alagalah says it’s easy to start with something like the REST APIs to learn about what can be done
21:05:45 <tbachman> #info shague_ says there’s a gdoc that shows the APIs from the V3 stuff
21:06:05 <tbachman> #info shague_ says he thinks there are also postman scripts checked in to resources dir
21:06:21 <alagalah> Thanks shague_
21:06:48 <tbachman> #action shague_ to capture what was said and try to work on a plan on how to get these pieces done
21:07:18 <tbachman> #info shague_ asks if  resource that edwarnicke mentioned can reach out to shague_
21:07:34 <tbachman> #info edwarnicke to talk to the person to reach out
21:07:51 <tbachman> #info alagalah asks about the email from colin_dixon re: MD-SAL and OVSDB
21:08:10 <tbachman> #info edwarnicke says that we’re trying to work out times, and notes that the OVSDB meeting time is tough for Europe and Asia
21:09:36 * tbachman hears a regXboi :)
21:10:17 <tbachman> #info regXboi says you’d need to walk through the deprecation process in order get this done in time for the Boron release
21:11:00 <tbachman> #info edwarnicke says that he believes that ghall was interested in moving to an MD-SAL ML2 mechanism driver
21:11:19 <tbachman> #info regXboi says that the code reference in the email does that, which he feels is a bad idea
21:12:13 <tbachman> #endmeeting