20:00:11 <tbachman> #startmeeting ovsdb_weekly_call
20:00:11 <odl_meetbot> Meeting started Tue Jan 27 20:00:11 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:00:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:11 <odl_meetbot> The meeting name has been set to 'ovsdb_weekly_call'
20:00:15 <tbachman> #chair shague
20:00:15 <odl_meetbot> Current chairs: shague tbachman
20:00:19 <tbachman> #chair flaviof
20:00:19 <odl_meetbot> Current chairs: flaviof shague tbachman
20:00:24 <tbachman> #topic Agenda
20:00:34 <tbachman> #link https://meetings.opendaylight.org/opendaylight-ovsdb/2015/ovsdb_weekly_call/opendaylight-ovsdb-ovsdb_weekly_call.2015-01-20-20.00.html Minutes from last week’s meeting
20:01:56 <mestery> shague: Joining ?
20:02:08 <mestery> #info It's my birthday today
20:02:13 <tbachman> mestery: nice!
20:02:15 <shague> yeah, joinging now...
20:02:25 <shague> let's sing happy birthday
20:02:37 <tbachman> Is there such a thing as a vSong?
20:02:40 <mestery> rofl
20:02:41 <tbachman> MP3 I guess
20:02:44 <mestery> only if tbachman records it
20:02:46 <mestery> and dave_tucker joins
20:02:47 <mestery> ;)
20:02:47 <tbachman> LOL
20:02:57 <tbachman> mestery: we need ghangout, with gdraw
20:03:00 <tbachman> draw you a birthday hat ;)
20:03:05 <tbachman> all of us, actually
20:03:11 <mestery> lol
20:03:12 <flaviof> lol
20:03:44 <plaurin_> haha!
20:04:04 <mestery> #info shague suggests the "50 Cent" version of "It's Your Birthday" for mestery's song.
20:04:09 <tbachman> LOL
20:04:13 <mestery> ROFL
20:04:16 <tbachman> it’s in the minutes
20:04:21 <tbachman> recorded for posterity
20:04:24 <mestery> indeed
20:04:31 <abhijitkumbhare> Happy birthday mestery
20:04:38 <mestery> Thanks abhijitkumbhare! :)
20:06:11 <tbachman> #topic trello board
20:06:52 <tbachman> #info shague finished getting all the IT tests into the integration directory
20:07:15 <tbachman> #info shague and edwarnicke have been coordinating on getting neutron into it’s own MD-SAL piece
20:07:51 <tbachman> #info plaurin_ has finished porting of L3 services, and is now working on creating the UT for the services
20:08:12 <tbachman> #info mestery is hoping that Swami can set up a call to go over the testing
20:08:30 <tbachman> #action Swami to set up a call to go over UT, possibly on Friday
20:09:03 <tbachman> #info DPDK integration with Eric Multanen, Sharad, and edwarnicke is ongoing — working on the models
20:10:10 <tbachman> #info Eric asks if the capability to support DPDK ports is going to be in the stackforge effort
20:10:42 <tbachman> #info shague says that the OVS L2 agent is what’s talking to OVSDB — the agent is being replaced by ODL integration
20:11:02 <tbachman> #info mestery says that ODL is effectively doing the work that the agent was doing
20:11:41 <tbachman> #info mestery says that before the kilo release, the entire plugin was upstream in neutron, and did contain back-end logic to talk to ODL. As part of the decomposition in neutron, there will be a super-thin plugin that pulls in the stackforge project
20:12:08 <tbachman> #info Eric asks where the openstack folks are going to get the DPDK port information
20:12:47 <tbachman> #info shague says there are some neutron calls that talk to the OVS agent, which goes back into nova so it can use DPDK ports; since the L2 agent isn’t there any more, where would that belong/go with ODL?
20:13:30 <tbachman> #info Eric says that they want to know if the given host and bridge can support a DPDK port type, so that nova can go and spawn that VM
20:14:08 <tbachman> #info mestery says those VIFs are created by Nova
20:14:24 <tbachman> #info mestery asks if this can be as simple as a check of OVS versions?
20:15:36 <tbachman> #info shague says he doesn’t think the version matters, b/c when the VIF gets spun up, they need to query to see if it is a DPDK supported port; shague thinks blp added some support to bridge tables to indicate this
20:15:53 <tbachman> #info mestery says this would have to be exposed in ODL
20:15:58 <tbachman> #info mestery asks who’s doing this query
20:16:14 <tbachman> #info shague says it’s in openstack - they come down thru neutron L2 agent
20:16:28 <tbachman> #info mestery says that even if we put the data in the database, that’s not going to work
20:16:36 <tbachman> #info shague asks if the ODL stackforge stuff can address this
20:16:51 <tbachman> #info mestery says we might have to expose those details as part of the port binding
20:17:08 <tbachman> #info mestery says that requires some coordination in the back-end ODL side, as the ML2 driver doesn’t have anything running on the host
20:17:26 <tbachman> folks — make sure I’m getting this stuff right :)
20:17:43 <tbachman> #topic stackforge efforts
20:20:29 <tbachman> #info recording started 20-minutes into the meeting
20:21:04 <tbachman> #info as part of the kilo development work, blueprint was approved where all of the plugins and drivers are going through the decomposition process
20:21:24 <tbachman> #info there was a lot of code in neutron dealing with proprietary or opensource backends, where reviewers didn’t understand the backends
20:21:25 <flaviof> #link https://launchpad.net/networking-odl "OpenDaylight backend controller integration with Neutron"
20:21:39 <tbachman> #info there are over 25 plugins and drivers in neutrons, and only 14 reviewers
20:21:55 <tbachman> #info The result is that everyone can have a thin shim in neutron which is a pass thru
20:22:17 <tbachman> #info the back-ends can live in stackforge, github, etc., and can iterate much faster
20:22:25 <tbachman> #info there are still CI requirements on the backends
20:22:36 <tbachman> #info The ODL mechanism driver is the first to be fully decomposed upstream
20:22:51 <tbachman> mestery: any links you can share here to put in the minutes?
20:23:13 * tbachman goes off to look for links
20:23:59 <tbachman> #link https://github.com/stackforge/networking-odl Stackforge ODL project
20:24:28 <tbachman> #info Users will be able to use pip to install, or setup.py to install locally as well
20:24:43 <flaviof> #link https://review.openstack.org/gitweb?p=stackforge/networking-odl.git networking-odl gerrit
20:24:54 <tbachman> flaviof: thx!
20:25:37 <tbachman> #info mestery says there’s been a good confluence of people who are new to either OpenStack or OpenDaylight that have been jumping in
20:26:09 <tbachman> #info Swami, plaurin_, et. al. have joined in the development
20:26:59 <tbachman> #info mestery says that once this infra is in place, the tempest testing can be addressed
20:27:10 <tbachman> #info mestery filed a bunch of bugs on them, some of which are hard to replicate
20:28:21 <tbachman> #info flaviof says ODL also has an effort to take neutron out of the controller, which will isolate it and help with other efforts
20:28:50 <tbachman> #info mestery says that CI is pretty hosed at the moment, but it didn’t make sense to work on CI until the stackforge stuff was set up
20:29:24 <tbachman> #info mestery and colindixon says that a small, focused, sprint can happen via hangout/bluejeans/!webex
20:29:40 <tbachman> #info edwarnicke asks if this is connected with the ODL integration team
20:30:01 <tbachman> #info edwarnicke says that’s the right place for the CI to live, as that’s the thing that always gets checked for every bug fix release
20:30:24 <tbachman> #info vishnoianil_ says there’s a plan to integration neutron to the integration team
20:30:40 <tbachman> #info mestery says he’d like to move the jenkins config into Jenkins Job Builder as well
20:31:01 <tbachman> #info mestery says he doesn’t think the neutron tempest ever ran against the jobs on the OVSDB side
20:31:15 <tbachman> #info edwarnicke asks where integration stands on migrating their jobs into Jenkins Job Builder
20:31:47 <tbachman> #info shague says moving their stuff into JJB is kind of hard; wonders if integration doing this will help out here
20:32:01 <tbachman> #info edwarnicke says he knows this is a high priority for the integration group
20:33:56 <tbachman> #info flaviof asks if ovsdb needs a CI in openstack that doesn’t use OVS, would that be better when the neutron has moved out of the controller
20:34:14 <tbachman> #info edwarnicke says all the providers would live downstream; everything meets in the integration project, which makes it the optimal place to do this stuff
20:34:35 <tbachman> #info flaviof says there are a lot of hooks into OVS, and isn’t sure how much of that could be “faked out"
20:35:10 <tbachman> #info colindixon says the distribution selected could run the respective tests against that distribution; that could be part of the hack-fest work
20:35:22 <tbachman> oooh
20:35:24 <tbachman> boom
20:36:04 <tbachman> #info mestery says he feels these jobs need to live in OVSDB; configuring things like VTN and OpenDove is outside the scope of what we’d want to do
20:36:17 <tbachman> #info colindixon says we shouldn’t take on resposibility for that as part of the OVSDB project
20:36:50 <tbachman> #info edwarnicke says the multiple implementations of neutron stuff makes it more efficient to have this in integration
20:37:33 <tbachman> #info flaviof asks how agnostic tempest is of OVS
20:38:05 <tbachman> #info mestery says it’s pretty agnostic; however, things have to be configured for ODL; if OpenDove and VTN folks need to drive this testing, they’d have to provide this configuration
20:38:38 <tbachman> #info mestery says right now they’re pulling released versions of ODL; the matrix gets complex quickly, which is one reason for just using released versions
20:39:11 <tbachman> #info mestery wants to make sure the upstream openstack CI stuff is in OVSDB
20:40:01 * tbachman is in test confusion limbo
20:40:09 * tbachman hopes he hasn’t misrepresented any of this
20:40:24 * colindixon isn’t sure that he followed all of that, but he’s happy that others have
20:41:03 <tbachman> colindixon: real-time action item ;)
20:41:28 <tbachman> #endmeeting