16:01:29 <shague> #startmeeting Netvirt Weekly 2/14/17
16:01:29 <odl_meetbot> Meeting started Tue Feb 14 16:01:29 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:29 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_2_14_17'
16:01:34 <shague> #info shague
16:01:50 <shague> #info Everyone please #info in
16:01:52 <vthapar> #info vthapar
16:02:04 <alonko> #info alonko
16:03:11 <vpickard> #info vpickard
16:03:19 <jamoluhrsen> #info jamoluhrsen
16:03:34 <mattw4> #info
16:03:37 <aswinsuryan> #info aswinsuryan
16:03:43 <mgkwill> #info Marcus Williams
16:03:45 <afredette> #info Andre Fredette
16:03:50 <mattw4> #info Matt Welch
16:04:06 <shague> #topic previous actions
16:04:52 <vpickard> #info daya was have network connection issues, dialed into last mtg
16:05:20 <shague> #action daya, yamahata: come up with spec for dhcp port
16:06:16 <shague> #info action review the current csit, find where coverage is lacking
16:06:31 <shague> #info openflowplugin patch causing problems
16:08:01 <shague> #info thsi patch is breaking csit: https://git.opendaylight.org/gerrit/#/c/50153
16:08:18 <shague> #info revert is in https://git.opendaylight.org/gerrit/#/c/51814
16:08:19 <sridharg> #info Sridhar Gaddam
16:09:59 <shague> #action shague folowup with anil on openflowplugin patches
16:10:47 <shague> #action jamoluhrsen to add bocking bug
16:11:04 <shague> #action: alonko daya_k vthapar shague start list of test overage
16:13:01 <shague> #info vivek has a test lead in team that cna review test coverage
16:13:59 <shague> #info vthapar: asks about coverage for different config options
16:14:21 <shague> #info need to add tests for different configs
16:14:45 <vthapar> #action vthapar to compile list of current configuration flags
16:15:10 <shague> #topic compile csit test list
16:17:42 <shague> #action alonko, shague vivek vthapar : after adding csit test list work on adding new tests
16:18:43 <shague> #action alonko, shague work with vivek on adding sandbox setuo
16:20:02 <shague> #topic action tomer to contact vivek about pnf spec
16:20:35 <shague> #info vivek reviewed pnf spec, waiting on next review
16:21:04 <shague> #topic: jamoluhrsen look at quick scaling tests
16:21:29 <shague> #info jamoluhrsen no progress yet
16:22:12 <shague> #info mgkwill, mattw4: info on scale tests
16:23:13 <shague> mgkwill: mattw4: can you #link the slides?
16:23:52 <mgkwill> shague: sure, we will put on google and link
16:25:11 <odp-gerritbot> Tali Ben-Meir proposed a change to netvirt: Bug 7790 - Attempting to install RNH on local DPN for FIB with custom instructions  https://git.opendaylight.org/gerrit/51846
16:26:27 <shague> #info current setup uses docker containers
16:29:01 <shague> #info current to make this consumable upstream and increase scale to 500 nodes
16:29:30 <mattw4> WIP hosted at: https://github.com/matt-welch/docker-devstack
16:29:54 <shague> #link https://github.com/matt-welch/docker-devstack
16:30:30 <shague> #info extend setup to add quagga
16:34:52 <odp-gerritbot> Tali Ben-Meir proposed a change to netvirt: Bug 7790 - Attempting to install RNH on local DPN for FIB with custom instructions  https://git.opendaylight.org/gerrit/51846
16:38:03 <shague> #idea everyone add notes as needed
16:39:45 <shague> #info try to add scale setup to csit
16:40:19 <alonko> #info S3P working on docker environment, loading devstack computes for scale testing
16:40:24 <alonko> #info https://github.com/dileepranganathan/ODLRallyPlugin
16:40:26 <afredette> #info Ideally, we could run it on a regular basis to track whether functional changes affect scale and performance
16:41:06 <alonko> #info https://github.com/matt-welch/docker-devstack
16:41:15 <shague> #action mgkwill connect with trozet about the opnfv snapshots
16:42:35 <shague> #info mgkwill says this would be good to find home in opnfv cperf
16:43:23 <shague> #topic shague check with trozet on opnfv scale testing and someone to find out what/how/where for rally
16:44:03 <shague> #info jamoluhrsen thinks current work doesn;t apply
16:44:17 <mgkwill> #link https://jira.opnfv.org/browse/CPERF-5
16:44:19 <shague> #topic get peri +1 for parentRef specs
16:44:47 <shague> #info gerrits merged, looking good.
16:44:54 <trozet> shague: you just need to ask the functest guys what they test in rally..there is rally in OPNFV functest
16:44:58 <shague> #info some bfd tests with auto tunnels have problems
16:45:18 <trozet> shague: http://artifacts.opnfv.org/functest/docs/functest.html#rally-bench-suite
16:45:44 <shague> #action alonko still looking at failures
16:46:07 <shague> #topic:
16:46:12 <shague> #topic vthapar to merge genius and netvirt patches
16:46:39 <shague> #related to parentRef: done
16:48:23 <jamoluhrsen> jamoluhrsen @ ddf
16:48:53 <shague> #info: many waiting on OpenStack Summit CFP's getting accepted
16:49:07 <mgkwill> mgkwill @ ddf
16:49:25 <shague> #topic Roll call for OpenStack summit 5/8/17-5/11/17 and ODL DDF 5/31
16:50:48 <shague> #info HPE and E/// leaning more towards DDF, soem might go to Os if CFP's accepted
16:51:08 <afredette> #info most likely will go to OpenStack Summit.  would likely go to DDF if there is good turn-out
16:51:27 <afredette> #info above comment was about /me
16:52:12 <shague> #topic genius DataChange deprecations
16:53:11 <shague> #info mdsal has deprecated DatachangeListener but genius /netvirt still uses them
16:53:40 <shague> #info there are performance issues
16:54:58 <shague> #action vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree
16:55:05 <shague> #info weather page has been created
16:56:41 <shague> #action vhtapar and faseela to present datajob and other improvements in next meeting
16:57:17 <vthapar> #link https://wiki.opendaylight.org/view/Weather#Genius_AbstractDataChangeListener_clean-up
16:57:38 <shague> #topic specs
16:58:32 <shague> #action Daya to add netvirt spec for dhcp changes, there are pipeline updates
17:00:04 <shague> #info most specs are ready for next round of reviews: vni, bgp, counters and statictics
17:01:00 <shague> #info also review evpn rt2 and multiple vxlan specs, qos-alerts
17:02:34 <shague> #topic Hairpinning patches, VXLAN VNI patches
17:03:12 <shague> #info pacthes are ready, need to be reviewed
17:03:42 <shague> #action vivek to review patches laster this week
17:05:30 <shague> #endmeeting