16:01:44 <shague> #startmeeting NetVirt Weekly 2/21/17
16:01:44 <odl_meetbot> Meeting started Tue Feb 21 16:01:44 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:44 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_2_21_17'
16:01:53 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
16:02:12 <shague> #topic Review existing action items
16:03:33 <odp-gerritbot> A change was merged to netvirt: Fix several NPEs showing up in CSIT  https://git.opendaylight.org/gerrit/52084
16:03:51 <odp-gerritbot> Kiran N Upadhyaya proposed a change to netvirt: Adding debug statements to track caching of Operational Vpn Instances  https://git.opendaylight.org/gerrit/52118
16:04:18 <odp-gerritbot> A change was merged to netvirt: adding lport tag for temporary mac learning  https://git.opendaylight.org/gerrit/52069
16:05:14 <skitt> #info skitt
16:05:15 <vishnoianil> #info Anil Vishnoi
16:05:20 <vpickard> #info Victor Pickard
16:05:42 <alonko> #info Alon Kochba
16:06:12 <mattw4> #info Matt Welch
16:06:16 <shague> #topic switch to #opendaylight-netvirt
16:06:16 <aswinsuryan> #info Aswin Suryanarayanan
16:06:47 <shague> #info switch to opendaylight-netvirt going forward
16:07:13 <sridharg> #info Sridhar Gaddam
16:07:23 <shague> #info daya, yamahata: come up with spec for dhcp port
16:08:02 <shague> #action daya, peri to write spec end of week
16:08:30 <shague> #info [DONE} shague folowup with anil on openflowplugin patches
16:08:45 <shague> #info [DONE] jamoluhrsen to add bocking bug
16:09:02 <shague> #info alonko daya_k vthapar shague start list of test overage
16:09:11 <shague> #action alonko daya_k vthapar shague start list of test coverage
16:09:31 <shague> #action: shague start a thread on the test coverage
16:09:52 <shague> #action vthapar to compile list of current configuration flags
16:09:53 <odp-gerritbot> A change was merged to netvirt: Fix priority in IntervpnLink flows installed in LFIB  https://git.opendaylight.org/gerrit/51991
16:10:16 <shague> #info alonko, shague vivek vthapar : after adding csit test list work on adding new tests
16:10:35 <shague> #action alonko, shague vivek vthapar : after adding csit test list work on adding new tests
16:11:26 <shague> #action: alonko, shague work with vivek on adding sandbox setup, send docs to vivek
16:11:44 <shague> #info vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree
16:12:09 <shague> #info [DONE] vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree
16:12:39 <shague> #info [DONE] vhtapar and faseela to present datajob and other improvements in next meeting
16:13:01 <shague> #info patches are raised and need to be reviewed
16:13:15 <shague> #info Daya to add netvirt spec for dhcp changes, there are pipeline updates
16:13:47 <shague> #info [DONE] vivek to review patches laster this week
16:14:33 <shague> #topic M4 - 3/2/17 - API Spec freeze
16:18:07 <shague> #info alonko: DHCP spec review
16:18:10 <shague> #linke https://trello.com/c/0mgGyJuV/153-dhcp-server-dynamic-allocation-pool
16:20:25 <shague> #topic DHCP server spec
16:20:35 <shague> #info does ipv6 work also
16:20:46 <alonko> #action check if proposed DHCP server allocation works for IPv6, and also if we are adding neutron IPv6 port support
16:21:20 <shague> #topic SFC spec
16:21:43 <shague> #info spec to provide high-level design
16:21:52 <shague> #info need help from others to implement
16:23:33 <shague> #info vishnoianil networking-sfc v2 driver has been merged
16:25:26 <odp-gerritbot> Vivekanandan Narasimhan proposed a change to netvirt: releasing dcn thread once tunnel interface state dcn delivered  https://git.opendaylight.org/gerrit/51890
16:25:43 <vishnoianil> #link https://review.openstack.org/#/c/389081/
16:25:46 <shague> #info sfc translator code can be moved to new netvirt
16:26:15 <odp-gerritbot> Marcos López Samaniego proposed a change to netvirt: Bug 7772 - Service Chaining is not being applied to VMs in the L3VPN  https://git.opendaylight.org/gerrit/51681
16:30:12 <shague> #topic csit:exceptions
16:30:17 <shague> #link: https://trello.com/c/OynhbCPa/133-csit-exceptions-in-logs
16:32:13 <shague> #info patches will be out for review
16:33:57 <alonko> #action run in sandbox with fail on exception, see what happens
16:37:09 <shague> #topic: when to switch to ocata?
16:37:42 <shague> #info alonko: ocata needed for coe csit
16:38:09 <shague> #info: ocata has deprecated some apis and fails tests
16:40:19 <shague> #info: vivek: mitaka is default and needs to be supported
16:41:31 <shague> #info: alonk thinks maybe the reclone workarounds might fix the mitaka jobs
16:41:41 <jamoluhrsen> alonko, yeah, gonna stay mute
16:41:49 <shague> #action: jamoluhrsen to talk with venkat about reclone
16:41:51 <jamoluhrsen> shague, let's try the reclone thing in the sandbox and see
16:42:02 <jamoluhrsen> 10-4
16:43:28 <odp-gerritbot> A change was merged to netvirt: Adding debug statements to track caching of Operational Vpn Instances  https://git.opendaylight.org/gerrit/52118
16:43:34 <shague> #action: shague make sure there is a mitaka gate job
16:44:26 <alonko> #info mitaka gate job exists with stateful
16:45:32 <shague> #action: [DONE] shague make sure there is a mitaka gate job - job already exists
16:45:41 <shague> #endmeeting