14:59:39 <alonko> #startmeeting NetVirt Weekly 4/4/17
14:59:39 <odl_meetbot> Meeting started Tue Apr  4 14:59:39 2017 UTC.  The chair is alonko. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:39 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_4_4_17'
15:00:22 <alonko> #topic Roll call and agenda bashing (please #info <your-nick>)
15:00:26 <alonko> #info Alon Kochba
15:02:16 <vpickard> #info Vic Pickard
15:02:35 <skitt> #info skitt
15:03:02 <alonko> #topic Review previous week action items
15:03:15 <aswinsuryan> #info Aswin Suryanarayanan
15:04:36 <alonko> #info [DONE] sent mail to openflowplugin about open bugs
15:04:40 <daya_k> are we not using meetbot today?
15:05:01 <daya_k> #info daya_k joined
15:05:34 <alonko> #action vivekn to follow up with Hema on the openflowplugin issues
15:06:17 <alonko> Hi Daya, we are :)
15:06:48 <alonko> #info [DONE] Started bug scrubbing, will continue this week
15:07:17 <alonko> #info Request assignees make sure to update bugs they are working on, and assign them to themselves
15:11:08 <alonko> #topic Bugzilla bug scrubbing
15:11:36 <alonko> #action vthapar need to compile a list of modules we want to add to bugzilla components and send out helpdesk request for easier filtering
15:14:17 <sridharg> #info Sridhar Gaddam
15:14:30 <alonko> #topic stable/carbon to be pulled next week
15:15:53 <alonko> #info current planned date is 04-10
15:16:11 <alonko> #info we should push to wrap up all feature activity this week before branch is cut
15:16:30 <alonko> #topic Review remaining patches
15:18:13 <alonko> #info only several small patches remaining for HPE blueprints - alonko to send list to wrap up this week
15:18:48 <alonko> #info from E/// side there are a few patches for 3 remaining features - EVPN, L3VNI and ECMP
15:20:33 <alonko> #info vni-based-l2-l3-nat still missing two new patches yet to be raised
15:20:45 <odp-gerritbot> Miguel Perez proposed a change to netvirt: Refactor InterVpnLink. Part THREE  https://git.opendaylight.org/gerrit/54280
15:20:47 <alonko> #info this flag will be enabled to check CSIT once all patches are in
15:25:11 <alonko> #info EVPN and ECMP have a few more patches too - trying to wrap everything up this week
15:31:42 <alonko> #info requesting more peer reviews between companies wherever possible, especially on core features
15:33:15 <alonko> #info VNI final patches will be prioritized to enable HPE reviews this week
15:36:33 <alonko> #topic CSIT stability efforts
15:37:05 <alonko> #info a lot of the latest exceptions and bugs have been handled, scrubbing continues
15:37:29 <alonko> #info Tali's fix for the dispatcher remaining flows came in that should fix a lot of the remaining DHCP issues
15:38:03 <alonko> #info we need to aim for 100% passing CSIT to prepare for Carbon release
15:41:00 <alonko> #info a few known bugs remain to be handled - the rest need to be rescrubbed if they still happen
15:42:15 <alonko> #info for SNAT fix - need to consider the RPC fix to flow configuration for SNAT
15:43:24 <alonko> #info another option is to start trying to test the new SNAT code
15:46:27 <alonko> #topic adding of new CSIT tests after stabilization
15:48:45 <alonko> #info will go over blueprints and start adding in new CSITs for new features during the following month
15:49:39 <alonko> #topic SFC integration
15:49:50 <alonko> #info SFC integration almost done, one final patch remaining and then testing should begin
15:50:11 <alonko> #info we should be able to support SFC in Carbon both using SFC direct API and using openstack-sfc
15:50:18 <alonko> #topic HWVTEP cards moved to netvirt trello
15:51:16 <alonko> #info HWVTEP decided to use the netvirt board to help sync between netvirt and HWVTEP
15:51:25 <alonko> #info CSIT tests were added for HWVTEP
15:51:51 <alonko> #topic Upgrade-ability discussions
15:52:23 <alonko> #info mvorburger interested in setting up a bi-weekly call for discussing upgrade-ability, across ODL and also specifically for netvirt
15:58:12 <alonko> #info interest in this both for netvirt specific problems and general ODL issues, should set up discussions before DDF and continue in session there
15:58:13 <vpickard> vorburger: here is  a link to ODL meetings
15:58:14 <alonko> #endmeeting