17:04:07 <fabiel> #startmeeting Persistence Weekly Meeting
17:04:07 <odl_meetbot> Meeting started Wed Jan 21 17:04:07 2015 UTC.  The chair is fabiel. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:07 <odl_meetbot> The meeting name has been set to 'persistence_weekly_meeting'
17:07:20 <nachiket331> #info Agenda
17:08:25 <nachiket331> #info Status Update #info Lithium Release Plan Review #info Questions #topic Status Update
17:08:41 <nachiket331> #undo
17:08:44 <nachiket331> #info Status Update
17:08:59 <nachiket331> #info Lithium Release Plan Review
17:09:11 <nachiket331> #info Questions
17:09:27 <nachiket331> #topic Status Update
17:09:49 <nachiket331> #link https://wiki.opendaylight.org/view/Persistence:Main Persistence facts page
17:11:29 <nachiket331> #link https://wiki.opendaylight.org/view/Persistence:Weekly_Meeting Persistence Weekly Meeting
17:11:44 <nachiket331> #link https://wiki.opendaylight.org/view/Persistence:Lithium_Release_Plan Persistence Lithium Release Plan
17:11:55 <nachiket331> #link https://jenkins.opendaylight.org/releng/view/persistence/ Persistence Jenkins Jobs
17:12:07 <nachiket331> #link https://sonar.opendaylight.org/dashboard/index/31868 Persistence SonarQube
17:12:16 <nachiket331> #link https://bugs.opendaylight.org/buglist.cgi?bug_status=__open__&order=Importance&product=persistence&query_format=specific Persistence Bugs
17:12:28 <nachiket331> #topic Lithium Release Plan Review
17:15:27 <nachiket331> #info Do we need the status column in the release plan ?
17:17:17 <nachiket331> #action fabiel will upload the persistence release plan to lithium release plan for review
17:18:13 <nachiket331> #info sonar tracks unit test coverage
17:22:06 <nachiket331> #action fabiel or nachiket331 we need to investigate more on how system testing and CI is done for persistence. Is it Robot ? we create a test app using SQL lite for CI for now ?
17:29:00 <nachiket331> #action we need to investigate what applications will use the database ? Can they come with their own database as part of their plugin and install the relevant service without having to restart the controller ?
17:31:31 <nachiket331> #info As part of the developer guide, we should include information on implementing new database service
17:32:27 <nachiket331> #action update the JPA support section saying we will ship with SQLite DB by default
17:34:48 <nachiket331> #agreed Move Persistence API definition to M3
17:36:00 <nachiket331> #action investigate Nexus Repository Binary artifacts. What is it ?
17:38:25 <nachiket331> #agreed Move Configuration Module integration to M4
17:40:56 <nachiket331> #action we will look at an approach to hook persistence into MD-SAL framework before API freeze
17:45:08 <nachiket331> #action fabiel will follow up with Uyen to see where the common API should be placed ? Two possibilities are persistence or yang-tools
17:45:29 <nachiket331> #action common can also be in controller itself
17:47:50 <nachiket331> #action fabiel will update the release plan to update Expected dependencies on Other projects. Dependencies are ODL parent, controller and yang-tools as of now
17:49:16 <nachiket331> #info the serialization project proposal that uses SQLite persistence is an incompatibility.
17:50:08 <nachiket331> #action we should try to work with serialization project folks and get them onboard
17:51:08 <nachiket331> #action we need to work with yang-tools project to get support on Identifiable interface definition for Persisted objects
17:51:38 <nachiket331> #topic Open Questions
17:51:59 <nachiket331> #info No questions
17:53:18 <nachiket331> #action fabiel will update the wiki to accept questions before the meeting and also a notes of the meeting
17:53:37 <fabiel> #endmeeting