17:00:07 <tbachman> #startmeeting sfc_weekly
17:00:07 <odl_meetbot> Meeting started Thu Feb 19 17:00:07 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:07 <odl_meetbot> The meeting name has been set to 'sfc_weekly'
17:00:07 * ebrjohn_ it only took me 10 minutes this time
17:00:10 <tbachman> #chair ebrjohn_
17:00:10 <odl_meetbot> Current chairs: ebrjohn_ tbachman
17:00:22 <tbachman> #link https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-02-12-17.00.html Last week’s meeting minutes
17:00:29 <tbachman> #topic agenda
17:04:08 <tbachman> #info ebrjohn_ asks if we can get a POC in time for M3
17:04:08 <tbachman> #info ebrjohn_ says repenno has updated the functional spec
17:04:49 <tbachman> #info edwarnicke says that SFC is delegating the classification
17:05:02 <tbachman> #info ebrjohn_ says that’s been the assumption — GBP decides what traffic goes into SFC
17:05:15 <tbachman> #info edwarnicke says you might need to put a new classifier type into the model
17:07:03 <tbachman> #info ebrjohn_ asks how GBP and SFC are going to work
17:07:35 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/15491/ gerrit in SFC to provide API to GBP
17:08:07 <tbachman> #linkk https://git.opendaylight.org/gerrit/#/c/15255/ gerrit in GBP to invoke SFC functionality
17:09:24 <tbachman> #info edwarnicke says we have a new action in GBP, which specifies the service function chain name
17:10:19 <tbachman> #info edwarnicke says just getting the service chain name, that should should be enough to handle the ingress
17:10:27 <tbachman> #info paulq and ebrjohn_ say yes
17:10:40 <tbachman> #info paulq wants to make sure that SFC is handing back everything GBP needs
17:11:01 <tbachman> #info edwarnicke asks how modular is the thing that handles the SFC action
17:12:37 <tbachman> #info tbachman asks what edwarnicke means by modular
17:13:05 <tbachman> #info edwarnicke also asks who might be contributing to things like MPLS encap
17:13:34 <tbachman> #info ebrjohn_ had mentioned the possibility of doing the MPLS part in GBP
17:14:28 <tbachman> #info edwarnicke says he’d like to see integration soon as possible, as that’s when we find issues
17:14:36 <tbachman> #info edwarnicke says M3 is also coming up, which is functionality freeze
17:14:54 <tbachman> #info ebrjohn_ agrees — says we have about 1 month
17:17:16 <tbachman> #info ebrjohn_ asks if we can shoot for getting commits merged by Monday
17:17:26 <tbachman> #info tbachman says we can shoot for Monday
17:18:03 <alagalah> ebrjohn_: may I suggest we touch on how things are progressing with merging the patches in the GBP meeting tomorrow ?
17:18:11 <tbachman> #info ebrjohn_ asks if there’s anything else that needs to be discussed about integrating GBP and SFC
17:18:52 <tbachman> #info paulq says there’s a question on the next hop. In a perfect world, the packet would pop-out and the tunnel would be in place. However, you don’t always know where you’re going to pop out, as services move, etc.
17:19:09 <tbachman> #info paulq says having an API to query an overlay API for this info would be helpful
17:19:17 <tbachman> #info ebrjohn_ says that’s more of a long-term item
17:19:34 <tbachman> #info paulq is fine with preconfigured tunnels for the POC
17:20:30 <tbachman> #info mickey_spiegel says there’s one issue he doesn’t understand yet — if we have multiple ways in through classifiers (e.g. 2 different L4 ports into the same chain), how do we get it to go through the same set of nodes; reuse a service path? two different paths?
17:21:12 <tbachman> #info paulq says he’s not sure if it matters for phase 1; using NSH as an example, for a given path ID, SFC programs the data plane appropriate to go to the same nodes — so it’s consistent
17:21:27 <tbachman> #info mickey_spiegel asks if GBP should be asking for only 1 rendered service path?
17:21:48 <tbachman> #info ebrjohn_ says rendered service paths can be symmetric — you’re going to have to have two service paths
17:22:07 <tbachman> #info mickey_spiegel says he wasn’t referring to direction - should be a pair instead of one; is curious what that API looks like
17:23:03 <tbachman> #info mickey_spiegel says GBP has EPGs 1 & 2, with classifier where port 80 needs SFC and port 8080 does as well. Does GBP ask for two service paths?  If so, does that make different service function instances?
17:23:24 <tbachman> #info ebrjohn_ says last week we spoke about asking a service chain in a more abstract way — we want a FW, DPI, etc.
17:24:15 <tbachman> #info mickey_spiegel says it’s a simpler question; If port 80 and port 8080 are different rules in GBP, and we want them to go thru the same service function instances, does GBP ask for one chain or two?
17:24:54 <tbachman> #info paulq says it comes down to what the meaning of a service function path is; for POC, let’s keep it simple
17:25:19 <tbachman> #info paulq says that for now, when you request a chain from SFC, SFC constrains it to return the same path
17:25:47 <tbachman> #info mickey_spiegel says that’s a work-around for short term, but is interested in the long term solution
17:26:35 <tbachman> #info ebrjohn_ says that the service path has already been created, so should be there; if you ask multiple times, should be the same thing returned
17:27:06 <tbachman> #info mickey_spiegel asks if the chain is created by name, or by ID
17:27:28 <tbachman> #info ebrjohn_ says the path should be created by the time GBP asks for it; the API just returns the ID
17:28:22 <tbachman> #info paulq asks if mickey_spiegel can put his question to the mailling list — also since repenno isn’t here for today’s call
17:31:14 <tbachman> #action tbachman and repenno to get patches merged by monday
17:31:33 <tbachman> #action ebrjohn_ to send email to lists asking for folks to review the patches
17:32:14 <tbachman> #endmeeting