17:02:00 <tbachman> #startmeeting sfc_weekly
17:02:00 <odl_meetbot> Meeting started Thu Feb 26 17:02:00 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:00 <odl_meetbot> The meeting name has been set to 'sfc_weekly'
17:02:03 <tbachman> #chair ebrjohn
17:02:03 <odl_meetbot> Current chairs: ebrjohn tbachman
17:02:23 <tbachman> #topic Agenda
17:02:29 <tbachman> #link https://lists.opendaylight.org/pipermail/sfc-dev/2015-February/000943.html Agenda for today’s meeting
17:02:40 <tbachman> #link https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-02-19-17.00.html Minutes from last week’s meeting
17:03:17 <tbachman> #topic Status of GBP+SFC integration
17:03:58 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/15759 gerrit from reinaldo to support SFC+GBP integration
17:05:32 <tbachman> #info tbachman says GBP has merged a patch on GBP’s side — working on a new patch based on repenno’s latest gerrit
17:05:54 <tbachman> #info repenno says that the changes in the latest gerrit  are mostly backwards compatible
17:06:19 <tbachman> #info repenno says this one supports different encaps. Construction of the RSP includes the SFF data plane locator of how to reach the SFF used to enter the RSP
17:06:35 <tbachman> #info repenno says you theoretically could have an SFF with vxlan, another with MPLS, etc.
17:06:50 <tbachman> #info repenno says that doesn’t change much from the way things work — just additions to existing code
17:07:18 <tbachman> #info repenno says in the Service Function Path, the user can provide the name of the encap to be used on the RSP
17:07:41 <tbachman> #info the default is vxlan + NSH, but supports other types provided by user
17:08:08 <tbachman> #info repenno this allows GBP to ask SFC for the first hop of the RSP and get back a Java RSP hop object
17:08:27 <tbachman> #info repenno says GBP can get the appropriate values needed from the RSP object
17:08:51 <tbachman> #info ebrjohn says GBP needs the first hop to set up the tunnel to SFC
17:09:02 <tbachman> #info ebrjohn says if the path is symmetric, GBP will have to call twice
17:09:32 <tbachman> #info repenno says this is the first integration. repenno says that GBP really doesn’t want to know the encap, and symmetric
17:09:49 <tbachman> #info repenno says that for now, for the POC, this will be sufficient
17:10:19 <tbachman> #info ebrjohn says the previously the RSP was created internally when the SFP was configured; now that’s not the case any more — RPC needs to be called explicitly
17:10:43 <tbachman> #info repenno says that was already the case with the UI; if you came through RESTCONF to create an SFP, it did that internally
17:11:05 <tbachman> #info repenno says multi-encap use case leads us down the road of doing this internally
17:11:34 <tbachman> #info ebrjohn says we probably can get that merged in today
17:11:43 <tbachman> #action tbachman to review and provide comments on the patch
17:11:51 <tbachman> :)
17:11:53 <tbachman> on it :)
17:12:15 <tbachman> #topic SFC OVS
17:13:28 <tbachman> #info ebrjohn says there was an email sent on this
17:13:32 <tbachman> #link https://lists.opendaylight.org/pipermail/sfc-dev/2015-February/000935.html email on this
17:15:13 <tbachman> #info ebrjohn provided a patch to support MPLS
17:15:18 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/15501/ gerrit that added this
17:15:22 <tbachman> #topic M3 Milestone
17:15:29 <tbachman> #info ebrjohn says M3 is just 3 weeks away
17:17:01 <tbachman> #endmeeting