16:00:00 <tbachman> #startmeeting sfc_weekly
16:00:00 <odl_meetbot> Meeting started Thu Mar 12 16:00:00 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:00 <odl_meetbot> The meeting name has been set to 'sfc_weekly'
16:03:20 <tbachman_> #chair ebrjohn
16:03:21 <tbachman_> #topic agneda
16:03:22 <tbachman_> #link https://lists.opendaylight.org/pipermail/sfc-dev/2015-March/001014.html Agenda for today’s meeting
16:03:25 <tbachman_> #link https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-03-05-17.01.html Minutes from last week’s meeting
16:04:31 <tbachman> #topic status
16:04:39 <tbachman> lol
16:04:41 <tbachman> agneda
16:04:43 * tbachman can’t type
16:05:50 * ChrisPriceAB cookie fingers!
16:06:07 <tbachman> lol!
16:06:31 <tbachman> #info repenno says we’re reaching a point in SFC where a lot of stuff is working well and stable, but we need to improve unit tests and make them work reliably
16:06:47 <tbachman> #info repenno ran the unit tests yesterday and said there are a lot of problems
16:07:20 <tbachman> #info repenno reached out to some folks to clean these up, but encourages others to run the unit tests themselves and resolve the issues
16:07:57 <tbachman> #info ebrjohn says the unit tests should be run in jenkins — asks why these NPEs aren’t causing the tests cases to fail
16:09:11 <tbachman> #info repenno also discovered that different team members tests in different configurations — e.g. with things “connected”, without things “connected”, etc.
16:09:41 <tbachman> #info ebrjohn says we should create some tasks — the first task should be that any exception thrown from a test case should cause the test case to fail
16:10:03 <tbachman> #info ebrjohn says then each responsible party can clean up the exceptions
16:10:28 <tbachman> #info ebrjohn says repenno mentioned that there are some tasks related to the RPC that was recently deprecated
16:10:45 <tbachman> #info ebrjohn says the team may want to consider using the Trello board to track the growing list of items
16:10:58 <tbachman> #action ebrjohn to set up a Trello board for SFC
16:11:27 <tbachman> #action ebrjohn john will create Trello card for unit tests to fail on exceptions
16:13:19 <tbachman> #info ebrjohn says when you start karaf and look at the logs, there are some exceptions in the logs that should be cleaned up as well (e.g. 6-7 or exceptions about not being able to create bundles)
16:13:50 <tbachman> paging ChrisPriceAB!
16:14:04 * ChrisPriceAB one minute speaking...
16:14:08 * ChrisPriceAB tick tick
16:14:54 <tbachman> #topic OPNFV
16:15:18 <tbachman> #info ChrisPriceAB says there’s a proposal for OPNFV function chaining waiting for some action
16:15:44 <tbachman> #info ChrisPriceAB says in parallel, there’s a discussion with GBP, as GBP is providing a level of abstraction that OpenStack can communicate through in order to do SFC
16:16:12 <tbachman> #info ChrisPriceAB says after the first release of OPNFV in April, looking to bring in ODL trunk, and start to run and deploy that
16:16:27 <tbachman> #info ChrisPriceAB says he’d like to wrap that in an OPNFV recognized activity
16:17:16 <tbachman> #info ChrisPriceAB wants to see where we are in response to that, and if the late April/early May time frame looks okay to do this
16:17:40 <tbachman> #info ebrjohn says this is absolutely beneficial for ODL and SFC to participate in OPNFV — unless someone objects, recommends doing that
16:18:00 <tbachman> #info ebrjohn says by end of April/beginning of May, should be able to export that out to OPNFV
16:19:53 * tbachman ^H^H^H^H^H
16:20:13 <tbachman> #info Someone says there’s an OpenStack-based network graph effort that might be intending to use ONOS
16:20:28 <tbachman> #undo
16:20:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19a6690>
16:20:32 <tbachman> :)
16:21:12 <tbachman> #info repenno says we need to fix the deliverables; the Intel folks had an interest in the project
16:21:29 <tbachman> #info ChrisPriceAB says the Qosmos team is coming on board and also has expressed an interest
16:22:19 <tbachman> #info repenno says from the ODL/GBP perspective, we can show something, but from OPNFV perspective, there’s some packaging/installation questions
16:22:38 <tbachman> #info repenno says that doesn’t stop us from showing GBP + SFC
16:22:59 <tbachman> #info ChrisPriceAB says there might be a number of installers, but the endpoint is a stable state of OpenStack and OpenDaylight
16:25:01 <tbachman> #info ebrjohn says if we have an API freeze on 4/16, and code freeze on 5/14
16:25:11 <tbachman> #info ebrjohn says we can also create a branch to pull if needed
16:25:34 <tbachman> #info ChrisPriceAB says we do this work on the Lithium main branch so that when it’s released, it’s coupled with the OpenStack “L” release
16:25:58 <tbachman> #info ebrjohn is more concerned about the API freezes
16:28:05 <tbachman> #info repenno would prefer not to hinge the SFC project on the requirements
16:28:59 * tbachman couldn’t hear that — internetz dropping in and out
16:29:49 <tbachman> #info ebrjohn asks how Andrej how his effort is progressing
16:30:00 <tbachman> #info Andrej says he hasn’t had a chance to look at the documentation
16:30:08 <tbachman> is it just me, or is anyone else having trouble hearing Andrej?
16:30:53 <tbachman> #action ebrjohn to touch base with Andrej on all of the things that are being worked on
16:33:16 <tbachman> #action ebrjohn to touch base with ContexStream and Intel folks on Monday, re: M3
16:33:49 <tbachman> #info repenno says the Intel guys did the new SFC/GBP API, which allows GBP to pass a list of service functions
16:34:27 <tbachman> #info repenno had a discussion with Intel yesterday, and they’re going to try to do a generic SFC Netconf implementation
16:34:44 <tbachman> #info repenno says if this goes well, we should include that in our M3
16:35:13 <tbachman> #endmeeting