16:00:03 <tbachman> #startmeeting sfc_weekly
16:00:03 <odl_meetbot> Meeting started Thu Mar 26 16:00:03 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:03 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:03 <odl_meetbot> The meeting name has been set to 'sfc_weekly'
16:00:08 <tbachman> #chair ebrjohn
16:00:08 <odl_meetbot> Current chairs: ebrjohn tbachman
16:00:43 <tbachman> #link https://lists.opendaylight.org/pipermail/sfc-dev/2015-March/001053.html email providing the agenda for today’s meeting
16:01:00 <tbachman> #link https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-03-19-16.03.html Link to last week’s meeting minutes
16:02:56 <tbachman> #topic SFCOFL2 patch
16:03:27 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/17074 Gerrit that get encapsulation details for the SFCOFL2 renderer
16:07:58 <tbachman> #info ebrjohn says he’d rather hold off any decisions on the patch until paulq and repenno have a chance to look at the patch
16:08:13 <tbachman> #info ebrjohn says we can discuss the patch today if folks are interested
16:08:56 <tbachman> #info ebrjohn says the SFCOFL2 renderer is the openflow renderer in SFC; was present in the Helium release, but lacked encapsulation and only supported very simple/basic topologies
16:09:15 <tbachman> #info ebrjohn says he’s refactored it to support “normal” SFC topologies, and added VLAN and MPLS encapsulations
16:09:26 <tbachman> #info ebrjohn says the openflowpipeline (the easy part) is done
16:09:42 <tbachman> #info ebrjohn says the hard part - writing configuration information into the SFCOFL2 plugin - still needs to be done
16:10:28 <tbachman> #info ebrjohn provides an example with a service chain with two SFFs — problem is you need to know the encap info between SFF1 and SFF2: ingress to SFF1 and egress from SFF2; asks “where do you specify this information?"
16:11:14 <tbachman> #info ebrjohn says you could specify this on the individual SFF — on ingress and egress — providing things like VLAN 100 and VLAN 200, but that won’t work: need to specify a unique VLAN per RSP
16:11:54 <tbachman> #info ebrjohn says as an example, given 3 RSPs, with RSP1 using VLAN 100, RSP2 using VLAN 200,a nd RSP3 using VLAN 300. Do you need to create a data plane locator per path? (won’t scale)
16:13:07 <tbachman> #info ebrjohn says you could put this in the service path, and then the RSP is created by merging the SFC and SFP
16:14:09 <tbachman> #info ebrjohn says we need to discuss this in more detail — need repenno and paulq involved in that discussion
16:15:11 <tbachman> #info repenno noted that we need some sort of function, where there is a pair of SFFs and the path ID, and provides encap info for that hop
16:15:58 <tbachman> #info ebrjohn asks Andrej how they do this with NSH?
16:17:41 * tbachman wakes up
16:17:48 <tbachman> sorry - got distracted again
16:18:16 <tbachman> #action ebrjohn to schedule a separate meeting with paulq and repenno on that topic
16:18:24 <tbachman> #topic Other Items
16:18:41 <tbachman> #info ebrjohn says he’s on vacation next week (Easter week in Spain)
16:18:57 <tbachman> #info ebrjohn asks if anyone is available to host the meeting next Thursday
16:19:21 <tbachman> #action ebrjohn to send email to the SFC mailing list, asking if anyone can host the meeting
16:20:08 <tbachman> #info ebrjohn says the M4 is on April 16th; This is the API freeze, so we need to have those finalized by then
16:20:42 <tbachman> #info ebrjohn says that all of the documentation needs to be at “draft” quality for M4
16:20:57 <tbachman> #info ebrjohn set up tasks for M4 in the Trello board
16:22:12 <tbachman> #info ebrjohn says we need a simple set of System Tests for M4 as well
16:24:48 <tbachman> #info ebrjohn says there’s a hackathon between M4 and M5 milestones
16:25:12 <tbachman> #info ebrjohn says anyone interested in going is more than welcome
16:25:54 <tbachman> #link http://www.opendaylight.org/events/2015-04-15/opendaylight-hackfest-april-2015 web page on the hackfest
16:26:26 <tbachman> #info ebrjohn says Ricardo Noriega is joining the team from Ericsson
16:26:53 <tbachman> #info Ricardo will be joining the SFC project after Easter; has some experience with ODL in Helium
16:28:34 <tbachman> #info ebrjohn says that ChrisPrice talked a few weeks ago about SFC being integrated into OPNFV; ChrisPriceAB suggested ebrjohn nominate himself in OPNFV as well as the SFC project lead
16:29:36 <tbachman> #info ebrjohn says the bulk of the tasks will be to pull from the ODL git repo, build it, and test it in an integration environment with OpenStack
16:29:58 <tbachman> #info ebrjohn says OPNFV will likely push use cases back into ODL
16:30:35 <tbachman> #endmeeting