16:04:39 <tbachman> #startmeeting sfc_weekly
16:04:39 <odl_meetbot> Meeting started Thu Jul 16 16:04:39 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:39 <odl_meetbot> The meeting name has been set to 'sfc_weekly'
16:04:43 <tbachman> #chair ebrjohn
16:04:43 <odl_meetbot> Current chairs: ebrjohn tbachman
16:04:51 <tbachman> #link https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-07-09-16.00.html Minutes from last week’s meeting
16:06:29 <tbachman> #topic https://lists.opendaylight.org/pipermail/sfc-dev/2015-July/001397.html Agenda for today’s meeting
16:06:33 <tbachman> #undo
16:06:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1b6fad0>
16:06:39 <tbachman> #link https://lists.opendaylight.org/pipermail/sfc-dev/2015-July/001397.html Agenda for today’s meeting
16:06:45 <tbachman> #topic SFC Demo from Ricky
16:07:14 <ebrjohn> #link https://docs.google.com/presentation/d/1VYaL2lDV4HGj0qIfUHWXbRDUbXx-0z0RYlKmQ6lpq3U/edit?usp=sharing
16:07:18 <ebrjohn> That's the demo
16:07:21 <tbachman> #undo
16:07:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1cb8a10>
16:07:32 <ebrjohn> did you undo my link?
16:07:34 <tbachman> #link  https://docs.google.com/presentation/d/1VYaL2lDV4HGj0qIfUHWXbRDUbXx-0z0RYlKmQ6lpq3U/edit?usp=sharing Link to document describing the demo
16:07:38 <tbachman> good to have context
16:07:39 <ebrjohn> ok, thanks
16:07:43 <tbachman> otherwise just shows up as a link in the minutes
16:08:54 <tbachman> #info ericano_ presents demo on SFC that uses an HTTP proxy (SQUID) to show traffic traversing different chains
16:09:14 <tbachman> #info The motivation for the demo is to be able to easily set up and use ODL SFC
16:10:03 <tbachman> #info The demo graphically shows which service chain a client is using; this is done using a client talking to an apache web server, which traverses different chains that add HTTP headers to change the color of a web page
16:10:58 <tbachman> #action ebrjohn to send an email to the SFC ML with a link to today’s presentation
16:11:13 <tbachman> #info The demo uses two classifiers, two SFFs, and two SFs
16:11:20 <alagalah> I stilkl can't get in
16:11:33 <tbachman> #info The demo uses 3 service chains.
16:11:46 <tbachman> #info Chain #1 just traverses SF1, which colors the web page blue
16:11:56 <tbachman> #info Chain #2 just traverses SF2, which colors the web page red
16:12:11 <tbachman> #info Chain #3 traverses SF1 and SF2, which colors the web page purple
16:12:13 <ebrjohn> alagalah: sorry man, we had trouble at first, but its working now
16:12:19 <ebrjohn> we're recording just in case
16:12:24 <tbachman> alagalah: it’s a european thing ;)
16:12:38 <tbachman> no chains from europe ;)
16:12:41 <tbachman> (save spain)
16:13:21 <tbachman> #info The demo uses a vagrant setup, which makes it easy to stand up and use
16:13:50 <tbachman> #info ericano_ says the script starts the controller, which runs in one of the VMs
16:14:17 <tbachman> ebrjohn: kubuntu is another distro that’s small
16:14:32 <tbachman> fwiw
16:14:33 <ebrjohn> its actually xubuntu
16:14:45 <tbachman> yeah - just throwing out other options :)
16:14:51 <ebrjohn> ahh, ok, sorry
16:15:39 <ebrjohn> Ive tried lubuntu too, but it was too basic
16:15:48 <tbachman> ah
16:15:50 <ebrjohn> lubuntu = lightweight ubuntu
16:15:52 <tbachman> maybe that’s the one I was thinking of
16:15:55 <tbachman> yeah, that’s it
16:15:57 * tbachman has no memory
16:16:03 <tbachman> I rely way too much on googl
16:16:04 <ebrjohn> xubuntu is lighter weight, but not too basic
16:21:37 <tbachman> #info lmcdasm asks what’s been defined by the demo
16:21:50 <tbachman> #info ericano_ says it defines the SF types, SFFs, etc.
16:22:10 <tbachman> #info ericano_ says that instead of using the gui, the configuration is pushed using REST calls
16:24:51 <tbachman> #info the demo has some tools to help — such as a tool to show clients, list rendered service paths, and assign paths to clients
16:25:33 <tbachman> #info lmcdasm asks if the reason that you need the classifier function is that you never know what the classifier is until you have a client
16:25:55 <tbachman> #info ebrjohn says that this demo doesn’t use NSH, so there’s a bit of a workaround for the classifier for the demo
16:26:24 <repenno> did you folks record the meeting so we can review the demo?
16:26:33 <lmcdasm> yup
16:26:36 <tbachman> #info meenakshi asks if the RSPs is information from ODL
16:26:37 <lmcdasm> its recording
16:26:39 <tbachman> #info ebrjohn says yes
16:26:55 <tbachman> #Info meenakshi asks if the RSP IDs are a result of RSP creation
16:26:58 <tbachman> #info ebrjohn says yes
16:27:17 <tbachman> #info ebrjohn says the REST sender tool can be used to query the datastore to query/list the RSPs, if desired
16:28:19 <tbachman> #info lmcdasm asks if this informed mininet about the RSPs that were assigned to the client
16:28:21 <tbachman> #info ericano_ says yes
16:28:57 <tbachman> #info ericano_ says the header enrichment isn’t yet running — need to open consoles on the SFs and start the process for header enrichment
16:29:05 <tbachman> #Info ericano_ says there are scripts in the demo to do that
16:31:12 <tbachman> #info lmcdasm asks if we’re using an SFF at this point
16:31:16 <tbachman> #info ericano_ says yes
16:32:17 * tbachman crosses fingers
16:32:34 <tbachman> ericano_: did you start the server?
16:32:51 <tbachman> I guess you would have gotten an immediate error if that were the case
16:34:33 <tbachman> #info lmcdasm asks if you have to unassociate with the first chain before associating the second chain, or is this done automatically
16:34:45 <tbachman> #info ebrjohn says the client tool is just setting up the classifier — the RSPs are always there
16:34:54 <tbachman> #undo
16:34:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a8ce50>
16:35:06 <tbachman> #info ebrjohn says the client tool is just setting up the classifier — the RSPs are there
16:35:35 <tbachman> #info ebrjohn says in a big scenario, you could have a DPI or PCIF controlling the classifier
16:35:53 <ebrjohn> PCRF Policy Control Routing Function
16:36:14 <tbachman> ebrjohn: thx!
16:36:15 <tbachman> #undo
16:36:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a8c8d0>
16:36:34 <tbachman> #info ebrjohn says in a big scenario, you could have a DPI or PCRF (Policy Control Routing Function) controlling the classifier
16:37:55 <tbachman> #info meenakshi asks where the classifier flows are programmed in the demo?  Is it at the client?  At the SFF?
16:38:26 <tbachman> #info ebrjohn says there is an ingress and egress classifier switch — and those are where the classifiers are programmed
16:38:40 <tbachman> #info ebrjohn says the classifier switches are separate from the SFs and SFFs
16:39:06 * tbachman hands ericano_ an extra 4GB of RAM
16:39:24 * ebrjohn hands ericano_ an extra CPU
16:40:09 <tbachman> demo curse
16:40:14 <repenno> I think the problem with SFC build has to do with those tests that have always failed every now and then
16:40:23 <tbachman> solar flares
16:40:38 <repenno> and that as well
16:40:50 <repenno> I’m wearing my tin foil hat now
16:40:53 <tbachman> lol
16:40:59 <tbachman> I never take mine off
16:41:03 <repenno> and my desk points north, that’s where my power come from
16:41:09 <tbachman> lol
16:41:18 <tbachman> which way does the water turn in your toilet bowl?
16:41:23 * tbachman stops his silly talk
16:41:34 <tbachman> ericano_: is that purple?
16:41:35 <repenno> port a potty?
16:41:58 * tbachman sees green
16:42:06 <tbachman> yellow and blue?
16:42:58 <tbachman> #info ebrjohn says the only thing the classifier does is an L2 to L4 classification and assigns the RSP
16:44:31 <tbachman> #info ebrjohn says he’d like to discuss Beryllium planning, but probably not enough time in today’s meeting
16:44:32 <tbachman> #topic other items
16:44:41 <tbachman> #info ebrjohn added a new section to the SFC wiki — SFC configuration in a nutshell
16:44:56 <repenno> there was a job config change in build 63
16:45:06 <repenno> and then we started to get unstable builds
16:45:24 <ebrjohn> #link https://wiki.opendaylight.org/view/Service_Function_Chaining:Main#The_SFC_Configuration_in_a_nutshell SFC in a nutshell on the SFC wiki
16:45:52 <repenno> I think following the first part of the SFC 101 should be very clear
16:46:07 <repenno> we have lots of material at this point
16:46:08 <tbachman> #info ebrjohn says the IETF hackfest starts this week and continues into next week
16:46:28 <tbachman> #info ebrjohn says the week after that (July 27th-31st) is the ODL summit in Santa Clara
16:48:02 <tbachman> #info ebrjohn says he’ll try to host the meeting during the summit, if it’s feasable
16:49:20 <tbachman> #endmeeting