17:00:28 <ebrjohn> #startmeeting weekly ODL SFC meeting
17:00:28 <odl_meetbot> Meeting started Wed Nov 23 17:00:28 2016 UTC.  The chair is ebrjohn. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:28 <odl_meetbot> The meeting name has been set to 'weekly_odl_sfc_meeting'
17:00:37 <ebrjohn> #chair dgranados
17:00:37 <odl_meetbot> Current chairs: dgranados ebrjohn
17:00:45 <ebrjohn> #info Brady Johnson
17:01:38 <dgranados> #info Diego Granados
17:03:02 <jaicaa> #info Jaime CaamaƱo
17:05:19 <ebrjohn> #topic Non-NSH encapsulation for SFC Carbon
17:05:25 <afredette> #info Andre Fredette
17:08:01 <dgranados> #info Ericsson will start working on a different alternative for NSH encapsulation than NSH (not abandoning NSH, just need something pure open source for its products)
17:08:08 <juanmafg> #info Juanma Fernandez
17:09:30 <dgranados> #info for that alternative, transport between classifier and the first SFF, and also in the transport trunk (i.e. between SFFs) will be vxlan
17:10:21 <dgranados> #info for traffic coming back from the SF to the SFF, the plan is to do reclassification
17:15:22 <dgranados> #info some discussion between afredette and ebrjohn follows on alternative ways (transport-based) to avoid/support reclassification
17:18:49 <dgranados> #info afredette describes a simple use case (virtual CPE) on which SFs only participate in one chain, allowing to avoid reclassification
17:24:25 <dgranados> #info this approach, given a working netvirt classificator, would uses vxlan VNIs in the trunk as SFC encapsulation
17:27:07 <dgranados> #info @ebrjohn mentions the possibility to incorporate that SF behaviour ("single-chain mode") to the model in the SF type
17:31:41 <dgranados> #info @juanmafg states that tricky details about this approach. Other protocols traffic (e.g. dhcp) would use the same service chain, and would end reaching SF's not really expecting it
17:34:56 <ebrjohn> #link https://wiki.opendaylight.org/view/Service_Function_Chaining:Carbon_Release_Plan SFC Carbon release plan
17:37:14 <dgranados> #afredette mentions a mechanism which uses different ports in the SF for handling multiple chains
17:37:23 <dgranados> #info @afredette mentions a mechanism which uses different ports in the SF for handling multiple chains
17:37:59 <ebrjohn> #action afredette will send the requirement to netvirt to support the vxlan transport/encapsulation
17:42:39 <dgranados> #info some discussion follows regarding the "single-chain mode" for SFs. It is clear that the main use case is virtual CPE
17:46:06 <ebrjohn> #endmeeting