15:01:29 <tnadeau> #startmeeting opendaylight-meeting
15:01:29 <odl_meetbot> Meeting started Fri May 27 15:01:29 2016 UTC.  The chair is tnadeau. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:29 <odl_meetbot> The meeting name has been set to 'opendaylight_meeting'
15:01:41 <tnadeau> #subject agenda-bashing
15:01:50 <tnadeau> #topic agenda-bashing
15:03:26 <tnadeau> 1. where is the Web UI?
15:03:37 <tnadeau> 2. Mo's questions about proxy/gerrit Rest API
15:03:52 <tnadeau> 3. possibility of push model for unified dashboard
15:04:17 <tnadeau> 4. meta data proposal (An)
15:06:13 <tnadeau> Mo - question: was there a meeting last week?
15:08:30 <tnadeau> is thanh the only person with credentials to push to the LF server?
15:08:39 <tnadeau> idea is to have a script that updates this setup upon merge
15:08:50 <tnadeau> goal: get base setup asap
15:09:04 <tnadeau> #action - script to update production LF server upon commits
15:09:32 <tnadeau> #action Tom - to sync up with Vasu on exact date to push base UX
15:10:22 <tnadeau> #topic proxy-gerrit Rest API - Mo
15:20:12 <tnadeau> value in normalization/unification of the underlying APIs (gerrit/git/etc...).
15:20:31 <tnadeau> value added in underlying company mappings that are not available from direct underlying direct APIs
15:20:47 <tnadeau> Mo points out that today, the mapping of 1:1 with gerrit is redundant
15:22:15 <tnadeau> An: keeping APIs in place, allows us to incrementally enhance functionality - working in steps to enhance/advance
15:25:41 <tnadeau> #action Tom will ask team about setting a hangout/session next week to work on normalization and analysis of the current Spectrometer APIs
15:27:25 <tnadeau> #optic push model (an)
15:32:29 <tnadeau> #agree Spectrometer is positioned to be a unified dashboard for statistics/views on project "metrics".  Key is to advertise the fact that we are the unified dashboard and welcome others to come and contribute to this project instead of doing their own thing.
15:33:58 <zxiiro> tnadeau: mohzah it will be automated deploy but I need something to deploy first.  we're lacking the webui code!
15:34:51 <tnadeau> back to the push model...
15:36:27 <tnadeau> need an API that allows other projects to push statistics/metrics and have them visualized
15:37:21 <tnadeau> pros: consumers are able to produce their own charts (generic API). This provides a means to a single, unified dashboard.
15:37:28 <tnadeau> cons: might become too "ODL"
15:38:50 <tnadeau> organization is key. we want to add value, but we don't want to make it part of the base package.
15:39:03 <tnadeau> we need to make sure that the customization is optional
15:41:42 <tnadeau> #agree this is a 2.0 feature
15:41:52 <tnadeau> #action tom will add a Trello card to the 2.0 stack
15:43:00 <anipbu> https://git.opendaylight.org/gerrit/#/c/39290/
15:43:08 <mohzah> https://git.opendaylight.org/gerrit/#/c/39290/
15:45:24 <odp-gerritbot> A comment has been added to a proposed change to spectrometer: Use VERSION file to represent spectrometer version  https://git.opendaylight.org/gerrit/39290
15:46:11 <odp-gerritbot> A comment has been added to a proposed change to spectrometer: Use VERSION file to represent spectrometer version  https://git.opendaylight.org/gerrit/39290
15:47:26 <tnadeau> #topic meta data proposal (An)
15:49:09 <tnadeau> proposal: have each project have its own meta data BUT some projects are in archive mode and will not allow any additional commits to those projects (or projects are simply inactive), so in these cases  we have a separate metadata file or location so that metadata first looks into project metadata, and if it can't find it we have a default.
15:50:52 <zxiiro> I disagree, we can ask tsc for permission to merge metadata
15:51:00 <zxiiro> let's not make this complicated
15:51:11 <tnadeau> question: what min info do we need in the default files?
15:51:31 <tnadeau> super power is the key! 8)
15:52:31 <tnadeau> should get a slot at the next TSC meeting to raise this point?
15:52:31 * zxiiro just passed customs :)
15:52:50 <tnadeau> and explicitly ask for permission to override this specific thing?
15:53:10 <zxiiro> we should have the metadata well defined before we bring it up to the tsc
15:53:18 <zxiiro> so they we only edit it once
15:53:38 <tnadeau> good point. once this works and we can show it (demo), then we can ask the TSC since they have a functional resource
15:53:43 <tnadeau> functional example
15:53:51 <zxiiro> so I would recommend folks respond to the metadata thread that is currently going
15:54:00 <tnadeau> #agree lets wait for 1.0 to be finished
15:54:12 <tnadeau> (or at least next week's call when everyone is on)
15:54:40 <zxiiro> in the meantime we can test the metadata in spectrometer as an example
15:54:53 <zxiiro> one project example i mean
15:55:25 <zxiiro> since we control that project. we can also test other projects we are committers on like releng/builder
15:56:27 <tnadeau> good point
15:57:02 <tnadeau> my point is that if projects do not choose to participate in spectrometer, we either do not display their info, or display it in some default format (which is likely not ideal)
16:01:55 <tnadeau> An asked an important question: what defines what a project is?  today we require a git repo, but there are plenty of projects that do important work that don't push any code to git
16:02:22 <tnadeau> super power does not solve these problems that are solved with some form of fall back meta data
16:05:25 <zxiiro> what project doesn't have a git repo?
16:06:24 <zxiiro> I also don't see how a project could possibly opt out of spectrometer
16:07:02 <zxiiro> git repos are public they can't stop openhub and github from recording stats
16:07:16 <tnadeau> #endmeeting