14:56:12 <tnadeau_> #startmeeting opendaylight-spectrometer
14:56:12 <odl_meetbot> Meeting started Fri Apr  8 14:56:12 2016 UTC.  The chair is tnadeau_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:56:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:56:12 <odl_meetbot> The meeting name has been set to 'opendaylight_spectrometer'
14:56:21 <zxiiro> tnadeau_: I think Phil said he was going to join us
14:56:25 <zxiiro> tnadeau_: let me ping him to make sure
14:56:26 <tnadeau_> if you can, jump on the webex now so that we can get thought stuff
14:56:30 <vasya10> ok joining
14:56:58 <tnadeau_> yes - and Dan from HP (Stangel, Dan <dan.stangel@hpe.com>)
14:57:13 <tnadeau_> he contacted me yesterday about joining/using the code from here for some internal stuff they're doing
14:59:44 <vasya10> meeting ended ?
14:59:58 <tnadeau_> webex decided to close the meeting - not sure
15:00:00 <tnadeau_> im restarting
15:00:16 <anipbu> webex is not avail
15:00:22 <vasya10> im in now
15:00:38 <vasya10> ah.. it ended again
15:00:39 <zxiiro> I think when you do the hostkey thing when another meeting is in progress it kicks everyone off
15:00:44 <vasya10> yes
15:00:53 <tnadeau_> sorry when I enter the host key, webex says, "you have too many simultaneous meetings going. this meeting will end in 30 seconds..."
15:01:05 <vasya10> yes
15:01:09 <vasya10> happened last time too
15:01:16 <vasya10> i think Phil is running another mtng at the same time
15:01:21 <zxiiro> yeah there's 4 meetings scheduled at this time
15:01:24 <vasya10> (or someone else)
15:01:28 <tnadeau_> ok no host key entered
15:01:43 <tnadeau_> we need to get our own host  key as we record these
15:01:47 <zxiiro> neutron, NIC, and ODL Performance
15:01:59 <tnadeau_> please rejoin the webex everyone
15:04:40 <tnadeau_> #topic agenda bashing
15:04:55 <tnadeau_> #topic schedule
15:05:23 <tnadeau_> where are we on the web and server sides?
15:05:43 <tnadeau_> vasu details the web side. getting initial env setup in jenkins so we have a CI build
15:06:10 <tnadeau_> no blockers on this; matter of getting it working.
15:06:35 <tnadeau_> thanh - we have verify jobs on the py side right now.
15:06:44 <tnadeau_> thang - we have a static server for spectrometer but its not been completely setup
15:07:37 <tnadeau_> #action thanh will hopefully get this serving by 2 weeks from now
15:08:05 <tnadeau_> https://trello.com/b/fIVlZ0M5/opendaylight-spectrometer
15:13:26 <mohzah> GET /git/commits/:modulename?db=true
15:13:26 <mohzah> GET /git/commits/:modulename/:branchname?db=true
15:19:11 <anipbu> https://wiki.openstack.org/wiki/Governance
15:19:24 <tnadeau_> #topic openstack governance
15:19:36 <tnadeau_> Should we include this in ODL (i.e.: inside spectrometer)?
15:21:29 <tnadeau_> pros - centralized repo of this information
15:21:54 <tnadeau_> cons - information spread around. initially this needs to be manually maintained BUT we can initiate a process where projects update spectrometer
15:23:11 <tnadeau_> cons - we must not make this ODL-specific
15:27:36 <tnadeau_> idea - create a special entry in gerrit by the project itself
15:28:04 <tnadeau_> dynamically drive this data. if its in a static file then the file has to be managed
15:28:12 <tnadeau_> vasu points out issues around versioning
15:29:02 <tnadeau_> good point: versioning and branching information is kept in gerrit
15:29:22 <tnadeau_> cons - getting projects to push all this info
15:30:17 <tnadeau_> An concerned about participation
15:30:31 <tnadeau_> thanh/tom - if they don't respond, the TSC can get involved.  until then, no data
15:32:06 <anipbu> project.git/metadata/governance.json
15:32:24 <vasya10> +1 its a good stat to show who is not being part of governance
15:34:27 <tnadeau_> Mo - what is included in the JSON file?
15:34:39 <tnadeau_> an - making from gerrit project ID -> project name
15:34:42 <tnadeau_> also list of active committers
15:34:52 <tnadeau_> emails other contact info
15:35:28 <tnadeau_> PTL(s) are included
15:35:44 <tnadeau_> "governance info" includes more information that you can glean from just the project files/contributions
15:35:52 <tnadeau_> this also covers inactive participants
15:36:39 <tnadeau_> mo - point is that whatever we can get dynamically we should
15:38:15 <tnadeau_> thanh - my opinion is that we should use Yaml instead of JSON
15:38:53 <tnadeau_> an - i prefer JSON but...
15:39:07 <tnadeau_> vasu - prefer JSON but not much change, so ok w yamh
15:39:31 <zxiiro> http://yamltojson.com/
15:40:49 <tnadeau_> tom - is it going to be easy enough to parse/convert yaml <---> json ?
15:40:54 <tnadeau_> yes
15:41:29 <tnadeau_> darien - votes for YAML. breaks the tie!
15:41:48 <tnadeau_> #agree we use YAML as the file format for governance file
15:42:52 <tnadeau_> an - do we have something in spectrometer to do this?
15:43:02 <tnadeau_> thanh/tom - python already does this natively
15:44:00 <tnadeau_> it is possible to pass a config file to the server. in this file we need an address to the YAML file.  right now the YAML file is populated with a list of repos and a default addr.
15:44:28 <tnadeau_> Mo wants to delete the contents of the file and leave as an example there only (commented out) so that those that want to work with spectrometer passes a config file at runtime
15:45:12 <tnadeau_> thanh - the user should pass a -c parameter BUT if the user doesn't pass that we should check /etc/spectrometer/... for a default
15:45:37 <tnadeau_> #agree this is the way to go
15:45:46 <tnadeau_> #action mo will fix this in the next commit
15:47:52 <vasya10> brb
15:50:38 <vasya10> back
15:57:37 <tnadeau_> #action goal for next week is to have data for projects and data. per project commits, per commiters
15:59:38 <tnadeau_> #topic setting a data for first  release
16:01:42 <tnadeau_> TWS on May 2 is our final target for release .1
16:02:07 <tnadeau_> open stack summit is may 2
16:02:10 <tnadeau_> prototype push 4/22
16:05:34 <tnadeau_> #endmeeting