16:01:22 <anipbu> #startmeeting spectrometer meeting
16:01:22 <odl_meetbot> Meeting started Fri Jan 15 16:01:22 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:22 <odl_meetbot> The meeting name has been set to 'spectrometer_meeting'
16:01:41 <anipbu> #topic agenda bashing
16:01:59 <anipbu> #chair tnadeau_ zxiiro
16:01:59 <odl_meetbot> Current chairs: anipbu tnadeau_ zxiiro
16:02:11 <anipbu> #link https://trello.com/b/fIVlZ0M5/opendaylight-spectrometer <- trello board
16:07:14 <anipbu> #info nodejs
16:07:24 <tnadeau_> #action agenda items discussion. An suggested agenda to wrap up node.js issues, how we collect issues from git/gerrit, open discussion
16:07:47 <tnadeau_> #action agenda items: discuss trello board too
16:08:01 <anipbu> #undo
16:08:01 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1fd0410>
16:08:03 <anipbu> #undo
16:08:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x20d3a10>
16:08:29 <tnadeau_> #info agenda items discussion:An suggested agenda to wrap up node.js issues, how we collect issues from git/gerrit, trello board discussion followed by open discussion
16:08:29 <tnadeau_> #info
16:08:52 <tnadeau_> #topic node.js
16:10:12 <tnadeau_> #info issue: where to host the node.js server. do we use it just for dev?  package management or just to make things easier for dev. Afterwards we compiler the entire thing into a .js script file and serve it that way.
16:10:34 <tnadeau_> #issue one of the downsides to this approach is that many JS libs require npm to built.
16:11:04 <tnadeau_> #info advantages to node.js native is isomorphic code execution
16:11:23 <tnadeau_> #info npm package management is an advantage
16:12:48 <tnadeau_> #info @Vasu and @tom agreed that the standalone node.js option was preferred
16:14:28 <tnadeau_> #info Are there any issues in the ODL backend to pushing a precompiled JS versus a node.js?
16:15:03 <tnadeau_> #action @Tom to ask Andrew Grimberg about preferences (or security issues) of node.js versus complete package
16:15:32 <tnadeau_> #info @an assumes we push a binary to production
16:17:05 <mohzah> note from previous meeting minutes "downside of not using node.js in production is loosing isomorphic capability"
16:17:25 <tnadeau_> thanks for correction - sorry for typo
16:17:46 <tnadeau_> tom's explained the way we did spectrometer previously
16:18:30 <tnadeau_> @an has ideas for how to do this differently
16:20:11 <tnadeau_> #action @tom to contact Andrew@lf and CC our distro list to get his inputs
16:21:27 <tnadeau_> #topic multi language project support
16:21:37 <tnadeau_> @an asked to reuse existing java functionality
16:24:28 <tnadeau_> @tom raised two issues: 1) multiple moving parts to maintain 2) java as a lang vs python might be more difficult for some to work on
16:24:44 <tnadeau_> 3) project is a bit more complex, might be less inviting for people to contribute to in the future
16:25:57 <tnadeau_> @mo - agrees with simplicity
16:26:22 <tnadeau_> @carol - py would be easier for me
16:27:00 <tnadeau_> @an agrees points are valid, but wants to re-use existing dashboard code
16:27:42 <tnadeau_> @an backend will not change much. just processes and pushes data to data store
16:29:50 <tnadeau_> @an we are written in java, a release dashboard that collects data. produces a "quality of projects" concept.  from 1 dashboard you can get a glimpse of all 52 projects: bugs, sonar reports, j  unit and robot tests
16:30:03 <tnadeau_> @mo when the data is collected does the java code store the data in a DB ?
16:30:07 <tnadeau_> @an yes
16:30:55 <tnadeau_> @an addresses issue of multi back ends/languages - it is more complex but we loose ability to pull in whatever gets the job done
16:38:59 <tnadeau_> #action @an to send out email w information about how to access the existing java-based backend
16:43:26 <tnadeau_> #agree all code except for the back end is python
16:43:51 <tnadeau_> #agree investigate the existing java-based data store/back end to see if its worth recycling, or redoing a new one
16:44:26 <anipbu> #link https://trello.com/b/fIVlZ0M5/opendaylight-spectrometer <- trello board
16:53:27 <tnadeau_> #info we modified the trelllo board to update things
16:55:35 <anipbu> #topic cookies
16:55:36 <anipbu> #endmeeting